The Witcher 3 driver

Discussion in 'Videocards - AMD Radeon Drivers Section' started by oGow89, May 11, 2015.

  1. DiceAir

    DiceAir Maha Guru

    Messages:
    1,368
    Likes Received:
    15
    GPU:
    Galax 980 ti HOF
    AMD should stop trying to get hairworks to work on amd gpu's and first get the game to run smooth without it on.
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Well said.
     
  3. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    Unless Intel buys NVIDIA. Although then things would be scary, unless Samsung grabs AMD too.
     
  4. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    That's quite correct, they should have at least posted a Crossfire profile for people with multiple GPUs. The game runs fine in single GPU configurations, honestly.

    I believe that abandoning the driver CAPs was one of the mistakes they made. Now they have to push a whole new driver for a new game.
     

  5. niczerus

    niczerus Master Guru

    Messages:
    290
    Likes Received:
    3
    GPU:
    MSI GamingX 580 4GB
  6. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
  7. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
  8. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    I get the same with 15.4, 1018, 1023.0, 1023.3 so I don't think it matters. 1.03 made it a little more playable though.
     
  9. niczerus

    niczerus Master Guru

    Messages:
    290
    Likes Received:
    3
    GPU:
    MSI GamingX 580 4GB
    15.4 beta i try reduce all settings to low/off but nothing change , fullscreen , windowed mode , with the patch 1.02 the game runs better(a little better) , i dont have a single crash , but is unplayable the game now :/ .
     
  10. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Update to 1.03 to reduce it further. I can literally make the setting all low with 800x600 resolution and the game still stutters. Exactly like FarCry4 was.
     

  11. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    Weird. I don't get ANY stutter, except for the first 30 seconds or so after the game loads. I'm using the 1023.3 Vbs drivers posted here. My settings are everything on Ultra with HBAO+, except Foliage Draw Distance, Grass Density and Shadows, who are on medium.

    I have the 30fps lock enabled in the game, in-game vsync off and antialiasing off, and I'm downsampling from 2560*1440 to 1080p. I also have double vsync enforced through RadeonPro.
     
  12. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Yeah the initial stutter after the game loads, I get that. It's just the stutter happens all the time, every few seconds. I will play with Process Lasso a bit and see what happens. It really shouldn't be happening on my system though... I can't see any reason for it looking at CPU/GPU/HDD usage, etc...
    I learnt not to adjust The Witchers 3 affinity. It's useless.
     
  13. Supertribble

    Supertribble Master Guru

    Messages:
    869
    Likes Received:
    118
    GPU:
    1080Ti/RadVII/2070S
    I get stutter but it's more of a frame pacing issue, which I think is normal for this game because I tried a few Nvidia cards (670 960) and it was exactly the same. My 290 is much faster than both of those cards with Witcher 3 which is a nice change because it sucks for Far Cry 4 and other games I want to play.
     
  14. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    I would suggest trying the framelock and vsync through RadeonPro.
     
  15. eshk

    eshk Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    Powercolor 280x 3gb
    I'm on the same boat. Far Cry 4 was literally the only other game I had this issue with, and yet to go past the prologue. Hell Unity runs better than both of these. TW3 is a great game, but in terms of performance, after countless nauseating breaks, I can safely say its the worst game I've ever sunk 20+ hours into.
     

  16. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    It's weird how others either don't have it or don't see it with similar or worse systems.
     
  17. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    When that comes to that, the next thing to check usually is (with that order):
    -Power profiles
    -Parked Cores
    -Resident Antivirus Software
     
  18. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Bitsum.
    Unparked.
    None.
     
  19. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,928
    Likes Received:
    793
    GPU:
    Inno3D RTX 3090
    Damn.
     
  20. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,643
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Yeah. There's no sign of a hardware issue. CPU is under used (20% or less with no spikes) GPU usage doesn't spike. HDD isn't even used when the stutter occurs (maybe when the game first loads). I tried everything I could possibly try when FarCry4 was released so I could play it. Eventually what fixed it was game patches and driver updates. That game runs fine now with no hardware adjustments or OS changes. Everything is the same pretty much since it was released.
     

Share This Page