Just downloaded final creators and game mode is gone?

Discussion in 'Operating Systems' started by HonoredShadow, Oct 17, 2017.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,166
    Likes Received:
    36
    GPU:
    EVGA GTX 1080 Ti SC2
    Mine shows exactly like that screenshot. It does say that Game Mode is supported so I assumed that means it is enabled and that there's no way to optionally disable it.

    However, my understanding is that Game mode has to be enabled on a per-game basis via the Game bar (accessed on my PC via the Guide button on my Xbox One controller) so it is in effect disabled by default unless you check the box for the game while it is running.

    Is that correct?
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,166
    Likes Received:
    36
    GPU:
    EVGA GTX 1080 Ti SC2
    P.S. What are the fullscreen optimisations that are supposedly enabled by default for all executables, e.g. right-click on a game executable then select Properties > Compatibility and you'll see there is an option to DISABLE Fullscreen Optimisations (which suggests they are on by default).

    I have come across an odd issue with a few Unity engine game that lock to 22-24 fps in the default borderless fullscreen mode, e.g. Road Redemption, Cuphead (a 2D game of all things!) and Dungeons 3. Forcing proper fullscreen mode via the -windowed-mode exclusive launcher command fixes the issue but I've found that disabling fullscreen optimisations also works too.

    Has anyone else come across this issue?

    It only seems to affect Unity engine games so far and then not all of them (Ori and the Blind Forest, The Last Tinker: City of Colors and Oddworld: New 'n' Tasty all work fine for example in their default borderless fullscreen modes).
     
  3. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    According to MS there are some games where they have enabled Game Mode by default but from my limited testing in the last couple of days I haven't run into any such games. So essentially this is correct, albeit with a remark that some games may be in MS's "white list" of titles which should run with Game Mode On.

    This is an option of emulating exclusive fullscreen for D3D11 games. With its on when you request EFS in such games you get something more like what UWP games have - a borderless window which bypass the DWM in fullscreen mode. It's easy to see if it's working by invoking the Game Bar with Win+G - it won't appear if a game is running in a "true" EFS.
     
  4. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    10,230
    Likes Received:
    224
    GPU:
    1080Ti H20
    For me, I only enabled it for two games.

    Only those two showed up in directinput reg.
    There's also a reg within those that says 'last game played.'

    Interestingly I found a way to bypass that.

    I've always disabled Fullscreen optimizations.
    Win G would flash screen and do nothing.

    Simply, alt enter to go to window mode then win g works; then you enable game mode and go fullscreen again with alt enter.
    After that, win g is working even though it's not a borderless windowed mode.
     

  5. EdKiefer

    EdKiefer Maha Guru

    Messages:
    1,261
    Likes Received:
    1
    GPU:
    MSI 970 Gaming 4G
    That's interesting on that option with exe to "Disable full-screen optimizations".
    I did quick look an all my exe have it not checked, except for BF1, I don't remember doing that, I am going to toggle it unchecked an see what happens if any.
     
  6. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    This is a bit weird and means that the game doesn't run in an actual exclusive fullscreen after that.
     
  7. -Tj-

    -Tj- Ancient Guru

    Messages:
    14,029
    Likes Received:
    83
    GPU:
    ZOTAC 980Ti Amp!Ext
    Now wddm 2.3 uses some kind of fake fullscreen with DSR.

    Just tried USF4 and pressed X sign on my controller and it opend up game bar mode.
    [​IMG]
     
  8. Dragondale13

    Dragondale13 Maha Guru

    Messages:
    1,089
    Likes Received:
    10
    GPU:
    ZOTAC 1070 AMP!
    Ok so question!?
    If game mode i.e. gamedvr reg key is off, but I don't add "allowgamemode" reg key.

    Will the auto profile kick in?
     
  9. Apparatus

    Apparatus Master Guru

    Messages:
    290
    Likes Received:
    7
    GPU:
    Aorus 1080 ti
    Gaming

    • The Game Bar now has an option to enable Game Mode for a specific game
    • Game Bar now allows you to make screenshots of games running in HDR
    • Screenshots of games running in HDR are now tone mapped to SDR and saved in PNG
    • Bitrate changes during a game broadcast to Mixer are now smoother
    • You can now specify the language you speak in a Mixer broadcast
    • Game Mode will now provide better performance on some popular configurations like 6 and 8 core CPU machines
    • Broadcasting using game-only audio is now a setting under "Broadcasting"
    • "Audio settings" has been renamed Game DVR in the Game bar
    • Game DVR-settings have been moved to the Game DVR-page in Game bar
    • Xbox Networking has been added as a new page, showing you details about your network
    • Game Mode is now enabled by default for some games
    • "TruePlay" has been added
    found that info in a detailed list with all the changes the Creators updates brings :
    https://www.reddit.com/r/Windows10/comments/76t8r4/windows_10_fall_creators_update1709_megathread/
     
    Dragondale13 likes this.
  10. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    What's "auto profile"? If you're asking if Game Mode would be enabled or not in games which MS whitelisted then this can only be checked by launching such games - and so far I haven't found even one in which Game Mode is enabled by default.
     
    Dragondale13 likes this.

Share This Page