Creative Launches a BlasterX AE-5 PURE edition

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Dec 14, 2017.

  1. Raider0001

    Raider0001 Master Guru

    Messages:
    425
    Likes Received:
    17
    GPU:
    Powercolor RX 6800
    Try resetting CMOS battery or flash new bios
     
  2. Octopuss

    Octopuss Master Guru

    Messages:
    887
    Likes Received:
    56
    GPU:
    -
    Is that a joke?
     
  3. Raider0001

    Raider0001 Master Guru

    Messages:
    425
    Likes Received:
    17
    GPU:
    Powercolor RX 6800
    no, my motherboard did multiple reboots after installation so that means something
     
  4. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,156
    Likes Received:
    70
    GPU:
    XFX 5700 XT Thic II
    yea because that's odd, even without the drivers installed, windows should had at least installed the stock drivers for the AE-5 from there servers.

    In fact that was the first thing it did for me when I got my AE-5 when it came out. Windows couldn't wait to install it's own drivers for it. Sounds like you was unlucky and got sent an DOA card it happens sadly. Most like you may have to RMA the card to get it replaced. That what it sounds like to me, that same thing can happen with any hardware too.

    If the latest drivers off the site is also doing the same thing. Then like i said most likely you got an dud.


    That also odd, I only had to reboot once and that was after I installed the driver.
     

  5. Octopuss

    Octopuss Master Guru

    Messages:
    887
    Likes Received:
    56
    GPU:
    -
    I've just installed the card in my wife's PC and it's detected just fine. Could be something messed up in my registry, but I can't tell. And I don't feel like reinstalling the damn OS right now.
     
  6. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,268
    Likes Received:
    1,012
    GPU:
    Aorus 3090 Xtreme
  7. Raider0001

    Raider0001 Master Guru

    Messages:
    425
    Likes Received:
    17
    GPU:
    Powercolor RX 6800
    I meant a card in to the PCI-E slot installation and first PC boot - card is complicated enough to force my mobo a couple of reboots before it was ready to finally boot the system
     
  8. Apparatus

    Apparatus Master Guru

    Messages:
    375
    Likes Received:
    37
    GPU:
    Aorus 1080 ti
  9. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,156
    Likes Received:
    70
    GPU:
    XFX 5700 XT Thic II
    ineresting enough i seen people use that lighting kit on there motherboards, since the strip needs 5v to be used, I kind of wondering if another RGB strip from another brand that's 5v will work off the card. Since if some one wanted to add 3 more to the card without paying that much for the kit.

    One thing i do know that the card will only support up to 4 RGB strips, since I was curious and message them about it.
     

Share This Page