YES! Got Physx running! (HD4870 and 9600GT)

Discussion in 'Videocards vs General Purpose - NVIDIA Ageia PhysX' started by Keitosha, Feb 20, 2011.

  1. Keitosha

    Keitosha Ancient Guru

    Messages:
    4,870
    Likes Received:
    111
    GPU:
    Vega56 8GB
    Yes! I got a single slot 9600GT 512MB (PCI-e) today and i got Physx running.
    The card is running @ PCI-e 2.0 x1 atm because i had to mod my PCI-e x1 slot to make the card fit. Will put in another mobo later which has more x16 slots.

    I ran Batman: AA today with high Physx on and it played smoothly, same with Mirror's Edge.

    Despite the card running at just x1, i'm quite surprised in handling Physx quite well. Can't wait to run it @ x16! :banana:

    Didn't have to mod anything. I'm using Forceware 257.15 Beta which had a "bug" making it possible again using Physx with AMD cards.

    [​IMG]
    [​IMG]
     
  2. sykozis

    sykozis Ancient Guru

    Messages:
    21,791
    Likes Received:
    1,051
    GPU:
    MSI RX5700
    9600GT was a good card in it's day....when it worked. Lots of complaints of Black screens....but they performed well until the black screen happened.
     
  3. Keitosha

    Keitosha Ancient Guru

    Messages:
    4,870
    Likes Received:
    111
    GPU:
    Vega56 8GB
    We will see how it turns out. Got the card for a few euro's. It's an EVGA 9600GT Superclocked card. It does a good job, even at PCIe x1 lol.

    There's only one title having trouble or in which Physx isn't working: Mirror's Edge. Slows down real bad when glass shatters. The flags and other garbage floating around isn't a problem, but when some glass windows or other stuff breaks, its 1 a 2 fps for me.

    Other titles are working fine like Batman and the Physx maps for UT3.

    I couldn't try Sacred 2 all of a sudden. The game was always a crashfest. Upon changing any setting and hitting apply, a ctd occurs. :bang:
     
  4. sykozis

    sykozis Ancient Guru

    Messages:
    21,791
    Likes Received:
    1,051
    GPU:
    MSI RX5700
    I tried to play the demo for Sacred 2....didn't impress me
     

  5. 1boolet

    1boolet Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    5970+5850GPU+gf460gtx PPU
    im playing on hybrid physx crossing 5970+5850 with 460 gtx for ppu in pci-e 2.0 8x

    not working in Mirror's Edge

    in cryostatis, metro, batman,mafia, two worlds and dark woid its working awesome

    also working on fluidmark and 3dmark vantage...

    I have already finished Mirror's Edge twice and I don't care about those 2 efects...
     
    Last edited: Feb 24, 2011
  6. Keitosha

    Keitosha Ancient Guru

    Messages:
    4,870
    Likes Received:
    111
    GPU:
    Vega56 8GB
    It is strange. Is ME using a different Physx engine or something? UT3 and Batman are working perfect and are using Unreal 3 engine, just like ME.

    But ME seems troubled with Physx anyway, even when using only an NV card. lol
     
  7. 1boolet

    1boolet Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    5970+5850GPU+gf460gtx PPU
    I think u need stealth patch or something like that...


    Im playing mafia2 now and I think its awesome...
     
  8. 1boolet

    1boolet Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    5970+5850GPU+gf460gtx PPU
    Mirror's Edge also worked fine after deleting its PhysXCore and PhysXDevice dlls

    I have no more physx problems with my setup...

    the only one was this

    :biggun:
     
  9. lmimmfn

    lmimmfn Ancient Guru

    Messages:
    10,445
    Likes Received:
    123
    GPU:
    AorusXtreme 1080Ti
    ME only supports software physx not hardware physx, a lot of games are like that, besides is there really any need to improve ME performance?
     
  10. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    Mirror's Edge has GPU physx.
     

  11. 1boolet

    1boolet Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    5970+5850GPU+gf460gtx PPU
    after deleting those files setup runs ME briliant

    before deleting those files it performed like that :puke2:
     

Share This Page