Xperia Z4 Tablet - CPU Issues

Discussion in 'Tablets and Smart Phones' started by dk_lightning, May 8, 2017.

  1. dk_lightning

    dk_lightning Maha Guru

    Messages:
    1,329
    Likes Received:
    0
    Looking or some input on a odd issue I am having with my Z4. It is on contract with O2 UK and is well in warranty as I have only had it about 3 months.

    Anyway. When I got it I ran the software update to get Android 7.0 installed.

    When viewing system specs I noticed that CPUZ showed the Snapdragon 810 running at 1.56Ghz on both clusters and the last 4 cores showed as sleeping.

    Benchmarks like geekbench confirmed that something was hinky. with those 4 cores. Sinlge threaded score matches the 810 scores I see online but the multicore score is taking a massive hit.

    So, I decided to do a factory reset but this did not help. Next stop was to go back to an older version of Android so I went hunting for a firmware file that was Android 5 or 6. I found one and installed that and this time everything seemed as it should.

    CPUZ was showing 4 cores at 1.5Ghz and another 4 at 2Ghz as it should and the last 4 cores where active. Geekbench confirmed all was fine with normal multicore scores.

    So, Back to the latest Android 7.0 aaannnnd same issue as before. What on earth is going on here with 7.0? Something seems to be stopping 4 of the cores from working?

    I would like to try and fix this my self if I can as it does seem to be a software issue vs hardware.

    Its a pain having this problem as most things are a bit laggy and gaming is just not possible.
     
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    17,747
    Likes Received:
    9
    Check performance mode settings, pretty sure (Not 100% sure) this is Nougat 7.0 specific and not just Samsung, but there are different performance modes you can choose for power saving, maybe Nougat defaults to something that saves power by disabling cores?
     
  3. dk_lightning

    dk_lightning Maha Guru

    Messages:
    1,329
    Likes Received:
    0
    Only settings like that on Sony devices or at least mine is Stamina mode witch is off.

    I did try turning it on to see what it do to cpu cores/speed and nothing.
     
  4. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    17,747
    Likes Received:
    9

  5. dk_lightning

    dk_lightning Maha Guru

    Messages:
    1,329
    Likes Received:
    0
    Thats for the Z4 phone but I am assuming they use the same firmware for all z4\810 devices just tweak some bits for tablet others for phone.

    I hope there is a fix soon then!
     

Share This Page