XP takes ages to get to the welcome screen

Discussion in 'Operating Systems' started by Jimgeruk, Jan 19, 2011.

  1. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    20
    GPU:
    2xTitan XM@1590Mhz-CH20
    Oh Sorry i didnt know that about SSd drives:)
     
  2. Cambria

    Cambria Banned

    Messages:
    626
    Likes Received:
    0
    GPU:
    8800GTS 320MB
    Im curious. I dont know anything about SSDs and the first time I heard about them was right here, but why would defragging them wear them more? What exactly does defragging do thats harmful to them?

    I was looking into SSDs and wondering if I should get one, but Im not sure now. I have a ball defragging my HDDs all the time :p
     
  3. Pzykotik

    Pzykotik Ancient Guru

    Messages:
    2,569
    Likes Received:
    0
    GPU:
    ZOTAC RTX 2070 AMP
    Stay on topic. Read the forum to find out why you shouldn't defrag SSD's.
     
  4. Jimgeruk

    Jimgeruk Master Guru

    Messages:
    317
    Likes Received:
    0
    GPU:
    Radeon HD 4850
    OK, so here's what I tried. I know about SSDs and defragging, and since this is a pretty recent install of Windows I don't think that MFT fragmentation it likely to be a problem, particularly on an SSD when even reading fragged files will be way faster than non-fragged files from an HDD. But I have diskkeeper, so I ran a boot-time defrag with check disk for good measure. No difference.

    Since the SSD's firmware has garbage collection, hopefully the defragging etc won't be a big issue.

    I also tried replacing ntkrnlpa.exe - I really wish I hadn't! Windows didn't want to boot. Luckily Safe Mode worked, and I have a second PC (an i5 running Win7, so I know how much nicer 7 is than XP :)) and so was able to google the problem. Turns out that you can't just simply replace ntkrnlpa.exe - there's a multi-core CPU version called ntkrpamp.exe that you ned to rename to ntkrnlpa.exe. Luckily that's done the trick and I'm back to booting in normal mode. But I still have the 80-second wait.

    I also tried uninstalling the AMD CPU driver as it was the driver that loads after the delay, but that hasn't made any difference. I'm also not sure whether I need to bother reinstalling it either, as XP still detects 2 CPU cores.

    Hmm, not sure what to try next.

    I'm dubious about the .Net packs, and in Services they don't even show up (the v2 and v4 do on my Win 7 PC, but not this XP one), and I don't want to start messing about with the .Net installations and updates.

    Detection, is that prog you linked to actually any use? On the face of it it sounds like one of those "download me and I'll tell you your PC has loads of problems that only I can fix once you've paid for the full version" things. But with the lack of alternatives I could try it I suppose. I may now be into the realms of unplugging stuff to see whether that makes a difference in the boot time.

    Thanks for all the suggestions so far. If anyone has anything else though then please shout. Thanks!
     

  5. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]


    well you shouldn't have .net 4 by default, but im pretty sure you have .net 20,

    check if there is such service (Microsoft .NET Framework NGEN v2.0.50727_X86) and disable it, if not then it doesn't matter.

    and it wont screw anything, just try and test it to see if its the cause..
     
    Last edited: Feb 5, 2011
  6. Jimgeruk

    Jimgeruk Master Guru

    Messages:
    317
    Likes Received:
    0
    GPU:
    Radeon HD 4850
    What I have in Services is Microsoft .NET Framework NGEN v4.0.30319_X86

    Right now, it's set to automatic startup, but it's not started. So I'm guessing that it won't start until I actually need it - so will it make any difference to disable it?

    What do you reckon?

    Oh, and I tried that Soluto prog too, but it only looks at stuff that loads after you log into Windows, so it's not what I'm looking for unfortunately.
     
    Last edited: Feb 6, 2011
  7. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    yea sry i mixed up i didnt disable it, only set to manual.. but you can have net 2.0 disabled.


    Btw if its set to auto it will start then stop later.. its just this transition when it starts that it can slow things down.. even if you're not using it.


    set it to manual and test.
     
  8. Altazimuth

    Altazimuth Maha Guru

    Messages:
    1,307
    Likes Received:
    2
    GPU:
    Sapphire Vapor-X 5870
    Last edited: Feb 7, 2011

Share This Page