Xfx 9800gt problem

Discussion in 'Videocards - NVIDIA GeForce' started by fanxl1908, Jan 22, 2012.

  1. fanxl1908

    fanxl1908 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    XFX / 9800GT / 512MB
    CPU: AMD Athlon 64 X2 3800+ 2.0GHz
    Graphics Card: XFX 9800GT 512 MB
    OS: Windows 7 32-bit
    RAM: 2 GB
    PSU: 400 W or more

    Hey there. I recently found a problem with my 9800GT. I have it for a year or more and it worked fine but yesterday when i tried to play a game (PES 2012) which I have played many times without problems it crashed and i had a BSOD.so i restarted it and when it opened it got full of zeros and false pixels.
    I've managed so far to flash new BIOS both to system and to vga, uninstall drivers and reinstall, clean the pc case and vga with air, clean the cooler of the card...
    The system currently starts and works but in the motherboard logo when opening the image is full of some white pixels. Apart from that, the windows works, but I get no aero effects, i can't get correct vga specs neither from NVIDIA, I can't control the card from NVIDIA CP cause it says no nvidia gpu connected and when i use device manager to check its options, it says "Windows stopped this device because it reported problems (Code 43)". But it works, though not at all correctly

    Please help me the card worked fine till now and just opening a game made it malfunction...
     
    Last edited: Jan 22, 2012
  2. morbias

    morbias Don TazeMeBro Staff Member

    Messages:
    13,427
    Likes Received:
    36
    GPU:
    -
    If you get screen corruption at the BIOS screen then the card is almost certainly broken. You might be able to resurrect it by baking it in an oven (you might want to google it and read up on how to do that first though).
     
  3. fanxl1908

    fanxl1908 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    XFX / 9800GT / 512MB
    Thanks but before trying that, I thought maybe there would be a safer method.
    Actually, I only get partial screen corruption after the VGA's BIOS has been shown. Then "Windows is Loading" is not corrupt and after windows is loaded the screen's image is not corrupt, but I can't get any aero effect and the rest that i've explained above...
     
  4. JJayzX

    JJayzX Master Guru

    Messages:
    476
    Likes Received:
    13
    GPU:
    Evga RTX2070XCUltra
    Re-seat the card but first check the slot on the mobo and the pins on the card are clean before putting it back in.
     

Share This Page