X99 rig going under water eventually

Discussion in 'General Hardware' started by fantaskarsef, Feb 8, 2015.

  1. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,856
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    I don't like you either. Have a nice day.
     
  2. nm+

    nm+ Don Cappuccino Staff Member

    Messages:
    10,422
    Likes Received:
    17
    GPU:
    old
    Girls girls, you're all pretty.
    I'd lock this, except it isn't the OP's fault. Next non-helpful post gets a ton of points.
     
  3. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Uhm okay.
    Well I've completed the list so far, I'll be ordering either later today or the latest, tomorrow. Can't wait for stuff to get here! Thankfully my credit card's limit is big enough :D
     
  4. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    I've ordered my parts, and hope they get here sometime, that's always a pain in the ass. I had to order almost everything from Germany... either it's cheaper and thus making sense to bundle in one big order from there, or simply not available in Austria.

    But god, I hate that they only ship things with UPS, DHL, GLS... I hate it, it's highly unflexible, unfriendly to the customer, and it costs too much money as to let me feel any real gain. I won't order simple biocide for €6,50 (with already 15€ for shipping) with the Express Delivery option for 1000% of the product's price (>€65), that's simply insane... And I bet that stuff still won't be here for the weekend.

    [edit] Some parts are suddenly not available in the shop I ordered... will have to wait at least another week. Patience is a virtue... :bang:
     
    Last edited: Mar 18, 2015

  5. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    I am still waiting on the main order as some Bitspower parts have been said to arrive on the 25th, now 27th... probably won't get stuff until next week anyway. Disappointing, to say at least. Frustrating, also.
     
  6. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    Yeap that's the trouble sometimes, I remember waiting like 1 - 2 weeks for a specific part. Just the way it goes unfortunately.
     
  7. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    One thing I know for the next build I'll be doing in a couple of years: Order Watercooling parts in advance, then the actual hardware. ;)

    But I'm looking forward to tinkering a little this weekend, the thing's I've got so far is a red single cable braided PSU extension for the 24pin cable... I got it this week, unfortunately it's not as flexible as I'd have hoped for.

    I still got to check how to arrange the PSU and bottom rad, as I actually thought to put the rad on the opposite side of the window, but I'm not sure anymore if the power cables connecting to the mainboard are long enough, as I'd rather not have the power cables bent 90°, possibly damaging the wires inside.

    I can't see the pics in your thread Vet, but on which side did you put the PSU? Window side or the other (I'd call it the right side of the case if you look at it from the front)?
     
  8. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Just a small update: Apparently things have been shipped on Friday. I should check my emails more regularly, too bad my real life still does not include checking my emails daily...

    On the other hand, there might be some manual work coming in again!
     
  9. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    About time man. :)
     
  10. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Yeah... only that they were not able to deliver to the given adress, despite somebody being present ALL DAY. Now I got to take a 35km drive there and another 35km drive back to pick up my stuff. God those logistic business it such a piece of sh*t, I'm so upset... my time isn't free as well as gasoline.
     

  11. Megabiv

    Megabiv Master Guru

    Messages:
    798
    Likes Received:
    2
    GPU:
    GTX980Ti SLI (h²o)
    Yeah just think about that smile on your face when you're driving back with the box of goodies sat next to you :nerd:.
     
  12. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Well... they said they have tried to deliver the box, but in fact, they didn't. Because I was fairly aware of not being around during delivery times (8am to 6pm), I ordered stuff to be dropped off at my parent's place. They have been home, but nobody rang, and no notification on the outside / inside their mailbox.
    So I only learned by the tracking number that actually the package has been dropped off somewhere else, but not where. I had to call the customer service, one of those numbers that are NOT free with 99% of cell phone plans, but oh well.
    After about 7 minutes holding the line, I reached customer support and got the information that my mum, as holding the adress, needed to pick stuff up, and that it was not in their regional depot, but in a small partner shop they had, some few minutes of driving away.
    Good, called my mum, she was available, so I picked her up and we went there. Turns out it was a little shop with a guy obviously selling little of his small trinklets and gifts, but making money of being a drop off and pick up point for the logistics company.

    Got the box, instantly noticed it was damaged. Took pictures, noted it, and went home. As I checked the contents of the box I only noticed on of the cable combs I ordered to actually be a little damaged, but everything else looks to be okay, and actually complete, and what I ordered. I will post pictures later, since it's been a very big order.

    Tbh, I'm not as enthusastic anymore as I've been three weeks ago, and there was little relief or happyness as I picked up the stuff yesterday. But now things are here I can go on to really start to put stuff together, maybe once it's done I will be able to enjoy it even more.
     
  13. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    I had a couple of hiccups regarding my build with supplier. It happens and it does leave you less enthusiastic. I'm sure when you start building it you will start to get excited again.
     
  14. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    [​IMG]

    So here the stuff is... well, some of it. Unluckily not visible there is the waterblock for the aquearo controller, the second RX480, the other 7 noiseblocker fans, and all the bitspower parts and cable combs I ordered for my PSU extensions. All together the order summed up to 68 parts (the PSU extensions counting as a single one here).

    Now I've got so many things to do again, I find myself having a hard time to decide what's first. Probably 'cleaning' the blocks with water to get them ready for assambley onto the mainboard, CPU, and graphics cards?

    Yes, I do hope the fun in it comes back. I've already postponed on starting new games I already own as well as buying other ones (too, because there were only two of them so far hehe), and I start to get the feeling I should get the rig together, as well as continue my research on Haswell-E overclocking (still don't know how to do that lol), GPU bios modding (still not through with it), and of course, downloading the latest firmwares, BIOS's, and drivers once I set it up.
     
  15. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    Good stuff. Do one thing at a time and take your time. The best watercooling builds are the ones that are not rushed.
     

  16. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Ok, I startet 'cleaning' my blocks today. I didn't think the blocks for GPUs and mainboard would be that heavy, but it's logical as they are pretty much big copper blocks. I just hope that the PCBs of the mainboard or the GPUs will not give in, I would not want to have my cards sack... that would pretty much suck!

    Then I went for the rads, and unboxing the first one (still wrapped in that paper and seemingly originally enclosed I was taking a deep breath. Undoing the plastic transport plugs at the ports, I noticed something that worries me. Actually the inside of the rad looks odd... either as if it was already used, or it already comes being stained or possibly corroded. Below is the best picture I could take with my phone, and I'm quite worried if this looks normal to you experienced watercoolers. Here's the pic I took, click it for a full size version:

    [​IMG]


    I seriously hope you can dismiss my doubts, since that would mean I would have to send those back... probably waiting for another week or longer to get replacement. If it's okay, I'd appreciate a quick answer as I'd want to continue working on the rig tomorrow too...

    Does that look normal, or have I been screwed over? :uhoh:
     
  17. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    I cannot see exactly but that looks like it could be Radiator Flux which is normal for some radiators. Just flush the rad with tap water and vinegar over-night and let them soak. The vinegar is an acid which should remove the flux. The old but excellent PA120.* Thermochill series were prone to this flux.

    Here is an old Radiator roundup from around 4-5 years ago from good old Skinnee and still one of the best reviewers for enthusiast watercooling hardware.
    http://skinneelabs.com/triple-radiator-comparison-v2/

    Here is a more up to date one which ive yet to read myself which is only a few months old.

    http://www.xtremerigs.net/2015/02/11/radiator-round-2015/

    Just for reference i have the XSPC RX360's V1. You can see a review of these on SkinneeLabs (first link).

    Looking at that picture it does look like there is a bit of rust in the thread but im unsure. Check the rad over for any marks and check the fins to see if any have been damaged.
     
    Last edited: Apr 18, 2015
  18. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,470
    Likes Received:
    4,755
    GPU:
    2080Ti @h2o
    Thanks for your quick answer Vet, you know it's appreciated to the most.

    I've checked the other rad too now, and it looks to have flux / rust inside too. On the outside (frame) of the rads there are absolutely no marks or scratches or bumps, whereas the fins look a little odd close to the edge of the rad, see the picture below.

    That does not look like I should worry much about it, but am I wrong there? It looks pretty much the same on both rads, but the first one also has one slightly bent fin I marked with an arrow, the rest of them looks good on both of the rads.

    [​IMG]
     
  19. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    21
    GPU:
    2xTitan XM@1590Mhz-CH20
    There should not really be any rust in there, maybe flux but no rust. I do not know why there is a bit of rust in there. Saying that you can either return them or just use. If it was me i would just use them to save the hassle. As for the fins they are very easily bent, you can actually bend them with your finger if you press hard enough.

    Just be careful when installing, apart from that they look ok and tbh they will work and function correctly so nothing to worry about.

    Also just to note that it may actually not be rust, it may be just the copper coming through the black paint. That is something that you will have to judge yourself.
     
    Last edited: Apr 19, 2015
  20. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,856
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    Yeah, just a warning not to keep a copper radiator soaked with a vinegar solution regardless of concentration overnight as that will corrode the copper beyond simply cleaning the radiator and removing oxidation. Flushing is fine, as long as you only let it settle for a few minutes or so, mixed with water.

    Oh and those pics are nothing to worry about.
     

Share This Page