x-fi titanium and windows 10 support

Discussion in 'Soundcards, Speakers HiFI & File formats' started by squalles, Jun 26, 2015.

  1. squalles

    squalles Master Guru

    Messages:
    833
    Likes Received:
    36
    GPU:
    Galax GTX 1080 EXOC OC
    and a console launcher working ok? because have a exactly same options
     
  2. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,680
    Likes Received:
    17
    GPU:
    2x AMD R9 290X
    I don't use third party drivers, so only official ones from the Creative website. Is the console launcher also available in the official drivers from the Creative website?
     
  3. Aaron123

    Aaron123 Master Guru

    Messages:
    562
    Likes Received:
    1
    GPU:
    MSI GTX 1070 8GB
    Im using the official drivers for my x-fi fatal1ty and everything seems to be working. Was running Daniel K drivers, but everytime i hit reboot and not shut down my settings would never save, or id loose audio all together.
     
  4. MrH

    MrH Ancient Guru

    Messages:
    2,808
    Likes Received:
    14
    GPU:
    MSI GTX 1080 Armour

  5. squalles

    squalles Master Guru

    Messages:
    833
    Likes Received:
    36
    GPU:
    Galax GTX 1080 EXOC OC
  6. dsbig

    dsbig Ancient Guru

    Messages:
    4,041
    Likes Received:
    37
    GPU:
    EVGA RTX 2070
    soundblaster or microsoft messed up on this one.


    I understand that some people dont have problems.

    but other do.


    my problems.

    switching audio settings in game results in a loud pop sound.

    s/pdif input has random lag and stuttering in audio sometimes.

    audio from videos has pop sounds sometimes when video ends or starts /pausing.



    creative needs to fix these issue along with making a better installer that actually removes everything(files/registry settings). it leaves a mess that is sometimes not fixable unless doing a clean install.

    I got a soundblaster HD card thats keeps getting detected as a extreme gamer, because the system used to have a extreme gamer card in it. and only way to fix is to do a clean install, and the user doesnt want that.
     
  7. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,680
    Likes Received:
    17
    GPU:
    2x AMD R9 290X
    I can't get my microphone to work with these drivers on my X-fi Titanium..
     
  8. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,050
    Likes Received:
    1,867
    GPU:
    Zotac GTX980Ti OC
    And I can't get a working crxfihlp.exe start up file, I need it for my auto headphone detection switch in front panel..

    Win8.1 didn't have any issues though, in win10 no go.. I tested various startup parameters, and no luck.. Yesterday I even reinstalled everything from scratch, but its still the same..

    [​IMG]


    Could be the same issue by you Vinnie, this ctxfi file is more then just for headphones switch, maybe its also for mic detection.
     
  9. aveee

    aveee New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Asus EN7950GX2 @ 567/800
    Update:
    Official drivers are now running fine: I had to uninstall the drivers one last time after my previous post to have them working correctly.

    I am going to install right now the console launcher, thanks squalles for the tip!
     
  10. Mineria

    Mineria Ancient Guru

    Messages:
    4,168
    Likes Received:
    109
    GPU:
    Asus RTX 2080 Super
    It is also used for onscreen display etc.
    Hard to pinpoint the issue without event log errors or other log files that give some detailed info.
    You should report it on Creatives forums, DanielK might be nice and look into it.
     

  11. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,054
    Likes Received:
    7,095
    GPU:
    GF RTX 2070 Super
    Have you tried:
    - to place exe-file not into Windows foder/subfolder but into your own folder?
    - to switch on "run this program as administrator" setting for exe-file?
    - to place its "name=path" pair into "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" key?

    Does it start normally when you launch exe-file manually?
     
  12. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,050
    Likes Received:
    1,867
    GPU:
    Zotac GTX980Ti OC
    ^
    Yes I set to admin, now I added it manually again will see how that goes on next reboot.


    Nah nothing happens when I try to start manually, except I saw extra COM surrogate starting then terminating itself.

    Thanks for help :)


    hm there is no info in logs, well not that I know of..


    EDIT: nah not working.. ah well..
     
    Last edited: Sep 21, 2015
  13. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,054
    Likes Received:
    7,095
    GPU:
    GF RTX 2070 Super
    You can spy after the process of crxfihlp.exe (started manually) with procmon.exe.

    It may be that something is missing either from file system (files and/or folders) or registry (keys and/or values).

    But such monitoring can be overwhelming due to huge amount of file system and registry queries made by process.
     
  14. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,050
    Likes Received:
    1,867
    GPU:
    Zotac GTX980Ti OC
    Just saw new DanielK 3.7 pack with lots of fixes when I helped another guru3d user,
    http://danielkawakami.blogspot.si/2015/09/sb-x-fi-series-support-pack-37.html

    Looks like this could fix my issue too.. Will try it now :)


    EDIT: it works half way now,.. if I start it it runs and switches to headphones if connected, but if I refresh it goes to disabled mode again, disconnect headphones start the file again and it switches back.. Its like some part could be blocking it..


    Ok when it starts it also activates background task command for a split second..

    I found this so far, it seems to poinpoint to this yamisoft startup manager, well I do start it there since it doesn't want to autostart.. heh weird stuff

    [​IMG]

    [​IMG]

    and this com surrogate as mentioned earlier, 2 process and this pinpoints to probably this syswow64 part since its set like that atm

    [​IMG]

    this process call ID is DllSurrogate

    Edit2:

    I've looked some more and noticed something; now added /r command at end, just saw volumepanel uses the same command and copied this ctxfihlp.exe in same main folder as volumepanel folder..

    Edit3:
    nah it starts by fresh boot and detects headphones, but then it terminates it self again.. I have to manually start it again if I disconnect headphones and it switches to speakers, what a load of bull..


    and there is this
    https://social.msdn.microsoft.com/F...b9a86166358/mfc-and-windows10?forum=vcgeneral

    MS probably changed some stuff regarding MFC applications and I think its just it.. meh.. Idk, I ran out of ideas.


    edit4:

    lol well this is the default value, not pinpointing to anything and yet it works by windows start and detects headphones, but only one time like above if I pinpoint to correct or custom path, then I have to re-start the file e.g. with that win10manager so it switches again to speakers..
    [​IMG]
     
    Last edited: Sep 22, 2015
  15. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,680
    Likes Received:
    17
    GPU:
    2x AMD R9 290X

  16. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,050
    Likes Received:
    1,867
    GPU:
    Zotac GTX980Ti OC


    Ok windows refresh fixed it heh, all is ok now. I see it running in taskmanager.:nerd:

    [​IMG]
     
  17. Pervirtuous

    Pervirtuous New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    GeForce GT 720 1GB
    Windows 10 drivers for Creative Sound Cards

    Creative Windows® 10 - Software Availability Chart

    Sound Blaster 5.1 VX
    SB1071

    Sound Blaster Audigy 4/4 Series II
    SB0610/SB0612

    Sound Blaster Audigy 5/Rx
    SB1550

    Sound Blaster Audigy Fx
    SB1570

    Sound Blaster Audigy SE/Value (Bestbuy)
    SB0570

    Sound Blaster Audigy SE/Value (SI/Bulk)
    SB0570

    Sound Blaster PCI Express X-Fi Xtreme Audio
    SB1040

    Sound Blaster Recon3D PCIe Series
    SB1350, SB1352, SB1353, SB1356, SB1358, SB1359, SB135A, SB135D, SB135E , SB1354

    Sound Blaster X-Fi Elite Pro
    SB0550/SB0510/SB055A

    Sound Blaster X-Fi Fatal1ty
    SB0466

    Sound Blaster X-Fi Platinum
    SB0460/SB0251

    Sound Blaster X-Fi Platinum Fatal1ty Champion Series
    SB046A/SB0256

    Sound Blaster X-Fi Titanium
    SB0880

    Sound Blaster X-Fi Titanium OEM
    SB0881/3/7/9

    Sound Blaster X-Fi Titanium Fatal1ty Champion
    SB0886

    Sound Blaster X-Fi Titanium Fatal1ty Professional
    SB0886

    Sound Blaster X-Fi Titanium HD
    SB1270

    Sound Blaster X-Fi Titanium Professional Audio
    SB0888

    Sound Blaster X-Fi Xtreme Audio
    SB0790

    Sound Blaster X-Fi XtremeGamer
    SB073A/SB0730

    Sound Blaster X-Fi XtremeGamer Fatal1ty Pro Series
    SB046A

    Sound Blaster X-Fi XtremeMusic
    SB0460

    Sound Blaster Z
    SB1500

    Sound Blaster Z (bulk/online)
    SB1502

    Sound Blaster Zx
    SB1506

    Sound Blaster ZxR
    SB1510 + SB1510A

    You can download OEM Windows 10 drivers for any of these at the link below.


    Source: support.creative.com /kb/ShowArticle.aspx?sid=126331
     
    chinobino likes this.

Share This Page