X-Fi series cards and Windows 8

Discussion in 'Soundcards, Speakers HiFI & File formats' started by Anarion, Oct 16, 2012.

  1. Helpful

    Helpful Master Guru

    Messages:
    635
    Likes Received:
    0
    GPU:
    GTX 980 Ti
    Follow up after second restart:
    Sound settings did not stick. So i used uninstaller to clear all Creative stuff then restart and re-install.
    All sticks as it should now. Sounds great (same goodness observed/heard)
    The front bay, though, is a let down! No lights and no controls work after clean install.
     
  2. kakarot

    kakarot Maha Guru

    Messages:
    1,108
    Likes Received:
    0
    GPU:
    evga 980ti sc+
    One thing I noticed after installing the drivers and rebooting is that in windows action center/maintenance there was a warning to finish installing the device, which i am guessing was the x-fi. Funny thing is it worked perfectly even before doing it but maybe it will help you if you are having the same warning in there.

    Also looks like both those sets were officially released at creative support
     
  3. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    8,884
    Likes Received:
    2,806
    GPU:
    ASUS RX 470 Strix
    Yayyyyyyyyyyyyyyyyyy!~~!!!!!!!!!!!!!!!!!!!~~!~!~!~! Final Windwos 8 Drivers~
     
  4. MrBozack

    MrBozack Master Guru

    Messages:
    670
    Likes Received:
    0
    GPU:
    Gigabyte 7850OC Windforce
    Oops! Google Chrome could not find uk.creative.com
    Try reloading: uk.*creative.*com​

    LOL I think Creative driver team are working on their network infrastucture.
     

  5. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    8,884
    Likes Received:
    2,806
    GPU:
    ASUS RX 470 Strix
  6. Caenyss

    Caenyss Active Member

    Messages:
    69
    Likes Received:
    14
    GPU:
    RogStrix Vega 56 OC
    Does this fix the issue of no sound after restarting?
     
  7. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    for me yes :banana:
     
  8. scandalous

    scandalous Master Guru

    Messages:
    718
    Likes Received:
    4
    GPU:
    980TI Classified
    Hey guys, haven't really been keeping up, but have there been any new drivers released for the Titanium HD?

    Thanks,
     
  9. doodle333

    doodle333 Master Guru

    Messages:
    493
    Likes Received:
    0
    GPU:
    HD7870 2Gb
  10. Caenyss

    Caenyss Active Member

    Messages:
    69
    Likes Received:
    14
    GPU:
    RogStrix Vega 56 OC
    Finally! I'm going to give these a try then. :)
     

  11. Drivers are nice...

    The boot up no sound issue with SSD is gone.

    Settings also did save.

    Yes they are good...
     
  12. blunden

    blunden Master Guru

    Messages:
    919
    Likes Received:
    1
    GPU:
    ASUS RTX 3080 TUF
    Creative have a beta driver for X-Fi cards now. Daniel_k also swooped in and released a pack for all X-Fi cards based on the Auzentech Forte drivers. They are newer than Creative's private beta drivers. I currently use Daniel_k's pack with no issues.

    http://forums.creative.com/showthread.php?t=699146
     
  13. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,173
    Likes Received:
    1,921
    GPU:
    Zotac GTX980Ti OC
    Great, thanks for the info!


    I had newest DK 1.8 UAA pack + creative win 8 official January 2013 driver and it kinda sucks.
    Every time i boot into windows i have to switch between modes to get my sound back. I didnt have that with all in one DK UAA 1.8 pack.


    Hope everything is ok with this new forte 2.0 pack. :)
     
  14. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    It loads the creative auto update program again if it was deleted before. :3eyes:
     
  15. Kaleid

    Kaleid Ancient Guru

    Messages:
    2,579
    Likes Received:
    217
    GPU:
    MSI 5700 8GB
    Interestingly enough the win8 drivers also work with win7.
     

  16. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    378
    GPU:
    GeForce RTX 3060 Ti
    Going to try that, I can't stand this crap Realtek any more.

    EDIT:
    Works perfectly. Finally I can enjoy new music. Aaaaahhhh! What a difference!
     
    Last edited: Jan 11, 2013
  17. xankazo

    xankazo Ancient Guru

    Messages:
    2,839
    Likes Received:
    7
    GPU:
    EVGA 1060 SC (6GB)
    No luck for the Prelude. The same daniel_k said he can't make a mod for them cards. :(
     
  18. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,173
    Likes Received:
    1,921
    GPU:
    Zotac GTX980Ti OC
    That Forte 2.0 driver works ok on my SB046A XFI (win8), but now i cant enable 32bit/96khz anymore, only 24bit (max 24/192) available.. UAA 1.8 or default creative driver worked ok (max 32/192), ah well.

    Btw it sounds better then default Creative January 2013 driver or UAA 1.8 prelude driver, its clearer and with more defined sounds :)
     
  19. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    378
    GPU:
    GeForce RTX 3060 Ti
    Why would you want to do that anyway? X-Fi hardware doesn't support 32-bit so it was a bug for sure.
     
    Last edited: Jan 12, 2013
  20. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,173
    Likes Received:
    1,921
    GPU:
    Zotac GTX980Ti OC
    Why not? :grin: and i know its mostly interpolated? to higher bit rate.. btw no its not a bug win8 also supports 32bit.
     

Share This Page