X-Fi CMSS-3D Headphone

Discussion in 'Soundcards, Speakers HiFI & File formats' started by king-dubs, Oct 1, 2007.

  1. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    X-Fi CMSS-3D Headphone - THE RIGHT WAY TO DO IT

    Old post for Windows XP 32-bit and 64-bit:
    I have a 5.1 surround setup (speakers), and I also have stereo headphones. This is the first time I'm going to try the CMSS-3D Headphone feature on the X-Fi.

    So, I plug in my headphones, and set the "Speaker" in the Creative Audio Console to "Headphones" and unchecked Synchronize with Windows Control Panel, and CMSS-3D tab, turn it on, with Elevation and Macro to Auto.

    I kept the speakers in Windows' sound settings as "5.1 surround speakers", and fire up a game like CS:S. I make sure speakers in CS:S under "Audio" is set to 5.1, and join a server.

    Am I using CMSS-3D Headphone correctly?
    -------------------------------------------------
    #EDIT:
    For Vista and 7 32-bit and 64-bit:
    I made a tutorial with colorful pictures so you guys can easily follow it :)
    [​IMG]

    Then, you SHOULD reboot your system. You don't have to, but if it ends up not working in games, you will need to reboot once.

    I tested this, works perfectly on Battlefield 2 with Creative X-Fi, Ultra High... very very accurate positioning. Also tested on CS:S, set sound to 5.1, and that's it, could hear exactly where enemy was coming from. Also tested in Call of Duty 4, set sound to "Windows Default", and I was getting full positioning as expected.

    Again, enjoy!
     
    Last edited: Jul 22, 2009
  2. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
  3. ROBSCIX

    ROBSCIX Ancient Guru

    Messages:
    16,241
    Likes Received:
    8
    GPU:
    22" LCD on GTX260 C216
    Yes sounds about right.
     
  4. Sobek

    Sobek Master Guru

    Messages:
    496
    Likes Received:
    0
    GPU:
    Gigabyte R9 280
    I always thought you just had to set everything to headphones and enable it, and it automagically simulated surround sound...or something. Might explain why it sounds so **** though if that's how you're actually supposed to do it.

    I've enabled CMSS in the past and couldn't possibly understand what kind of person would ever use it... It sounded muffled and 'airy' or 'spacy'...not sure how else to put that. Basically CMSS makes it sound like you've got giant tin cans over your ears.

    So i'll bump this one too, are you supposed to use 5.1 with CMSS headphones?
     

  5. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    I think this is right, because before I did not uncheck "synchronize with Windows Control Panel", and it set it to "Headphones", and did not set game or windows to anything other than what's automatically set ("headphones").

    As you described, it sounded weird, muffled, and dull, and did not have surround.

    However, today I decided to uncheck synchronize with windows control panel, and set the "Speakers" to Headphones in Creative Audio Console, and kept the Windows one set to 5.1 speakers.

    Then, I fired up CS:S and it indeed sounded like a multi-channel headphone.

    Since I did not find any "formal" instruction on setting up CMSS-3D Headphone, I'm asking you Gurus what's the "correct" way to set it up.

    The way I have it seems to work, but is it the right way?

    #EDIT:
    Also, I think you can use 7.1 instead of 5.1 too since Creative advertised that games and music will sound "just as good if not better than a 7.1 surround speaker set". - Source here
     
    Last edited: Oct 1, 2007
  6. Satan

    Satan Ancient Guru

    Messages:
    6,684
    Likes Received:
    0
    GPU:
    some
    Yeah, that sounds fine :)
     
  7. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    I'd still like to see some formal (official) instructions for using CMSS-3D Headphone though :p
     
  8. The_AC

    The_AC Maha Guru

    Messages:
    1,176
    Likes Received:
    0
    GPU:
    R9 390X
    That's right. You're basically supposed to trick windows into sending a 5.1 signal to the sound card, and then the sound card converts that into stereo headphone sound.
     
  9. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    And how do you know this for sure if you don't even own an X-Fi? :knock:
     
  10. -Ruin-

    -Ruin- Maha Guru

    Messages:
    1,192
    Likes Received:
    0
    GPU:
    Asus GTX 1060 6GB
    In CS, use headphone mode.

    Do NOT use 5.1 with headphones. And ignore the windows control part, the creative software overrides it anyway.

    In the the creative control simply turn on Headphone mode wih cmss3d on, and NO macro or elevation filters, those kill the sound and do not work.

    In Counter Strike just enable Headphone and your all set.
     

  11. Thug

    Thug Ancient Guru

    Messages:
    2,200
    Likes Received:
    9
    GPU:
    RTX 3080
    I use it with Call of Duty 2, and have set it up the same as you. Make sure it IS set to eax in game though, and not to headphone or 2.1 speakers.
     
  12. PixelPerfect

    PixelPerfect Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    GTX 285
    Thats right and I have tested every settings and even read on Creatives forum that that is the correct way to set it up!

    The soundcard must get 5.1/7.1 so it can then send it out the correct way to the virtual speakers to get surround sound :)

    So it works just as you set it up for a real surround system ..if you set the control panel to headphones/stereo then the soundcard only get stereo source and that you obviously dont want to have!

    PS! Of course set hedphones mode in creatice CP with CMSS3D enabled!
     
    Last edited: Oct 1, 2007
  13. Grahf

    Grahf Ancient Guru

    Messages:
    1,817
    Likes Received:
    0
    GPU:
    MSI N580GTX Lightning

    No, you're not.

    If your speakers are set to 5.1, then you're not using CMSS3D Headphone, period.


    When you're using headphones, your game/windows should be set to HEADPHONES.

    The CMSS3D Headphone feature alters a STEREO (headphone) signal, thus you should have everything set to headphones when you're using headphones.

    WRONG.

    CMSS3D does NOT EQUAL "Virtual 5.1 or 7.1 for headphones".

    CMSS3D Headphone alters a stereo signal to give the impression of multi-directional sound; ideally, you'll be able to differentiate between sounds that are behind you, in front of you, etc.

    IT IS *NOT* the same thing as "Virtual 5.1". There is no virtual subwoofer, NO virtual speakers; STEREO sound is altered to give the impression of multi-directional sound. Pretty simple to understand.

    ----

    I don't care where you read what you read but I am 100% positive that when using X-Fi CMSS3D Headphone, ALL of your speaker options should be set to HEADPHONE, *NOT* 5.1 or 7.1
     
    Last edited: Oct 1, 2007
  14. -Ruin-

    -Ruin- Maha Guru

    Messages:
    1,192
    Likes Received:
    0
    GPU:
    Asus GTX 1060 6GB
    ^ Exactly, you do NOT want 5.1 if you are using headphones.

    *hi-fives* Grahf for being the only other one who knows how to use it correctly! :knock:
     
  15. BOYDIE-NI

    BOYDIE-NI Master Guru

    Messages:
    220
    Likes Received:
    18
    GPU:
    GTX 1660 6GB
    Yup agree 100% also, set cmss-3d to Headphone,speakers to headphone and game/source to headphone.How can cmss -3d headphone work if you arn't using headphones settings in game.Cmss-3d alters the 2 channel signal.
     

  16. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Well that's what unchecking "Synchronize with Windows Control Panel" is for. It's to make windows and the apps that run on it send 5.1/7.1 signals to the card (the CMSS-3D Headphone feature will interpret those signals and essentially create 8 or 6 virtual speakers in your stereo headset).

    Maybe you guys aren't reading what I'm writing, or I'm not writing what I did.

    I'll now do a visual demo of what I did:

    Settings that are done in Creative Audio Console and Windows' own sound thing
    [​IMG]

    In-game settings for Counter-strike: Source
    [​IMG]

    Note: If I do NOT follow this procedure and just set it to "Headphones" in Creative Audio Console and not uncheck synchronize with windows, it will set EVERYTHING to headphones. And CS:S sounds like absolute sh*t. Could not tell what's behind, above, or below me. However, If I do this procedure I found on my own, it sounded like my 5.1 speakers (similarly). I took off my headsets while playing, and could not hear sound (confirming that they were coming from headset).
     
    Last edited: Oct 1, 2007
  17. -Ruin-

    -Ruin- Maha Guru

    Messages:
    1,192
    Likes Received:
    0
    GPU:
    Asus GTX 1060 6GB
    Then your giving yourself a placebo effect if you think that THAT is working correctly. CMSS3d uses a STEREO/HEADPOHNE signal and mixes it to a "surround" effect.

    Anything 5.1 or 7.1 is NOT needed.
     
  18. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Actually, I did hear a difference. Using "Headphone" in CS:S and Windows made it sound dull, and not very surround at all.
     
  19. PHJF

    PHJF Maha Guru

    Messages:
    1,266
    Likes Received:
    0
    GPU:
    ASUS GTX 970
    You'd think it would need a surround-sound signal to process into a "3D" stereo signal, wouldn't you?

    How does CMSS-3D know if a sound is supposed to be in front of you or behind you if all it's getting is a standard stereo signal?
     
  20. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Qft. I knew it was actually working, because CS:S sounds like sh*t without it set to 5.1. The game would only be sending out stereo sounds.

    And it really is that good. In CoD2 just now, I nailed a couple of guys in the head that were BEHIND me, and I could hear them. I also thought again it was my speakers, but then I took off my headphones, and no sound :p
     

Share This Page