Workaround for stuck memory clock on RX580

Discussion in 'Videocards - AMD Radeon Drivers Section' started by passenger, Jun 29, 2019.

  1. warlord

    warlord Ancient Guru

    Messages:
    2,824
    Likes Received:
    943
    GPU:
    Null
    Interesting. Is it the same or a different way of input connection between those two monitors?
     
  2. Undying

    Undying Ancient Guru

    Messages:
    13,113
    Likes Received:
    2,364
    GPU:
    Aorus RX580 XTR 8GB
    Same, hdmi. If i use both as 60hz the memory clock drops. If i use my main at 75hz and second at 60hz clocks are elevated so i know its the configuration.

    Meh, to be honest its been a while it does not bother me that much. Card works, temps are fine.
     
    warlord likes this.
  3. warlord

    warlord Ancient Guru

    Messages:
    2,824
    Likes Received:
    943
    GPU:
    Null
    I see. That's my understanding as far as I remember clocks must have common multiplier of 30 hz among all connected monitors.
     
  4. Lipici

    Lipici Member

    Messages:
    44
    Likes Received:
    11
    GPU:
    580
    Yeah but consume power(28w idle vs 7) and temperature (44 vs 30) its the same as it was with locked so you didnt resolved anything.
     

  5. ninja750

    ninja750 Master Guru

    Messages:
    202
    Likes Received:
    45
    GPU:
    RX580 Pulse
    just in case.. how we can turn back to the original state before the CRU mod?
     
  6. Mesfigas

    Mesfigas Member

    Messages:
    41
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    when yoy say restart you mean the compute or one of the options trhat CRU offers |?
    for example restart64 ?
    please be more informative thanks
    also it doesnt works with older drivers cause i tried it with 19.12.1 and latest CRU 1.4.2
     
  7. MaCk0y

    MaCk0y Master Guru

    Messages:
    782
    Likes Received:
    267
    GPU:
    GB 5700XT Gaming OC
    reset-all executable.
     
    ninja750 likes this.
  8. Mesfigas

    Mesfigas Member

    Messages:
    41
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    thanks but still not working for me
    should i try the whole thing at 60 hertz or start at 75 hertz which i prefer cause of freesynq ?
    rx 580 4 giga card here
     
  9. MaCk0y

    MaCk0y Master Guru

    Messages:
    782
    Likes Received:
    267
    GPU:
    GB 5700XT Gaming OC
    my response was to ninja750. In your case, restart64. Post a screenshot of your CRU.
     
  10. passenger

    passenger Master Guru

    Messages:
    382
    Likes Received:
    56
    GPU:
    Sapphire RX580 8GB
    After setting cru you need to restart computer.

    If you trying this on multi-monitor setup it’s not going to work. Unless all of the displays are identical, same resolution, refresh rates, same connections.
     

  11. Mesfigas

    Mesfigas Member

    Messages:
    41
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    yes 2 monitors but not connected together
    they are connected in same gpu 1 with display port and the other HDMI
    but not as a multi monitor setup to act as 1 monitor
    just 2 seperate 1 for gaming and the other for youtube
     
  12. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,942
    Likes Received:
    185
    GPU:
    5700XT/290X
    Can you provide a CRU pic of your 75Hz setting, the LCD Standard one that works with idle memory clocks.
     
    Last edited: Mar 3, 2020
  13. passenger

    passenger Master Guru

    Messages:
    382
    Likes Received:
    56
    GPU:
    Sapphire RX580 8GB
  14. fenderjaguar

    fenderjaguar Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    RX 570
    I have RX 570 and 240hz AG251FZ, locked to 1750mhz permanently, even on desktop.

    I use CRU to delete all other 1920x1080 refresh rates, apart from 240hz. Because it's annoying some games will only run in 240hz, when you force it to like this:



    I have tried changing/editing the refresh rate to LCD with CRU, like you said passenger, but it doesn't seem to make any difference...
     
  15. passenger

    passenger Master Guru

    Messages:
    382
    Likes Received:
    56
    GPU:
    Sapphire RX580 8GB
    I never said to delete anything, just edit provided resolution under "Detailed resolutions", not under "Extension blocks", and then under timing select Automatic - lcd standard.
    https://ibb.co/cvDMnm0
     
    fenderjaguar likes this.

  16. fenderjaguar

    fenderjaguar Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    RX 570
    I know, but I have to do that anyway, otherwise a lot of games run in 60hz etc

    yes, I have done, still 1750mhz
     
  17. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,942
    Likes Received:
    185
    GPU:
    5700XT/290X
    Last edited: Mar 7, 2020
  18. passenger

    passenger Master Guru

    Messages:
    382
    Likes Received:
    56
    GPU:
    Sapphire RX580 8GB
    Can you try 17.5.1 drivers and see how are the idle clocks are? If the are still elevated try to change monitor connection.
     
    fenderjaguar likes this.
  19. fenderjaguar

    fenderjaguar Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    RX 570
    It works on those drivers!

    It took a lot of messing around with CRU, infact I got a black screen, and had to manual cold restart. But when I got back in, the 240hz refresh runs at 300mhz memory at idle on desktop now.

    so how come this doesn't work with the new drivers? how old are these 17.5.1?

    also, it's not perfect, because I'm getting a lot of random black screens on restart
     
    Last edited: Mar 8, 2020
  20. D1stRU3T0R

    D1stRU3T0R Member Guru

    Messages:
    174
    Likes Received:
    65
    GPU:
    8 GB
    Using RX580 with 75Hz, 300/300 MHz working fine since day 1. Buying 144Hz monitor in some weeks hopefully, gonna report back. 300/300 was working on LITERALLY EVERY DRIVER.
     

Share This Page