Workaround for stuck memory clock on RX580

Discussion in 'Videocards - AMD Radeon Drivers Section' started by passenger, Jun 29, 2019.

  1. Exodite

    Exodite Ancient Guru

    Messages:
    1,917
    Likes Received:
    171
    GPU:
    Sapphire Vega 56
    FWIW I'm getting this issue on my Vega 56 as well.

    Windows 10 1903
    Drivers 19.6.2
    Single monitor connected via DP, 1440p@144Hz

    Basically forced to reboot once it happens as the 900MHz memory clock forces the card to randomly turn on the fans for a few seconds until the card drops just below the temp threshold again. It's very distracting when just browsing or whatever.

    I'm sure it'll be fixed with a new release, fingers crossed for 19.7.1, but if not I'll probably experiment with some older drivers.
     
  2. Thadeus

    Thadeus New Member

    Messages:
    9
    Likes Received:
    6
    GPU:
    Sapphire RX 580
    2 Monitor setup here aswell. First monitor at 120hz is connected via dvi to my 580 and the second is connected via dvi to hdmi cable to the motherboard and powerd by intel 3570 graphic. No issue with the high idle speed/temps.
    Am i missing some disadvantages here you guys could tell me about?

    Doesnt work since 16.11.5 drivers - at least for my 390. Back then i could force the memory clock to the idle speed with both monitors connected to the 390 (and 580) within trixx or afterburner.
     
  3. Mesfigas

    Mesfigas Member

    Messages:
    38
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    @Thadeus you miss the point which is 2 monitors in the same gpu
     
  4. Thadeus

    Thadeus New Member

    Messages:
    9
    Likes Received:
    6
    GPU:
    Sapphire RX 580
    Impressive reply..
    My setup fixed the problem with 2 monitors in the same gpu and im asking you why would you force the full mem clocks if you just have to plug the second monitor into your motherboard?
     

  5. Mesfigas

    Mesfigas Member

    Messages:
    38
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    apologies then
    i didnt fully understood your question
    i was sure that you have always 2 monitors connected in different place
    1 in motherboard and the other in gpu
    apologies again
    i have a XFXX RX 580 2 monitors connected in the gpu via different cables and that might be the problem
    both monitors same refresh rate etc
     
    Thadeus likes this.
  6. grimmute

    grimmute Member

    Messages:
    13
    Likes Received:
    3
    GPU:
    SAPPHIRE RX590 8G
    Holy crap, actually worked.

    [​IMG]


    I'm using a single 144hz@1080p monitor with my RX 590. When it's on 144 hz setting, memory is on max 2100 mhz, when it's on 120 hz, it's on 400 mhz... I tested this with Radeon 19.6.3 as the new driver doesn't even install on RX 590 cards.

    Never realized this issue until I saw this topic. What is the downside of having the memory clock on max? Does it draw more power/run hotter?
     
  7. Undying

    Undying Ancient Guru

    Messages:
    12,311
    Likes Received:
    1,809
    GPU:
    Aorus RX580 XTR 8GB
    vrms run a little hotter on idle, that is all. It should not bother you. I agree it is an issue but people are making it worse than it is.
     
    LocoDiceGR likes this.
  8. Montville

    Montville Master Guru

    Messages:
    202
    Likes Received:
    18
    GPU:
    Aorus RX 570 4GB
    permanently higher power consumption and GPU stays @ x16 3.0 mode unable to switch to idle mode (1.1)

    To me it's causing intermittent desktop screen seizures (read short flashes) - the more windows open the worse the problem.
     
  9. DigitalAiz

    DigitalAiz Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    xfx 5700 xt thiccII
    my xfx 5700xt thicc has the same problem . i run a 3440x1440 monitor at 75hz and the clocks are stuck at max.the only work around is either go 3440x1440 @ 50 hz , or 2560x1080 @59z. seems that this problem exists for months now.honestly kinda doubt if they gonna fix it but i sure hope so
     
    passenger likes this.
  10. passenger

    passenger Master Guru

    Messages:
    343
    Likes Received:
    48
    GPU:
    Sapphire RX580 8GB
    Unfortunately the only solution is to use 17.1.1 driver(with RX580) which have “working” 75Hz, but losing all stability and performance optimisations. I haven’t been able to use any new driver since Windows 10 1903 release. I reported bug to AMD and it was debated on reddit and AMD community, but nothing so far.
     

  11. DigitalAiz

    DigitalAiz Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    xfx 5700 xt thiccII
    i would go for it too if i hadnt the s 5700 series card ;/
     
  12. Jayson

    Jayson Active Member

    Messages:
    58
    Likes Received:
    11
    GPU:
    Radeon RX 580 8GB
    I don't have high idle clocks and I'm running a Sapphire PULSE RX 580 at 144Hz at the desktop using an ASUS MG278Q FreeSync monitor. It always says 300 for me at the desktop.
     
  13. Mesfigas

    Mesfigas Member

    Messages:
    38
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    connect a second monitor and start crying then
     
  14. MaCk0y

    MaCk0y Master Guru

    Messages:
    605
    Likes Received:
    182
    GPU:
    GB 5700XT Gaming OC
    That's what integrated graphics are useful for. :p
     
  15. Mesfigas

    Mesfigas Member

    Messages:
    38
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    for multi monitor gaming AMD might not be the best solution
    this bug is unacceptable
     

  16. DigitalAiz

    DigitalAiz Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    xfx 5700 xt thiccII
    well its seems to me AMD for gaming , period , might not be the best solution ( since this bug affects single monitor setups all the same) ;p
     
  17. Undying

    Undying Ancient Guru

    Messages:
    12,311
    Likes Received:
    1,809
    GPU:
    Aorus RX580 XTR 8GB
    Nvidia has its own share of issues. I dont remember when is the last time i got driver has stop responding in the middle of my game. I dont care what people say but amd drivers are much more stable.
     
  18. DigitalAiz

    DigitalAiz Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    xfx 5700 xt thiccII
    true , i had a 780, a r9 390x devil , a 1070 ,a vega 56,a 1080 .they all had their issues , most of the times nvidia is plug and play. amd requires always some tempering BUT in the long run amd seems to have a way better support for their older cards compared to nvidia;s and thats why i went amd again. no fun boy here at all.
     
  19. MaCk0y

    MaCk0y Master Guru

    Messages:
    605
    Likes Received:
    182
    GPU:
    GB 5700XT Gaming OC
    Ok, I just fixed the memory clock issue. Someone mentioned CRU might cause the issue on AMD forum. Why didn't I think about this? :mad: I reset CRU settings and now back to 300MHz memory clock speed at idle with a 144Hz monitor. :)
     
  20. DigitalAiz

    DigitalAiz Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    xfx 5700 xt thiccII
    i tried that just now, didnt work for me . ;/
     

Share This Page