1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Workaround for stuck memory clock on RX580

Discussion in 'Videocards - AMD Radeon Drivers Section' started by passenger, Jun 29, 2019.

  1. passenger

    passenger Master Guru

    Messages:
    322
    Likes Received:
    37
    GPU:
    Sapphire RX 580 8GB
    Since latest 1903(some reported even earlier) update for Windows 10, I and many others having problems with elevated memory clock on Radeon RX580 and some other Polaris based cards.
    I have a single AOC 75Hz(native) FreeSync monitor connected via displayport and at this frequency GPU memory clock is raised to maximum of 2000MHz. In this state graphics card temperature is slightly higher and fan is active. Workaround is simple, by reducing refresh rate form 75 to 60Hz(right click on desktop, display settings, advanced display settings, display properties, monitor) memory clocks are back to idle values of 300/300MHz, temperature is back to normal and AMD zero rpm is not compromised. You can still use higher refresh rates in games but the memory clock will not stay an maximum returning to desktop.

    Drivers from Windows update version 17.1.1 work fine in this regard, but you have to choose between nominal desktop refresh rate of your monitor and new features and optimizations of latest drivers.
     
    Last edited: Jul 1, 2019
  2. Fox2232

    Fox2232 Ancient Guru

    Messages:
    9,684
    Likes Received:
    2,158
    GPU:
    5700XT+AW@240Hz
    And I thought that everyone knew price of running High refresh rate screens by now. I rather have 240Hz even on desktop. Can't stand low refresh rate animations/mouse movement.
    And 2250MHz on memory is not big deal.
     
  3. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    yep i have 2 monitors and when i connect both on my xfx RX 580 memory clock goes always at 1750 idle
    people here told me not big deal but i wish it was 300/300 idle like it is when i connect only 1 monitor on idle
     
    Thadeus likes this.
  4. Montville

    Montville Member Guru

    Messages:
    174
    Likes Received:
    15
    GPU:
    Aorus RX 570 4GB
    Good for you...passenger

    Na, my monitor is 60HZ default and still elevated idle clocks all the time causing intermittent desktop screen seizures here - only fix is reverting back to an older driver at least 19.4 (or older) for me. Notably then the driver graph is silent, smooth lines, and notta jumpin' jack all the time.

    Btw, RX570 here and the problem is/was same with Win 1809

    This is what I call an idle GPU
    https://imgur.com/Dypc19D

    PS: AMD should stop selling hardware when they are apparently incapable of delivering flawless drivers

    Oh wait, there is more ... another new card coming next month
    AMD Radeon™ RX 5700 XT
    .. a slightly pepped up FX 570
     
    Last edited: Jun 30, 2019

  5. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,257
    Likes Received:
    525
    GPU:
    Redacted by NDA
    This is the kind of thing that puts me off, there are always ridiculous flaws with AMD drivers.
    Because of them and there being no solution I had to sell my 290x and move to NVidia.
    I didnt want to but it was a real breath of fresh air to have a trouble free system again.
    AMD, sort it out!
     
  6. Trihy

    Trihy Active Member

    Messages:
    86
    Likes Received:
    10
    GPU:
    Onboard
    If you have dual or multi monitor, you need to run the exact same refresh rate AND color bit AND black levels/rgb type to have 300mhz mem.

    If you dont do this, mem will stay at highest clock.

    This been happening forever on amd cards.

    I have one monitor supporting 12bit color and the other 8 bit. If i dont set both to 8, it wont stay at 300mhz.
     
  7. spajdrik

    spajdrik Ancient Guru

    Messages:
    1,960
    Likes Received:
    340
    GPU:
    GB RX 5700 Gaming
    Got single LCD monitor and my clocks are 300/300 with a 75Hz set.
     
  8. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    woooow i m gonna try it now
     
    Trihy likes this.
  9. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    i did what you said and still have 1750 memory clock
     
  10. Trihy

    Trihy Active Member

    Messages:
    86
    Likes Received:
    10
    GPU:
    Onboard
    Hi. Been using this fix for years. Maybe if your refresh rate is too high, it doesnt work.

    Just tried in latest driver and worked fine. But im running at 75hz.
     

  11. Caesar

    Caesar Master Guru

    Messages:
    675
    Likes Received:
    236
    GPU:
    GTX 1070Ti Titanium
    underclock and lock it
     
  12. Chastity

    Chastity Ancient Guru

    Messages:
    1,901
    Likes Received:
    461
    GPU:
    Nitro 390/GTX1070M
    This idle clock issue is a very old one with multimonitor. In order to keep the clocks low, the monitors need to match settings: refresh rate, connection type, etc. If you connect 2 monitors that are identical, but connect one via DP and another HDMI, it still won't drop. I was running 3 Dell 1080p monitors off my 390, and I had to invest in getting DP to HDMI active adapters so that I can have my idle clocks. (These monitors predate DisplayPort)
     
    Trihy likes this.
  13. Trihy

    Trihy Active Member

    Messages:
    86
    Likes Received:
    10
    GPU:
    Onboard
    That part didnt tried. I have both on hdmi. Sapphire rx580.

    But great to know.

    Weird stuff on amd drivers.
     
  14. Undying

    Undying Ancient Guru

    Messages:
    11,590
    Likes Received:
    1,364
    GPU:
    Aorus RX580 XTR 8GB
    I dont want to drop my monitor refresh rate to 60hz. I've set freesync range and frtc and it works fine for me at 72hz. It does not bother me its stuck. Only downside is that vrm temps are little higher on idle but under control.
     
  15. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    yep that ight be the issue indeed
    the one monitor is connecred via DP and the other via HDMI
    different cables prolly causes the problem
    other than that i run both monitors at 75 hz and i dont go back to 60
    maybe i ll go to Nvidia cards nexti time hopeing no multi monitor bugs
    i m a sim racer and i need 2 or 3 monitors
     

  16. Montville

    Montville Member Guru

    Messages:
    174
    Likes Received:
    15
    GPU:
    Aorus RX 570 4GB
    While I am on single monitor with this problem....

    ... why discussing work-arounds when this def is a driver problem.
    See my message #4 .. butter smooth idle clocks with 19.4.x and I am fairly sure there is a working older driver for the multi monitor setups too.

    Why is this no longer possible? AMD's driver service quality turned ridiculous since 19.5.x where all the mess started. Instead of releasing a new GPU every "month" they better get driver services up to scratch first.
     
    Mesfigas likes this.
  17. Chastity

    Chastity Ancient Guru

    Messages:
    1,901
    Likes Received:
    461
    GPU:
    Nitro 390/GTX1070M
    This behavior goes back a long while, and it's coded to do this, so it isn't a bug. Just some legacy coding that needs to be updated. Make a stink on their dev forum about this. If anything, add a button to enable low idle clocks, this way if there is an issue, it can be disabled, and have the clocks jump up.
     
  18. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    how come and the devs dont know anything but the rest of the gamers knows everything ?
    i m sure they cannot fix it
     
  19. Trihy

    Trihy Active Member

    Messages:
    86
    Likes Received:
    10
    GPU:
    Onboard
    Sure, probably they need higher mem clocks. But using max mem clock is way too much.

    If they need higher mem clock for whatever reason for multimonitor with different conector, refresh rates, they could use an intermediate freq.
     
    Undying likes this.
  20. ninja750

    ninja750 Member Guru

    Messages:
    151
    Likes Received:
    17
    GPU:
    RX580 Pulse
    I also have that memory clock issue for my RX580+AOC 144hz

    I solved setting in windows 120hz instead of 144hz

    So i think it is a bug related to multiples of 60
     

Share This Page