Witcher 3 small stutters with RivaTuner

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Smough, Aug 31, 2018.

  1. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Hello. I need some help with The Witcher 3 and RivaTuner. Even if RivaTuner makes the game's frame timings very stable, I still have some weird stutters related to the program, without it the game seems to run with less stutter, but I get CPU usage spikes, with RivaTuner I don't. Also please note that I get perfect frame time with Windows 10 full screen optimizations but with random 100% CPU spikes at areas of the game with lots of NPCs and that creates fps drops.

    Right now I am playing the game on a 75 Hz mode with nVidia half v-sync refresh rate at 37.5 fps, this way I get way smoother motion than 60 Hz with half sync at 30 fps and can crank everything to Ultra on the game. I just need some help with RivaTuner's config.

    I am playing the game on an i5 4590 CPU, a GTX 1060, 8GB of RAM, the game runs on an SSD so I don't think the RivaTuner is related to that.


    Windows 10 1803 build.

    What I get are drops that go like: 37.5 fps, 37.3, 37.2, 37.4 and so on, its rare, but when it happens, its annoying. Sometimes also seems like RivaTuner creates random fps drops for no reason, 2 or 4 frames.

    My Witcher 3 .cfg looks like this:


    [Framerate]
    LimitDenominator=1000
    Limit=37498
    [Hooking]
    EnableHooking=1
    EnableFloatingInjectionAddress=0
    EnableDynamicOffsetDetection=0
    HookLoadLibrary=0
    HookDirectDraw=0
    HookDirect3D8=1
    HookDirect3D9=1
    HookDirect3DSwapChain9Present=1
    HookDXGI=1
    HookDirect3D12=1
    HookOpenGL=1
    HookVulkan=1
    InjectionDelay=15000

    Is there anything that can be tweaked so RivaTuner stops stutering the game?
     
  2. RealNC

    RealNC Ancient Guru

    Messages:
    3,108
    Likes Received:
    1,338
    GPU:
    EVGA GTX 980 Ti FTW
    I don't know the answer, but as a side note, you can remove "LimitDenominator=1000" from your profile file and just enter a fractional FPS value directly in the RTSS UI. You can do that if you install the latest RTSS beta. This makes it easier to change the FPS on the fly without having to restart the game every time, so you can check if raising or lowering the FPS cap slightly (in steps of 0.01 or so) helps or not.
     
  3. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB

    Well thanks man, that new version of RivaTuner makes testing frame rate limiting so much easier and quick. As for The Witcher 3, my only conclussion is that game is very poorly coded in some areas, the game does not respond well to certain things and the frame times on that game are a mess unless you "help" it somehow, very sad, but not a lot to be done. The same stuff happens on the other i7 4770 PC I have at home, despite the i7 being superior, if you use Windows 10 Full Screen Optimizations to get better frame times, the game takes the WHOLE CPU to a 100% for no reason, mainly at towns with lots of NPCs or cities. Lowering the setting itself does nothing.

    Without this Window settings active, the game goes back to normal a bit, but then the frame times makes me want to cut out my eyes.

    At this point, I am out of ideas, I will contact CDPR tech support to see if they know anything about this.
     
  4. emperorsfist

    emperorsfist Master Guru

    Messages:
    851
    Likes Received:
    465
    GPU:
    NVIDIA GTX 1080 8Gb
    A little question: have you disabled ingame vsync and the ingame frame limiter? As a side note, do you use any mods for Witcher 3?
     

  5. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Yeah, both of those are disabled. And yeah, I use a ton of mods lol, but the stutter issues I have can be "created" or so to say. Without RivaTuner frame rate limiter, I have zero stutter but in exchange, the frame time of the game goes to hell and makes it hard to play at some areas.

    With the nVidia frame rate limiter V2 from nVidia Inspector+RivaTuner frame rate limiter the game stutters less, but still has hitches; the cause is the same: RivaTuner frame rate limiter, which sucks because only RT can give proper frame times; well, there are alternative, but on this game only RivaTuner works.
     
  6. emperorsfist

    emperorsfist Master Guru

    Messages:
    851
    Likes Received:
    465
    GPU:
    NVIDIA GTX 1080 8Gb
    Hmm, and how does the Nvidiainspector framelimiting work without RTSS? Also, are you using max pre-rendered frames? If not, does setting them to 1 (instead of "app controlled") help? I too use RTSS with Witcher 3, and so far I haven't ran into these issues that plague you.
     
  7. RealNC

    RealNC Ancient Guru

    Messages:
    3,108
    Likes Received:
    1,338
    GPU:
    EVGA GTX 980 Ti FTW
    I think you should re-evalutate the importance of "ultra" settings. I'd recommend just targetting 75FPS or 60FPS. You have a 1060, so you should be able to do it at 1080p.

    The whole "half vsync" thing really is only useful for low-end machines or 30FPS-locked games.

    Motivational speech if you need it (helped me, I don't run anything at ultra it it hurts my FPS):



    If you're still hell-bent on doing it, first make sure half vsync actually works. Recent drivers seem to have issues with that setting, and many times it doesn't actually work. Disable all FPS caps first. Turn off in-game cap (Witcher 3 has one), no RTSS, no inspector cap. Does the game now get capped to 37.5FPS by the 1/2 vsync? If not, then that means /1/2 doesn't work, and that might be your problem.
     
    Last edited: Sep 6, 2018
  8. FAQU

    FAQU Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    RX 480 8GB
    Those stutters may be a result of the V-Sync method conflicting with RTSS frame limiter , since RTSS is a CPU-level FPS limiter , while the V-Sync method is done at a driver-level.
    For proper frame limitation try to use a driver-level FPS limiter such as Nvidia Inspector. Be aware though that Nvidia Inspector will add more delay (input lag) than RivaTuner
     
  9. Babel-17

    Babel-17 Member Guru

    Messages:
    116
    Likes Received:
    6
    GPU:
    RTX 2080 FE
  10. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Looks like a combination of RTSS, nVidia control panel frame rate limiter and v-sync can make the game smoother. Only happens with the Witcher 3. Without the nVidia control panel frame rate limiter, the game kind of gets a stroke and its like it does not know what to do (hitches and frame time spikes), even with RivaTuner active. All of this with capable hardware.
     

  11. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Do you use DDR4 RAM?
     
  12. emperorsfist

    emperorsfist Master Guru

    Messages:
    851
    Likes Received:
    465
    GPU:
    NVIDIA GTX 1080 8Gb
    Yes, I do. I have 16Gb DDR4 RAM.
     
  13. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Its possible that the game runs much better with RivaTuner and does not get affected by the fps limit layer due to the faster RAM, perphaps on DDR3 RAM there are more issues.
     
  14. RealNC

    RealNC Ancient Guru

    Messages:
    3,108
    Likes Received:
    1,338
    GPU:
    EVGA GTX 980 Ti FTW
    I'm on DDR3 (1600) and it's fine.
     
  15. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,411
    Likes Received:
    1,497
    GPU:
    Zotac GTX980Ti OC
    You mentioned ton of mods, are you sure it's not one of the mods causing it?
     

  16. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    I will try that, I will disable most of them and I will report back.
     
  17. RealNC

    RealNC Ancient Guru

    Messages:
    3,108
    Likes Received:
    1,338
    GPU:
    EVGA GTX 980 Ti FTW
    You haven't answered the question of whether or not 1/2 vsync actually works. Disable ALL frame limiters. Do you get 37.5FPS? If not, 1/2 vsync wasn't working to begin with.
     
  18. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    1/2 v-sync works perfectly fine without any frame rate limiter. I do get 37.5 fps or 37 fps if I set the monitor to 74 Hz. Managed to get what seems to be no stutter at all by limiting the frame rate to 37.001 from 74.001 Hz with 1/2 v-sync. 37.000 and 36.999 make the game stutter.
     
  19. RealNC

    RealNC Ancient Guru

    Messages:
    3,108
    Likes Received:
    1,338
    GPU:
    EVGA GTX 980 Ti FTW
    I mentioned it in my previous post. Was just making sure you know that sometimes 1/2 vsync doesn't "stick" for some reason (driver bug probably.)
     
  20. Smough

    Smough Member Guru

    Messages:
    161
    Likes Received:
    21
    GPU:
    GTX 1060 3GB
    Sorry if I acted a bit rude, I deleted that post lol.
     

Share This Page