Witcher 3 constantly crashing nvlddmkm?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by skacikpl, Jul 20, 2015.

  1. skacikpl

    skacikpl Master Guru

    Messages:
    488
    Likes Received:
    161
    GPU:
    MSI RTX 2070 8G
    Am i the only one who's having consistent driver stability issues when playing Witcher 3 ever since release, with numerous different drivers and game patch versions?

    Juggling different game and driver versions just lets me increase/decrease stability, but i've never achieved 100% stability.

    353.49 and 1.07 are absolute pinnacle of instability. I've seen russian people high on vodka and crocodile who performed better than that setup.
    Driver crashes within 5 seconds from start of anything 3d being rendered on screen in Witcher.

    Windows event log just points that nvlddmkm crashed and recovered. Ingame crash log ends with mentions of NVAPI so the culprit is certain here.
    I've tried downlcocking and upvolting the GPU but that merely postpones the crash.

    Just for the record, here's my setup:
    MSI Z87 GD65 Gaming
    I7 4770K @ 4GHz
    MSI GTX 970 4G
    16GB RAM @ 1333MHz

    Running on 8.1 Pro x64

    Tried many different drivers, best results were achieved with 350.12 (GTA V driver). Witcher 3 "game ready" and any newer driver are just various degrees of horrible.


    From what i can gather, many people with 970's and better cards get this problem with Witcher 3, isn't it a bout time we ask NVIDIA/CDPR to do something about this issue. Game's been out for 2 months now and, despite it's greatness it's barely playable for many on PC.
     
  2. Undying

    Undying Ancient Guru

    Messages:
    16,799
    Likes Received:
    5,688
    GPU:
    Aorus RX580 XTR 8GB
    I played last night 3h on my crappy 280X without single crash, AMD have no problems with TW3 so saying its barely playable on PC is just not true.
     
  3. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,168
    Likes Received:
    1,998
    GPU:
    GTX1070 iChillx4
    Are you running a OC ?
     
  4. skacikpl

    skacikpl Master Guru

    Messages:
    488
    Likes Received:
    161
    GPU:
    MSI RTX 2070 8G
    Yes i am, but even when underclocked it'll eventually crash.
    It's proven that there's some sort of relation between GPU OC and the game's stability, but sorry i am not going to cripple my GPU for the sake of single game, especially since it does not make stable, it merely delays the inevitable.
     

  5. stereoman

    stereoman Master Guru

    Messages:
    816
    Likes Received:
    137
    GPU:
    Palit RTX 3080 GPRO
    Working fine on my 980, no issues, only thing I can suggest is check your temps, increase the voltage on your overclock, disable any programs that could be interfering with the game also make sure to run the game as administrator, that can help sometimes.
     
  6. NyanOverlord

    NyanOverlord Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GeForce RTX 2060
    Having same issues with MSI GTX 960 OC, my temps is around 65-67C under load in TW3, playing almost all maxed out with 35 fps (lowest).
    I'm using 353.30 WHQL drivers, will download 353.49 and try again.
    Update: well, seems 353.49 fixed this game for me, no crashes so far.
     
    Last edited: Jul 20, 2015
  7. skacikpl

    skacikpl Master Guru

    Messages:
    488
    Likes Received:
    161
    GPU:
    MSI RTX 2070 8G
    Temps are fine, so is the voltage (given everything else is stable).
    Especially when i try it when underclocking, i mean would it really require me to upvolt it while downlocking? GG WP.

    Besides that, i contacted CDPR support which suggested me this tweak:
    https://support.microsoft.com/en-us/kb/2665946

    And NV CP settings (which i already had on, besides Vsync).
    Though something is on the mark with the external VSYNC as using one, either via NVCP or RTSS it postpones the driver crash by a fair bit of time.

    Now it runs for about 10 minutes instead of 10 seconds before crashing the driver.
     
    Last edited: Jul 20, 2015
  8. JohnLai

    JohnLai Member Guru

    Messages:
    136
    Likes Received:
    7
    GPU:
    ASUS GTX 970 3.5+0.5GB
    Use RTSS to lock witcher 3 frame rate to 30fps.
    In game disable vsync, use borderless windows and set unlimited frame.

    You will be suprised on how long you can game before the nvlddmkm pop up......
     
  9. skacikpl

    skacikpl Master Guru

    Messages:
    488
    Likes Received:
    161
    GPU:
    MSI RTX 2070 8G
    At this rate i may have just bought a console...
     
  10. JohnLai

    JohnLai Member Guru

    Messages:
    136
    Likes Received:
    7
    GPU:
    ASUS GTX 970 3.5+0.5GB

    I feel the same.
    But my Asus GTX970 with 30fps rtss lock for witcher 3 at all ultra including hairworks..... plus little overclock ;

    Core Voltage +20mV,
    Power limit 120%
    Core clock +207Mhz
    Memory clock +345Mhz

    ....I can run witcher 3 for 5 - 6 hours before the game itself decides to crash (not display drivers has stopped responding error, it is the game itself crashes)

    Edit: at 1080p resolution 60Hz....
    Edit2: If I set the RTSS frame lock to 60fps, the 'nvlddmkm' error will pop out after running witcher 3 around 10 minutes or less.
     
    Last edited: Jul 20, 2015

  11. Whiplashwang

    Whiplashwang Ancient Guru

    Messages:
    2,316
    Likes Received:
    238
    GPU:
    RTX 3090 FE
    If you'd rather play at 20-30fps then go for! The Witcher 3 is really sensitive to overclocking. I have to reduce my stock oc because of how unstable the game is.
     
  12. mansonfamily

    mansonfamily Member

    Messages:
    45
    Likes Received:
    2
    GPU:
    MSI 2080 Ventus OC
    Just disable Nvidia Streamer Service.
     
  13. KillerC

    KillerC Master Guru

    Messages:
    417
    Likes Received:
    0
    GPU:
    EVGA 2080 RTX
    I have a Factory overclocked EVGA 980GTX and I was plagued with this problem with the drivers I'm using 353.49. And I found something that got it to stop. If Mansonfamily's workaround doesn't work.......you can try this as a more radical approach.

    I'm not offering this as a solution, I am merely going to tell you what I have done to completely stop "driver stopped responding errors and any crashes in Witcher 3 for me.

    You can try it or not, but I have just finished 2 full days (30 hours of play time) with only ONE crash, and it wasn't a DSR, it was the one where the FMV cut scene just stops and then minimizes the game, you still hear voices it just never goes back to full screen...blah blah

    Anyways, I found this on the STEAM W3 Community forums:

    Before launching W3, right click and turn off/exit NVIDIA experience from the tray

    go into "Task Manager"

    scroll down to the bottom of all the Nvidia stuff running
    (everything but the 3D which should be farther down from the main NVIDIA services)

    one at a time from the BOTTOM UP "end task" ALL of the Nvidia running services
    (giving each one time to end their tasks as they may end others above them as well)

    all the way up to "NVIDIA Backend", leaving NVIDIA backend running, only because it doesn't seem to affect anything in the game.


    and then play Witcher 3 with ANY settings you want DSR free!!


    Like I said, I don't usually offer or share fixes because I don't want to hear "it doesn't work" or "that's not a fix" or whatever, IF YOU WANT try it, if it works great, if it doesn't than I'm sorry but it works perfectly for me.

    And if you don't want to try it then have a nice day and good luck. :cool:
     
  14. yosef019

    yosef019 Ancient Guru

    Messages:
    2,156
    Likes Received:
    10
    GPU:
    EVGA 1080 ti
    try 353.49 drivers HF
     
  15. skacikpl

    skacikpl Master Guru

    Messages:
    488
    Likes Received:
    161
    GPU:
    MSI RTX 2070 8G
    This so far seems to be best solution.

    Played over an hour with 1.07 and it didn't crash so far.
     

  16. Sabbath

    Sabbath Maha Guru

    Messages:
    1,018
    Likes Received:
    39
    GPU:
    RTX 2080 Super
    No problem here play's better then ever. Clean install went from patch 1.01 too patch 1.07 work'ed grate. Play'ed 5 hour's 40 min not one freezes hiccup shouter or crash using driver 353.49 @1920*1080 and that's ultra setting's put it on 30 fps play's butter smooth for (ME) that's this system too
     
    Last edited: Jul 21, 2015
  17. DeathAngel74

    DeathAngel74 Master Guru

    Messages:
    478
    Likes Received:
    0
    GPU:
    GTX1080Ti FTW3 Hbrd
    [​IMG]
    Been playing the witcher 3 @1440p since sunday, clean install and 353.51 beta drivers.
    Batman Arkham Knight, on the other hand.....used to crash within minutes until I lowered my cpu oc to 4.4Ghz from 4.5Ghz and -13Mhz Gpu from 1569/4001 to 1557.0/4000
     
    Last edited: Jul 23, 2015
  18. DreamTheatrics

    DreamTheatrics Member Guru

    Messages:
    105
    Likes Received:
    0
    GPU:
    EVGA GTX 980 Ti SC
    What in game settings are you using? Try disabling hairworks and report back.
     
  19. Timesgodjillion

    Timesgodjillion Member Guru

    Messages:
    170
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 ACX 3.0
    I beat the game around 70 hours (because **** Skellige) and I never crashed once. And I was using GTX 980 SLI and switching to GTX 980Ti SLI halfway through. Both sets of cards were overclocked 100% of the time I was playing the game.
     
  20. bigfutus

    bigfutus Master Guru

    Messages:
    530
    Likes Received:
    56
    GPU:
    MSI GTX 1080 Ti
    353.30, overclocked 970, no crashes here.
     

Share This Page