1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Winver 1903 first thoughts !

Discussion in 'Operating Systems' started by IchimA, May 22, 2019.

  1. IchimA

    IchimA Master Guru

    Messages:
    967
    Likes Received:
    73
    GPU:
    G1 1070
    So , Just upgraded my system to 1903 and the update for me went smooth like butter. An what I can say after about 3 hours of testing is that every single game runs better . Smother ... I do not see an increase in FPS but it's defenitly better . Something feels right . Also Autodesk Civil3D feels snappier .

    Any similar exp to mine !?
     
    akbaar and eGGroLLiO like this.
  2. aka2k

    aka2k Member Guru

    Messages:
    122
    Likes Received:
    26
    GPU:
    Geforce 8800 GS
    I thought I was seeing things with Autodesk 3DS Max running better on 1903. It actually might be something.
     
  3. Chert

    Chert Active Member

    Messages:
    58
    Likes Received:
    2
    GPU:
    Zotac GTX 1070
    Yep. I also noticed that games seem to run smoother and better too. Looks like MS did good (which is a rarity) with this update.
     
    akbaar and eGGroLLiO like this.
  4. maur0

    maur0 Master Guru

    Messages:
    757
    Likes Received:
    37
    GPU:
    point of view gtx 570 1gb
    1903 is more faster for games compared to old build 14393.2999? WDDM 2.1

    [​IMG]
     

  5. Alessio1989

    Alessio1989 Maha Guru

    Messages:
    1,376
    Likes Received:
    231
    GPU:
    .
    2019 update 3 takes 1 our to install... not sure what improvement wish you to see, but on 1809 it took 10 minutes on the same system...
     
  6. jbmcmillan

    jbmcmillan Ancient Guru

    Messages:
    2,656
    Likes Received:
    193
    GPU:
    Gigabyte G1 Gaming GTX970
    Took mine about 30 minutes same time it took for 1809.
     
  7. Alessio1989

    Alessio1989 Maha Guru

    Messages:
    1,376
    Likes Received:
    231
    GPU:
    .
    I inspected the msiexec process using the portmon.exe sysinternal utility and it was damn slow on each file... The entire 3DS Max 2019 installation from scratch took less than 10 minutes...
     
  8. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,814
    Likes Received:
    80
    GPU:
    GTX 980/290X
    Upgrade took a bout half an hour, its running fine, have yet to try the sandbox feature.
     
  9. Passus

    Passus Maha Guru

    Messages:
    1,096
    Likes Received:
    202
    GPU:
    GTX 1060 3GB
    30 mins,, 1 hour???? wth mine does it in like 15 mins or less,, upgrade or clean install

    Just SSD drive but i always disconnect my data drives when upgrading or clean installing
     
  10. Alessio1989

    Alessio1989 Maha Guru

    Messages:
    1,376
    Likes Received:
    231
    GPU:
    .
    We were talking about Autodesk 3DS Max installation time and it's last update (Update 3), and the latter took a gazillion time for apply a ~700MB patch on my main system....
    As for Windows, the upgrade and the clean installation process took more or less the same time, like ~20 minutes, but I do not disconnect all my secondary drives (4x4TB +1TB of additional HDDs).
     
    Passus likes this.

  11. Passus

    Passus Maha Guru

    Messages:
    1,096
    Likes Received:
    202
    GPU:
    GTX 1060 3GB
    Ah as usual my bad :)

    I unplug the drives so i dont get recovery partitions on all of them,, just a bit ocd with it lol
     
    GetMax likes this.
  12. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,379
    Likes Received:
    1,473
    GPU:
    Zotac GTX980Ti OC
    It's ok, better then expected as far as normal 1809 to 1903 upgrade goes. No real issues like by rs4 to rs5..
     
  13. aka2k

    aka2k Member Guru

    Messages:
    122
    Likes Received:
    26
    GPU:
    Geforce 8800 GS
    I'm using either 2018 or 2020, but mostly 2018 and it works quite fine. I might try 2019 to see if it behaves the same as yours setup. But as far as updates goes, they seem to take forever regardless of the OS version for me.
     
  14. xV_Slayer

    xV_Slayer Member

    Messages:
    16
    Likes Received:
    2
    GPU:
    RTX 2080 Ti
  15. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,985
    Likes Received:
    8
    GPU:
    MSI GTX1080 Ti Gaming X
    I've been trying the insider edition before RTM and I was getting random freezing which lasts between 5-10 seconds with 100% usage on my platter drive. I did a clean install of 1903 with latest updates once it became RTM and I'm still getting the same issue. I can't replicate the issue as it's completely random. I've upgraded/downgraded drivers, removed and swapped hardware and usb peripherals, uninstalled software to no avail. 1809 and earlier does not cause this issue. Has anyone else experienced this?
     

  16. Chastity

    Chastity Ancient Guru

    Messages:
    1,941
    Likes Received:
    478
    GPU:
    Nitro 390/GTX1070M
    Nosir, but my system is all SSD internally, with 2 external platter drives.
     
  17. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,985
    Likes Received:
    8
    GPU:
    MSI GTX1080 Ti Gaming X
    I have 5 ssd with 2 platters. But I don't think it's directly related to the hardware. I'm thinking it's drivers as usual. I just can pin down which one. I'll stay on 1809 for a while and hopefully in a few months everything will smooth out.
     
  18. aka2k

    aka2k Member Guru

    Messages:
    122
    Likes Received:
    26
    GPU:
    Geforce 8800 GS
  19. Amaze

    Amaze Ancient Guru

    Messages:
    3,038
    Likes Received:
    474
    GPU:
    1070ti 2114/4375
    I don't know what is causing it but every once in a while videos start stuttering for a few minutes and the mouse feels really laggy.
    I tried running Latencymon but it just stops after 16 secs.

    Disabling Stop Monitors when Event Buffers are lost fixed the stopping. Don't know if this is a bad thing.

    Got this after running for 10 mins.
    Highest measured interrupt to process latency (µs): 2207.90
    Average measured interrupt to process latency (µs): 3.707441

    Highest measured interrupt to DPC latency (µs): 2197.20
    Average measured interrupt to DPC latency (µs): 1.331980

    Highest DCP driver seems normal?

    Highest DPC routine execution time (µs): 53.754862
    Driver with highest DPC routine execution time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation
    Highest reported total ISR routine time (%): 0.000015
    Driver with highest ISR total time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

    Here's from a 53 min run, I don't really know how to interpret these random spikes.
     
    Last edited: Jun 1, 2019
  20. xV_Slayer

    xV_Slayer Member

    Messages:
    16
    Likes Received:
    2
    GPU:
    RTX 2080 Ti
    Related to the DPC latency spikes. I went back to a clean 1809 install and all is well again. I suggest you do the same. Build 1903 is a joke.
     

Share This Page