Windows Desktop Choppy on 144hz Monitor.. Drivers?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Baldassano, Oct 7, 2013.

  1. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    I have noticed with the last 2 drivers i have tried from Nvidia (Currently on the latest beta 331.40) that previous drivers, on my main screen, which is an asus 144hz 27", even tho the screen is set at 144hz, the windows desktop (dragging windows, minimizing) is acting choppy like the secondary window (24" samsung 60hz)..

    Now i know of the bug where if you dragged one of the windows close to the edge of the screen it would take on the Hz of the other one, i think i described that correctly (aka the 27" would get choppy like the 24", not vice cersa obviously)..

    Now if i mess with it, click on and off windows, it picks up smooth again, then draggin it around, goes choppy again..

    Has anyone else who has a fast Hz LCD noticed this? Im just curious.
     
  2. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,631
    Likes Received:
    14
    GPU:
    MSi GTX980 GAMING 1531mhz
    I have a benq XL2411T, i think has the same panel as your asus monitor. No, i didn't noticed this thing, mine is smooth on desktop, moving windows, dragging, etc.

    Probably your eyes are used with 144Hz and want more ?

    When i first bought my 144hz monitor, and then i switched to 144hz i was blown away, saw soo smooth, but now after some months using high Hz, my eyes feels like wants more...
     
  3. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    LOL We always want more.. but sadly no, this is some kind of bug or something im noticing.. It doesnt affect gaming (i dont think) but its noticeable enough on the desktop that its annoying the heck out of me.

    Im gonna try disabling monitor 2 just to see if its a dual/sli bug or something.. Have to do it when i get home.
     
  4. Outcasst

    Outcasst Member

    Messages:
    46
    Likes Received:
    1
    GPU:
    GTX 1080 Ti
    I've had exactly the same experience, however it only happens on Windows 8.1

    I've done several re-installs and the only thing which fixes it for me is installing my audio drivers (asus xonar). Strange solution, but it works.
     

  5. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,631
    Likes Received:
    14
    GPU:
    MSi GTX980 GAMING 1531mhz
    Sad thing is that in gaming on 144hz/120hz monitors, when you play games on 60fps cap they play very jerky, i mean is not smooth when you more the mouse around. Only if you play games on more than 75fps, then you get smoothness (smoothness like in only-60hz monitors).

    I noticed this then i bought my 144hz monitor. Fps cap on 60fps in games then compared with the same fps but with an only-60hz monitor, and its smoother on 60hz monitors.
     
  6. sapo_joe

    sapo_joe Master Guru

    Messages:
    614
    Likes Received:
    38
    GPU:
    ASUS RTX 3070 OC
    Perhaps it's something in the drivers "syncing" the refresh rate between the two displays...

    I'd test them individually (one display mode).

    Maybe, when you first set the primary display to work in 144hz, and THEN configurin the socondary... Hope it helps! :nerd:
     
  7. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    Thanks for the imput Joe, i definatley have to test it with the secondary monitor off.. I personally think your right, and i know there was a noted bug someplace that someone had found that if you took a window on the 144hz monitor and moved it to the edge of the screen, it would then lose its smoothness and get choppy like the 60hz screen (it was like an inch or 2 near the side that the monitor is located on).. But usually everything was ultra smooth.. I only have noticed this on the last 2 drivers i have used..

    More testing tonight.
     
  8. drbaltazar

    drbaltazar Banned

    Messages:
    416
    Likes Received:
    0
    GPU:
    amd 7950 3gb
    Is your monitor set to sRGB?is color management set to wcs srgb virtual or wharever?
    Make sure your GPU isn't doing sRGB otherwise you don't get the acceleration ms implemented for srgb
     
    Last edited: Oct 7, 2013
  9. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    Hmm, i never changed that, it should be whatever default is, but i will double check.
     
  10. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    Just an update.. I turned off the 60hz screen and the 144hz screen was completely smooth, and i couldnt make it stutter...

    I reenabled the 60hz screen and it seems to be as it was before, if i drag a window over to the other screen it drops to 60hz (as it should) and if i bring it back it goes to 144hz and smooth as silk..

    So far it looks like simply disabling the 2nd screen and re-enabling in the Nvidia CP has done the trick :D
     

  11. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    749
    Likes Received:
    120
    GPU:
    RTX3090 EVGA FTW
    Sort of unrelated, but on Windows 7, the idle clocks/voltage on cards kicks up a lot with 144Hz + a second 60Hz monitor, the only way to get it down to proper idle clocks is to set 120Hz. Could you check if it's the same on Windows 8?

    Pic shows the difference between idling on the desktop with 144Hz, and then the drop is when switched to 120Hz.
    [​IMG]
     
  12. applejack

    applejack Master Guru

    Messages:
    584
    Likes Received:
    4
    GPU:
    MSI 3070 Ventus 3X
    I'm on a single 144hz (asus) monitor, and while win7 window dragging is super smooth, it just isn't in win8.1. it feels choppy. also no option for aero in 8.1.
    using latest betas on both. only reason I use win8.1 in dualboot is for BF4 beta to run decently (its a stuttering mess in win7).
    should I try win8 instead of 8.1 ?
     
  13. Baldassano

    Baldassano Member Guru

    Messages:
    173
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
  14. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,667
    Likes Received:
    346
    GPU:
    MSI Geforce GTX 1080
    Nvm.
     
    Last edited: Feb 3, 2014
  15. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,631
    Likes Received:
    14
    GPU:
    MSi GTX980 GAMING 1531mhz
    Lol, i posted this fix long ago in some thread here on guru.

    That fix is for windows 8.1 due to having some problems with mouse. And i think the OP had a different problem.

    Also in the article from MS is a important notice about putting explorer.exe into reg file or other windows related stuff.

    Important You should apply the registry key mechanism only to games that are known to be affected by this issue. If you set this registry key outside the scope of the games that require this registry key, the performance of the computer battery may be affected. Specifically, do not apply the registry key mechanism to long-running background and notification area processes.
     

  16. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,667
    Likes Received:
    346
    GPU:
    MSI Geforce GTX 1080
    You are right , I have read a bit too fast... And I saw your thread too.
    Post edited.
    Thanks for noticing.

    As for the battery, it will just make it similar to windows 8.
     
  17. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,631
    Likes Received:
    14
    GPU:
    MSi GTX980 GAMING 1531mhz
    No problem. Its good though we have a fix for windows 8.1 mouse issue. Also i really don't know why they don't fix this issue with a update....maybe for that important notice they have on that MS article...

    Yes it will make it similar to windows 8.0

    I recently asked some MS MVP on the microsoft forums about this notice, and he didn't reply...

    That fix was designed for games applications, but someone found out if he put explerer.exe into the reg will actually fix the issue. :)
     
    Last edited: Feb 3, 2014
  18. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    Yes, at the page, it also said that it is affect for the platform, so just adding the always running process which is explorer.exe will always apply. ;)
     
  19. ßÍöHÅZÅRD§pëRM

    ßÍöHÅZÅRD§pëRM Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    EVGA-680 FTW+
    i have the Asus 24 144Hz and a Samsung 60Hz ,win 8.1/GTX 680FTW+ 4Gb ive not had any such issues with any of the last 4 drivers
     
  20. Phroster

    Phroster Master Guru

    Messages:
    285
    Likes Received:
    4
    GPU:
    Asus Strix 980 Ti


    I think if you cap a 144 hz monitor to 60 fps, the FPS will not be evenly divided each second.

    Try capping it at 72 fps. 144hz / 2 = 72hz
     

Share This Page