Windows 7 Backup and Restore issue - sees two system drives!

Discussion in 'Operating Systems' started by Darren Hodgson, Nov 8, 2009.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    Just to bump this thread and hopefully get some fresh ideas/help...

    I've come across a really strange issue that prevents me from using the Windows 7 Backup and Restore tool to image my C: drive (Crucial CT128M225 - 119 GB capacity, 84 GB free) to another hard drive, G:. For some reason, it sees both the C: and E: drives as System ones so when I try to image it, I get an error message stating that there is insufficient space on G:. Drive E: is some 480 GB in size and contains my game installs and backup data. Unfortunately the software doesn't allow me to deselect drive E: from the system image as it is greyed out and unselectable.

    I contacted Microsoft about this before Christmas but they were unable to help me. They suggested I backup the C: drive by deselecting the system image option and selecting the C: drive itself but that only backups user data and not Windows itself. If I view the hard drives under the Disk Managment tool then only C: is shown as the system drive, E: is just a normal partition. Microsoft did suggest I reformat the drive and I did try this after I'd backed up the contents to an external drive. When the drive was formatted, the Backup and Restore tool only showed C: as the system drive (as it should be) but when I restored all the files back to to E: (using the Windows Copy command) the tool decided that E: was a system drive again!!!

    I've examined the E: drive contents with hidden and protected files shown and there are no Windows system files on the drive nor is there a page file or any system restore points (it is disabled for that drive). I think the problem may have been caused by having had Windows 7 RC installed on the E: drive when I was dual-booting it with Windows Vista. Because I had dozens of games installed on E: when I did an in-place upgrade of Vista to 7 I just removed 7 RC from the bootloader using VistaPROBoot and deleted the Windows files from E:.

    It was a bit of a nightmare though because even though my PC was no longer using any of the 7 RC files, many of the files and folders were protected, preventing me from deleting them. In the end I had to tweak user access rights to make the files deletable and use FileASSASSIN to delete the remaining stubborn folder and files. As far as I know the drive is now clean of Windows 7 RC files and folders and I've not had any problems installing games to the drive since.

    Does anyone know what happened to make Windows 7 still think E: is a system drive and how I might be able to fix it? Is it a case of rewriting the BCD (whatever that is) as I've already rewritten the MBR using EasyBCD 2.0 beta and it didn't make any difference?

    Incidentally, Acronis True Image Home 2010 works fine and images only my C: drive, it seems that it's just the Windows 7 equivalent that doesn't. Obviously isn't a big deal as I have Acronis but I would like to be able to also use Backup and Restore to image my C: drive so I have a second backup in case Acronis fails.

    Thanks... and sorry for the long post.
     
  2. m72899

    m72899 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI Radeon 4600 Series
    I solved the same problem just a moment ago.
    There are two partitions on my HD. One for the OS and the other for data. The Backup and Restore tool insisted on backing up the data partition too. It showed '(System)' for that partition and the box was greyed out.

    I also have a TV card, and the folder for the records is on the data drive.

    For a test, I tried to remove the letter of the data drive inside the Disk Management tool. But it warned me that the drive was in use!

    A find for a handle with the drive letter in ProcessExplorer (only when started with admin rights) then showed that svchost.exe had some handles to 'System Volume Information' and another obviously OS-internal file, and 'wmpnetwk.exe' had the folder 'Recorded TV' on that drive open.

    Wmpnetwk turned out to be a 'Media Player Library Network Share' process (sorry for my english. Btw I have 'backup and restore user data' turned on on that system and had to do a full system restore three days ago - and I obviously never had opened Media Player since - because it asked the first-time questions when I did now. Still there was this process and handle!)
    Within Windows Media Player, the 'Recorded TV' library was easy to find. In the process of removing it, I got a strange confirmation dialog saying something like "If you remove this share, you must share the folder yourself, or if you don't, the library is removed, but the share persists" (this is a comprehensible translation of the dialog). When I had removed the share, I was able to remove the drive letter for the data partition, but the drive was still included as System for the backup.
    But after a reboot, Windows now accepts that the data partition is not a system partition - although I reassigned the drive letter.

    So, this time it was a problem of an automatically generated share that I was completely unaware of. It seems quite natural that users put media libraries to data drives - so similar cases with music or other libraries could occur. I am sure I did not allow or activate any such option. Now I ask myself how many shares of strange types my system might keep ready...

    You said that when your 2nd drive is formatted, it is not included. That was the key hint for me. It must have to do with the data on it (like 'Recorded TV' in my case). If my experiences do not help you, I propose that you recover your data on the drive from the external drive step by step to find out which of your data or folders make Windows consider it a system drive.
     
  3. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    Thanks for the post, m7289.

    I'll use it to see if I can finally solve this annoying problem when I've got a bit of free time, hopefully this weekend.
     
  4. Devolution

    Devolution Ancient Guru

    Messages:
    2,044
    Likes Received:
    0
    GPU:
    5850 Radeon HIS 1024MB
    You have a SATA drive and an IDE drive don't you...
     

  5. jrcallan

    jrcallan Active Member

    Messages:
    87
    Likes Received:
    0
    GPU:
    EVGA 8600gts
    I have the same problem. My system drive is C:, and a second HD is partitioned as D-E-F-G. But Backup/Restore won't permit backup to E: - it sees it as a drive Windows is installed on/from. I've never installed am OS on E --so that's not the problem.

    W7 will allow backups to D, F or G -- but not E: ???
     
  6. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    I have four SATA drives (one SSD and three HDDs) plus a DVD-Rewriter that is using EIDE... why?
     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    We're not the only ones as you can see here:

    http://social.technet.microsoft.com...l/thread/b8e726fc-9f95-4416-9212-7e24b01a111c

    Seems to be a bug...
     
  8. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    I *FINALLY* solved this annoying issue... thanks to m72899.

    What had happened on my machine was that Dragon Age Origin had been installed to the E: drive but the game also installed an updater service in the same folder. Windows 7 sees services as system files so it flagged E: as a system drive. I'd also installed the Dragon Age Toolset as well which also installs a SQL Server (BWDATOOLSET) service that is referenced to the E: drive. This also causes Windows to see E: as a system drive too.

    I've had to copy the DA Updater Service to a new folder on my C: drive (Program Files/Dragon Age Origins Updater) and change the reference to the service from E: to C: in the registry. I can now do a system image of C: and C: alone!!!

    My advice to anyone with this issue is to check carefully through the services and see where they're linked to. If you have any services running on drives other than C: then Windows will see that it as a system drive.
     
    Last edited: Jan 21, 2010
  9. Cybermancer

    Cybermancer Don Quixote

    Messages:
    13,795
    Likes Received:
    0
    GPU:
    BFG GTX260OC (192 SP)
    So the fix m72899 posted isn't working either, Darren Hodgson?
     
  10. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,104
    Likes Received:
    603
    GPU:
    Palit RTX 3080
    Well it was m72899's post that helped me fixed my problem as his was also related to a service, the Wmpnetwrk one, which was pointing to a non-system drive where his video folder was. In my case, I had updater and SQL Server (BWDAToolset) services for a game, Dragon Age Origins, that were pointing to my E: drive so Windows flagged it as a system drive. The fix is just to either remove the service or relocate it to the default system drive ( C: ).

    For anyone else having this issue, all you need to do is scan through the list of Services in Services.msc and check the properties of the non-Microsoft ones that have been installed to check that they're on the C: (system) drive. If they aren't then you'll find the Backup and Restore tool will include more than one system drive when you try to image Windows and you'll need to do what I suggested above and in my earlier post.
     
    Last edited: Jan 21, 2010

  11. Cybermancer

    Cybermancer Don Quixote

    Messages:
    13,795
    Likes Received:
    0
    GPU:
    BFG GTX260OC (192 SP)
    Thanks for the explanation, Darren Hodgson. :)

    I guess, I must have missed the post above mine somehow... :rolleyes:
     
  12. Devolution

    Devolution Ancient Guru

    Messages:
    2,044
    Likes Received:
    0
    GPU:
    5850 Radeon HIS 1024MB
    Because there is a known bug with Windows 7...or just X86/64 period that when you have a IDE HDD and a SATA HDD installed on the same mobo, most of the time it defaults for the IDE to be primary. Also, for some jacked up reason Windows 7 installation takes the EIDE drive as default. So...when you install Win 7 with that kind of set up, you have to disconnect the IDE drive, install on the SATA, THEN reconnect the IDE.

    ...but since this wasn't your problem and your problem was simply Dragon Age being ridiculous, no biggie.
     

Share This Page