Windows 10 & SSD: disable prefetch and superfetch?

Discussion in 'SSD and HDD storage' started by TheF34RChannel, Oct 19, 2015.

  1. TheF34RChannel

    TheF34RChannel Master Guru

    Messages:
    277
    Likes Received:
    3
    GPU:
    Asus GTX 1080 Strix
    Or should I leave it on?
     
  2. Undying

    Undying Ancient Guru

    Messages:
    19,458
    Likes Received:
    7,802
    GPU:
    RTX 2080S AMP
    Prefetch and superfetch, indexing, hibernation, everything off.
     
  3. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,652
    Likes Received:
    271
    GPU:
    RX 580 8GB
    I turn all those things off.
     
  4. jura11

    jura11 Ancient Guru

    Messages:
    2,641
    Likes Received:
    705
    GPU:
    RTX 3090 NvLink
    Hi there

    Agree with above there,I've turned everything off on the SSD,I've turned off too Windows Search as SSD is fast enough

    Hope this helps

    Thanks,Jura
     

  5. TheF34RChannel

    TheF34RChannel Master Guru

    Messages:
    277
    Likes Received:
    3
    GPU:
    Asus GTX 1080 Strix
    Thanks guys!
     
  6. kakarot

    kakarot Maha Guru

    Messages:
    1,126
    Likes Received:
    17
    GPU:
    gigabyte 3080 12gb
    Absolutely no need to do so, especially on win 10
     
  7. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,652
    Likes Received:
    271
    GPU:
    RX 580 8GB
    Why, what's different about Windows 10 to say Windows 8.1?
     
  8. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,549
    Likes Received:
    740
    GPU:
    RX 580 ♥ MESA 22.2
    I always disable all of those useless "features", but I always run into problems when playing ARMA 3 and GTA:V when running without a pagefile — you're probably better of just leaving it on auto.
     
    Last edited: Oct 19, 2015
  9. kakarot

    kakarot Maha Guru

    Messages:
    1,126
    Likes Received:
    17
    GPU:
    gigabyte 3080 12gb
    Never said you had to in 8.1 either. 7 was a little dumb sometimes but its been a long time
     
  10. Tree Dude

    Tree Dude Master Guru

    Messages:
    532
    Likes Received:
    3
    GPU:
    Radeon R9 270X 2GB
    That would cause a 16GB pagefile in your case. Some apps just want it to be there even if you have enough RAM that they would never actually use it. In those cases I set it to the minimum amount (200-400MB). I would set a custom 4GB pagefile if you have an app that is going to page a lot even with gobs of memory free. No sense wasting all that SSD space.
     

  11. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    13,303
    Likes Received:
    6,051
    GPU:
    2080Ti @h2o
    It would be great if such knowledge would be found in some sort of internet how to... you never get everything at one place.
     
  12. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,973
    Likes Received:
    1,167
    GPU:
    EVGA 1070Ti Black
    turn it all off, its used for HDD not ssd
     
  13. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,544
    Likes Received:
    2,174
    GPU:
    Zotac GTX980Ti OC
    I have all on and no issues, had the same in win8, ok except for hibernation..

    Intel SSD toolbox says its optimized and recommends it to be enabled in win8/win10.

    [​IMG]

    As for indexing, I turned off main indexing on drive and then indexed only the stuff I want in indexing service (music, pics, my documents).
    [​IMG]


    And pagefile set to fixed 800MB, just enough for BSOD viewer..
     
    Last edited: Oct 19, 2015
  14. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,973
    Likes Received:
    1,167
    GPU:
    EVGA 1070Ti Black
    samsung magician 4.7 still recommenced prefetch be turned off
     
  15. kakarot

    kakarot Maha Guru

    Messages:
    1,126
    Likes Received:
    17
    GPU:
    gigabyte 3080 12gb
    Samsung is smart that's why. Lets see how long it takes them to support 10 too
     

  16. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,973
    Likes Received:
    1,167
    GPU:
    EVGA 1070Ti Black
    they support windows 10 just not rapid mode.. and trim is done automatically by windows defrag
     
  17. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,544
    Likes Received:
    2,174
    GPU:
    Zotac GTX980Ti OC
    Well I have this SSD disk over 2 years now and its still WEI 8.1 score, just like when I first bought it along with win8.0, superfech was always enabled, pagefile - fixed also..

    Health is also at max, so I won't bother with this, its only for older win7 that its not optimal. But ok if you think its bad disable it. :)
     
  18. kakarot

    kakarot Maha Guru

    Messages:
    1,126
    Likes Received:
    17
    GPU:
    gigabyte 3080 12gb
    maybe some things work and some don't but even v47 which came out well after 10 still does not offer windows 10 support (officially at least). For example I would not trust it to do firmware until i see 10 support in the release notes;)
     
  19. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,973
    Likes Received:
    1,167
    GPU:
    EVGA 1070Ti Black
    my ssd already had it finalfirmware year or 2 ago
     
  20. TheF34RChannel

    TheF34RChannel Master Guru

    Messages:
    277
    Likes Received:
    3
    GPU:
    Asus GTX 1080 Strix
    Updated my SSD firmware last night... Enabled momentum cache as well.
     

Share This Page