Windows 10 refresh rate issues

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by brutlern, Aug 20, 2015.

  1. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    I have recently installed Win 10 and I have encountered an problem regarding the refresh rate. The desktop runs fine at 60 Hz but all my games default to 59 Hz (w/o the option to select 60 hz). I can tell the difference because the monitor flickers when alt-tabbing in and out of the game (because it has to apply a new display setting), but if I select 59 Hz for the desktop than the flickering is gone (no change is display setting).

    Running games at 59 Hz and not the native 60 Hz cause framerate issues (proly due to vsync being confused about proper refresh rate), the image is less crisp and the flickering is annoying when alt-tabbing (which I do a lot). Tried multiple drivers using DDU (353.84. 353.30 and latest 355.60) same result.

    Anyone else encounter any similar issues? Is it a Win 10 problem or an Nvidia driver problem. Any workaround for it?
     
  2. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    Try CRU. It's a great tool to actually modify the Screens EDID, i use it myself to overclock my Notebook Display from 60 to 110 Hz.

    My assumption is that you can try to add a new custom resolution with stock settings and only create a entry with the Hz upped from e.g 59.9Hz to 60.0Hz or 60.0Hz to 60.1Hz, you get the idea i guess, just adding +0.01Hz.

    Just select the monitor you use in the program (it's probably marked as [active]), and on the right side press (Add...), there on the lower side you see (Frequency) and there just modify the refresh rate a bit, then just restart and set it in Windows or Nvidia Drivers.

    And i know you could do that with nvidia Drivers directly too, but i noticed creating custom refresh rates with CRU actually let the games use it directly too, with Nvidia CR i could not force the 110Hz in DX9 games.
     
  3. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Gonna try CRU, thanks.
     
  4. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,837
    Likes Received:
    129
    GPU:
    EVGA 1080 Ti FTW3
    Yes, I did run into this issue a few hours after clean installing Win 10 on my gaming rig. I tried everything possible in the OS and AMD drivers before finally trying out CRU...and nothing ever helped in the slightest bit.

    I must have messed around with CRU for 5 hours and made hundreds of different attempts at getting the "1920x1080@60" options to be available in games, yet nothing ever worked. The closest I got was when Civ 5 and Splinter Cell Blacklist would allow me to use "1920x1080@61" but it was terribly washed out and also seemed to stutter.

    It was a different manner of stutter than the 59Hz stutter but it still ruined gaming on Win 10 for me. This has been by far the largest issue I've had with Win 10 thus far, seeing as most everything else is fine by me. ANY help or ANY clues that can be passed on from others would be great to help us solve this ridiculous issue.

    @OP - Hopefully CRU works for you. Just let us know. :)
     

  5. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    CRU works. Awesome. Basically, I deleted/deselected/deactivated all resolutions, and added just one at 60 Hz (LCD Native timing) and voila. Now all games have no choice but to use 60 Hz (the in-game options are even grayed out with 60 the only available choice).

    And to check that it works and not just placebo, the alt-tabbing is instantaneous, no flickering, confirming that both desktop and games are running the same settings.

    It does mess up DSR a bit, but that is expected since I deleted all other resolutions. I am still able to use DSR, the only weird thing is that the new ultra resolution(s) show up under standard resolutions rather than the separate Ultra resolutions group.

    The only question that remains is this a driver bug or a Win 10 bug, and are they doing anything about it (nVidia and/or MS).
     
  6. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    great that it works, and regarding your question i think it's both W10+Drivers, i think there was a issue with the release of W8 too which was similar.
     
  7. signex

    signex Ancient Guru

    Messages:
    8,708
    Likes Received:
    135
    GPU:
    Aorus RTX 2060 S
    Holy sh*t 110hz from 60?!?! without issues?

    My Alienware M17x R4 could do 90hz but it started to look weird+input lag.
     
  8. signex

    signex Ancient Guru

    Messages:
    8,708
    Likes Received:
    135
    GPU:
    Aorus RTX 2060 S
    Weird, i can't even get CRU to work, only DSR, but i think custom resolution looks much better then DSR.
     
  9. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Just spotted this new driver http://forums.guru3d.com/showthread.php?t=401966

    amongst other things "solving an issue with incorrect display timings."... could it be my exact problem? Gonna test it soon.

    Update: Just tested them, my refresh rate problem is still not fixed. My games are still only able to run at 59 Hz, not able to select 60 Hz. Back to CRU.
     
    Last edited: Aug 25, 2015
  10. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    my display maxes out at 127hz but like you said, i get bad artifacting and banding everywhere. i could actually do 113hz without errors, 114hz then makes a fine line from top to bottom on some colors. Using the Chi Mei Panel if you are wondering LVDS
     

  11. Shadowdane

    Shadowdane Maha Guru

    Messages:
    1,303
    Likes Received:
    12
    GPU:
    MSI RTX2080Ti
    wow yah that's a crazy overclock for a LCD!

    My Samsung LCD will run fine up to 76Hz, beyond that it will give me an Out of Range error. Oh and only over HDMI, if I try DVI anything beyond 60Hz gives out of range. lol
     
  12. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Just tested the new 355.80, still doesn't fix my refresh rate issues. So I'm still back at using CRU. On the other hand, seeing all this talk about oc-ing displays and since I am already forced to using CRU I thought I give it a go, and it does work. Currently running at 70 Hz (from native 60) with no visible issues.
     
  13. signex

    signex Ancient Guru

    Messages:
    8,708
    Likes Received:
    135
    GPU:
    Aorus RTX 2060 S
    CRU isn't even working for me sadly, could be the HDMI doing this don't know.

    Mine says it's succesful at 80 but it doesn't show that it does.
     
  14. Mda400

    Mda400 Master Guru

    Messages:
    746
    Likes Received:
    41
    GPU:
    1660 - 2130/10ghz
    Its not a driver or OS problem, its a compatibility measure with how older games/programs treat refresh rates.

    59hz in windows is actually 59.94hz (NTSC standard) sent to the display. 60hz in windows is also 59.94hz sent to the display.

    Why the same display frequency if different OS refresh rates?

    • Windows can't display decimal or partial whole numbers. 59hz allows newer programs with WDDM drivers to differentiate between true 60hz and 59.94hz.
    • 60hz is for those older programs to recognize that whole number refresh rate even though it isnt true 60hz, but 59.94hz in disguise.
    • Lastly the flickering or blackscreen in between desktop and application transitions are due to the switching of compatibility layers from 59 to 60hz and is up to the application fix.

    59hz is what you actually want to select. If a program that is using a DirectX version older than 10 and doesnt recognize 59hz, it will use the 60hz made available by the driver to prevent conflicts. It also fixes Vsync issues in some games that treated 59hz as 59.00hz and v-synced under refresh rate causing constant tearing.
     
    Last edited: Apr 18, 2017
  15. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Wow, that is a really awesome, and highly technical answer. But I still have some questions. I have the issue with BF Hardline and Elite Dangerous as well which are DX11 and why does everything work fine under Win 7 and why does 60 hz work fine when using custom resolutions with CRU?
     

  16. Mda400

    Mda400 Master Guru

    Messages:
    746
    Likes Received:
    41
    GPU:
    1660 - 2130/10ghz
    DirectX 10+ and refresh rates has behaved the same since vista (first OS to use the WDDM) so nothing should be less crisp or fluid from 59.94hz to the compatibility 60hz. Again both are sent as 59.94hz to your display.

    When you make a custom resolution it is done using GPU scaling as your display doesn't know the newly created resolution you made. So if you create 1440x1080p, it fits it into a 1920x1080 resolution with black side bars. The refresh rate is 60hz (or the native of your display) as the custom resolution is a compatiblity layer in its own existence and both must be scaled to your displays native resolution and refresh rate.

    You only see 59hz if its a resolution that is ATSC/NTSC designated and from the display's own edid memory. Something like 1024x768 is true 60hz as that resolution is a PC/VESA standard resolution which your display knows and can refresh at true 60hz.

    Also, even if you were able to display true 60hz, it would stutter on your 1080p screen as 1080p is an ATSC/NTSC resolution that defines a 59.94hz refresh rate for broadcasting. 60hz on a 59.94hz display would have every other frame overlap and stutter.
     
    Last edited: Apr 18, 2017
  17. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Another highly technical answer, thanks for educating me, but still doesn't answer my question as to why under Win 7 everything is peachy (even though you are saying that this has been happening since Vista), I can select 59 or 60 Hz on the the desktop AND in games as well, but in Win 10, while I can select 59 or 60 Hz on the desktop, I cannot select 60 Hz in games.

    The other thing that bugs me, is that how come nobody noticed that in Win 7 all your games had 60 Hz in the options, but when switched to Win 10, suddenly all the games that people have been playing for years with 60 Hz option selected, no longer have the 60 Hz option available. (even though the desktop still has the 60 hz option)
     
  18. Glottiz

    Glottiz Master Guru

    Messages:
    476
    Likes Received:
    125
    GPU:
    Strix 1080Ti
    I've been following the 59.94Hz issue ever since its first appearance in Window 8. There is a lot of confusion and false/misleading information regarding this issue.

    I haven't installed Windows 10 yet, but when I do I'll probably create a dedicated thread about this issue in hopes that it will get fixed eventually, although I'm skeptical since even MS doesn't comprehend this problem properly.

    This kb article ( https://support.microsoft.com/en-us/kb/2006076 ) is partly to blame for the confusion, as people just look it up when googling 59.94Hz, even MS employees themselves, and claim it's "normal" behavior. That article is about a different issue, not the one we talk about here.

    So I'll try to explain the issue as best as I can at this moment. Basically ever since Win 8, if you use a HDTV or a monitor with HDTV capabilities and use HDMI cable and try to play a game in full screen DX11 mode you can not select exactly 60Hz refresh rate. In most games you'll just see 59Hz or 59.94Hz listed twice, while if you were using Windows 7 and trying to play same games in DX11 you are able to choose 59Hz and 60Hz.

    Now there are a bunch of people claiming that 59.94Hz is the same as 60Hz (wrongfully quoting kb2006076 article I mentioned above), but I know for a fact that it's not the same.

    Proof #1 in windows 8 and up while in desktop I can choose 59.94hz and 60Hz, but when in DX11 game I can only choose 59.94Hz twice, and when I alt tab from game to desktop there's a long delay caused by refresh rate change from 1920x1080@59.94Hz to 1920x1080@60Hz, even HDTV reports this. In Windows 7 under same exact circumstances I can choose 59.94Hz and 60Hz in DX11 games, and alt tabing is instantaneous because display doesn't need to change refresh rate between game and desktop.

    Proof #2 59.94Hz isn't the same as 60Hz because it introduces micro-stuttering in some (all?) 60Hz rated displays. no such micro-stuttering happens when running 60Hz under Windows 7.

    Proof #3 In games that support multiple DX modes it's easy to test this. For example under Win 8 and up, in World of Warcraft running DX9 mode I can choose 59.94Hz and 60Hz, but in DX11 mode once again I can only choose 59.94Hz twice with no 60Hz option. Running 59.94Hz introduces annoying stuttering and mouse lag.

    Proof #4 Most HDTVs and HDMI capable monitors switch to "movie" mode when at 59.94Hz, so while in desktop you run PC mode because display receives 60Hz signal, but once again under Win8+ and DX11 you can only run 59.94Hz and display thinks you want to watch ntsc content and switches to "movie" mode or similar. This doesn't happen under Win 7 at all.

    I don't know yet if this also happens with DVI/DP cables (haven't had means to test it), my guess is no, as we would see a lot more complaints about this issue than we do now.
     
    Last edited: Oct 1, 2015
  19. brutlern

    brutlern Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Thank you for confirming that I am not insane. Also, you might be on to something regarding the HDMI 'cause that's what I am using with my monitor My monitor came bundled with only an HDMI cable, no DVI, so I had to use that but never had any issue up until trying Win 10 (I skipped Win 8). I have actually thought a lot about trying a DVI but I kept telling myself the problem can't be from a simple cable. But maybe it is, Windows/drivers detect HDMI, assumes you are using a TV, forces 59 Hz.
     
  20. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    322
    GPU:
    RTX 2080 OC
    A. I've said this so many times that this starts to sound like a broken record but - a pause / a flash / whatever when Alt-Tabbing is NOT a proof of a refresh change, it's a proof of a REQUEST for a display mode change. The resulting refresh can be the same as the original one.

    B. When someone says "microstuttering" I immediately wonder if the person knows what he's talking about. The only way to notice a microstutter is to feel that the real fps are lower than that which is reported by the app / monitoring. You can't notice microstutter, you can only feel that the fps is lower than what is shown.

    C. I've played countless games on different displays in both 59 and 60 Hz (which are really the same 59.94 mode which is very easy to check with the help of vsync and Fraps/AB overlay) and not once anywhere did I notice anything out of the ordinary when using 59 Hz mode. So unless one of you provide EXACT instructions on how to reproduce the issue and give a better description of it than "annoying microstuttering in WoW in DX11" this whole talk is completely pointless.
     

Share This Page