Windows 10 + NVIDIA + 144hz "main" monitor + 60hz secondary monitor - stuttering

Discussion in 'Computer Monitor Forum' started by Stryfex, Apr 5, 2018.

  1. Stryfex

    Stryfex Member Guru

    Messages:
    197
    Likes Received:
    7
    GPU:
    EVGA 1080TI SC
    This is probably a somewhat niche scenario but I've googled it enough to see that it's widespread amongst people with the setup in the title.

    The general scenario here is playing a game fullscreen on a main monitor at 144Hz while watching netflix or something similar on the 60hz secondary monitor. Something about the way windows 10 and NVIDIA handle the frame buffer for monitor outputs which aren't multiplicative causes the video on the secondary monitor to be stuttery/jittery and just a terrible overall experience.

    Some workarounds to this are putting the secondary monitor on a different GPU or setting the 144hz monitor to 120hz instead (2x 60Hz).

    The purpose of this thread is to ask the experts here who may know whether this issue has an actual driver/OS-level resolutions or perhaps it's actually resolved now and I just can't find information on that? My secondary monitor died and I want to buy a new one but 144hz monitors are very expensive (IPS) so I want to really get a handle on the state of this issue to determine the best decision to make. I really do not want to deal with that stuttering ever again.
     
  2. nhlkoho

    nhlkoho Ancient Guru

    Messages:
    7,743
    Likes Received:
    355
    GPU:
    RTX 2080ti FE
    Happens to me even at 120hz on the main monitor. Playing in borderless window usually fixes it
     
  3. Stryfex

    Stryfex Member Guru

    Messages:
    197
    Likes Received:
    7
    GPU:
    EVGA 1080TI SC
    That isn't very reassuring - that tells me that my understanding of the issue isn't very good. Do you use freesync/Gsync on the main one? Because doesn't Gsync basically constantly change the refresh rate of the monitor to match the framerate? I wonder if that means that the issue will always happen
     
  4. nhlkoho

    nhlkoho Ancient Guru

    Messages:
    7,743
    Likes Received:
    355
    GPU:
    RTX 2080ti FE
    Good question. I usually just leave GSync on. I can try it later tonight with it off
     

  5. Stryfex

    Stryfex Member Guru

    Messages:
    197
    Likes Received:
    7
    GPU:
    EVGA 1080TI SC
    if you do give that a try let me know your results
     
  6. Stryfex

    Stryfex Member Guru

    Messages:
    197
    Likes Received:
    7
    GPU:
    EVGA 1080TI SC
    also side question do you have gsync enabled in borderless window + fullscreen or just fullscreen?

    I don't know where I got the idea but I thought it wasn't a great idea to leave gsync on if not in a fullscreen game
     
  7. RealNC

    RealNC Ancient Guru

    Messages:
    3,139
    Likes Received:
    1,363
    GPU:
    EVGA GTX 980 Ti FTW
    It seems gsync is kind of broken when you have two monitors and there's no fix in sight other than disconnecting the second monitor. And sometimes even that doesn't help until a reboot.
     
  8. Duke Nil

    Duke Nil Maha Guru

    Messages:
    1,200
    Likes Received:
    28
    GPU:
    GTX 1080
    Well that's a bummer, I just bought a 120hz gsync monitor and I want to keep using my perfectly good current 60hz monitors next to it :(
     
  9. Shankthewank

    Shankthewank New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    GTX 1080 ti
    Go into nvidia settings down the global settings list there should be a preferred refresh rate : choose highest available. No need to turn off HW acceleration in chrome or anything. Refresh rates are forced by apps by default.
     
  10. Shankthewank

    Shankthewank New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    GTX 1080 ti
    I don’t use gsync but you could give this a go because it fixed it for me. I have a 1440p 144hz and 1080p 60 hz monitor and had all the stutters. Until I changed preferred refresh rate in nvidia control panel which by default is app controlled. Change to highest available for your 144hz monitor or primary.
     
    Duke Nil likes this.

  11. Shankthewank

    Shankthewank New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    GTX 1080 ti
    I’ve only found one fix for my free sync monitor works fine
     

Share This Page