Windows 10 mouse speed problem

Discussion in 'Operating Systems' started by Apparatus, Aug 4, 2017.

  1. Apparatus

    Apparatus Member Guru

    Messages:
    199
    Likes Received:
    0
    Graphics Card::
    RX 470 4gb
    I have a fresh(3 days) 15063.502 build(version 1703)installation of win10 pro x64.

    After a long session in which i changed various windows settings, i restarted and my mouse speed is the double than before.
    I droped two notches the mouse speed setting from the Windows control panel and the situation is a bit better but not satisfactory.

    I always use default mouse speed and i never had a similar issue.

    Any ideas on what can altered my mouse speed ?
     
  2. MisterGutsy

    MisterGutsy New Member

    Messages:
    7
    Likes Received:
    0
    Graphics Card::
    Zotac 1080 Ti AMP Extreme
    Do you have a razer mouse?
     
  3. Apparatus

    Apparatus Member Guru

    Messages:
    199
    Likes Received:
    0
    Graphics Card::
    RX 470 4gb
    No.
    I have a wireless Logitech M170 set(mouse&keyboard).
     
  4. mbk1969

    mbk1969 Ancient Guru

    Messages:
    3,536
    Likes Received:
    0
    Graphics Card::
    GeForce GTX 970
    May be try MarkC mouse fix (in case the acceleration parameters are broken in registry).
     

  5. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    17,752
    Likes Received:
    13
    Graphics Card::
    GTX980 SLI
  6. Steppzor

    Steppzor Master Guru

    Messages:
    718
    Likes Received:
    0
    Graphics Card::
    MSI 1080 Ti Gaming X
    Disable "Enhanced mouse precision" in mouse settings. Should be right under the where you set your mouse speed.
     
  7. Apparatus

    Apparatus Member Guru

    Messages:
    199
    Likes Received:
    0
    Graphics Card::
    RX 470 4gb
    I tried with no luck.
    I will give it another go, with more dpi combinations.

    I also tried :

    - remove and replug the receiver in the usb port
    - uninstall the device via device manager and reboot
    - sfc/ scannow
    - experiment with dpi values from display settings menu


    I already saw it, but do you think it has something to offer ?
    I want to say that from what i saw it will give me the option to alter mouse speed.
    But i already have and tried that option from the buildin win control panel.
    When drop the speed by two notches the all experience is affordable.
    If i drop it one more, the mouse becomes too slow and practically unusable. It feels more a sensitivity, rather than speed, issue.
    Keep also in mind that i already used this mouse in the past with windows 10 installations with no problems.
    No problem after the recent(before two days) format also.
    The problem started suddenly and i can't imagine what created it.
     
  8. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    17,752
    Likes Received:
    13
    Graphics Card::
    GTX980 SLI
    No harm in trying it, I know I get a better experience with the Razer software installed than without
     
  9. Apparatus

    Apparatus Member Guru

    Messages:
    199
    Likes Received:
    0
    Graphics Card::
    RX 470 4gb
    As i had applied the windows dpi fix(125%), i did the sequent :

    1) removed the dpi fix by applying windows default dpi settings
    2) restarted
    3) signed out and signed in
    4) reverted dpi scaling to default (100%)
    5) applied Markc mouse fix (default reg file)
    6) signed out and signed in
    7) re-applied the dpi fix (125%)
    8) restarted
    9) applied Markc mouse fix (125% reg file)
    10) signed out and signed in
    11) dropped one notch the mouse speed settings from wcpl

    That seems to fix the issue.
    I can't confirm that everything is as it was before, but i now have a good experience.
    I will see how things go, and i will maybe use even the Logitech software if the problem reappear.

    Thank you all for your help:)
     
  10. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,570
    Likes Received:
    1
    Graphics Card::
    EVGA 660gtx sig2
    I have not messed any ofthat on windows in years, I leave it default and set my mouse to 2 static DPI setting on it onboard profiles using LGS and it never changes, only thing that change how my mouse behaves issmouse acceleration in windows.

    I dont even use software for my mouse anymore I dont have setpoint installed for my kb or lgs for my mouse. no reason less issues that can be cause by software and updates

    well providing it not windows causing the issue in first place
     
    Last edited: Aug 5, 2017

Share This Page