Windows 10 monitor does not go to sleep (ignores power setting)

Discussion in 'Operating Systems' started by Smough, Jun 19, 2021.

  1. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Hello, I need some help here. I did a clean install of Windows 10 20H2, I installed ISO 20H2 19042.631 from TechBench and installed with no problems, I set up all of my programs, drivers, disable some services, etc as I would with any other Windows version, working fine so far, except my monitor never goes to sleep at any amount of specified time, it just stays on and I have to turn it off manually, the version I had before was 1809 and never had this problem. I haven't touched any power setting or changed anything nor I modified the power plans; they are as it comes, stock.

    I've tried looking for a solution, but none worked, I am thinking I may need an update, but I'd like to know which one because I am always cautious with updates and such, if there is any that fixes this. I reinstalled the same ISO clean to test if I may have compromised the first install and did exactly the same thing, nothing installed. Full clean install did nothing on this regard and my monitor does not go to sleep. :(

    The strange thing is that Suspend works perfectly fine and computer comes back quickly too; it turns off monitor and everything, but the option to ONLY turn off the monitor without Suspend is not doing anything. I even removed the Nvidia driver to check and does the same thing.

    What can I try?

    Thank you.

    Edit: Solved, it was an Xbox 360 controller driver preventing the monitor from sleeping, I installed an older one and the issue got fixed.
     
    Last edited: Jun 20, 2021
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,992
    Likes Received:
    4,060
    GPU:
    GTX 1080ti
    third party xbox 360 controller?
     
  3. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Yep, I unplugged it and still no luck.
     
  4. The Goose

    The Goose Ancient Guru

    Messages:
    2,774
    Likes Received:
    222
    GPU:
    MSIrtx3070 gaming X
    I've had this issue since the beginning of Windows 10, occasionally my system will sleep but its to rare to rely on, some times a fresh Nvidia driver install fixes it for a couple of days but then it just stops working again, after my last Nvidia driver change to 470.76 my power options changed my default to power saver and it still wont sleep properly on its own, it may be a simple thing like a usb hub preventing the system sleeping or a background app like Icue or Msi center, there are also programs like Epson`s printer software running in the background....ive been using that for years, or it could be MS xbox wireless software.

    There are so many possibilities as to the cause.....if I'm not going to use my system for a few hours.....turn it off.

    It is a pain when I buy a new game on Steam or Epic and its a long download but even then my system only uses @100watts when its idle but downloading....more eco friendly than it was 10-15 years ago, in that situation i just use a shutdown timer and force a shutdown.
     
    Last edited: Jun 19, 2021
    Smough likes this.

  5. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Yeah, most likely Windows 10 2009 is having some compatibility issue with one of my USB devices and it doesn't allow the monitor to sleep or some new Windows service. I really haven't tried unplugging everything off yet, it shouldn't be like this, it used to work before, I will do what I can to try to solve it, but seems the newer Windows version simply has issues with this setting, it is minor and since I installed it, my computer works better, this Windows also respects your Nvidia color settings from the get go (finally MS lol) and doesn't apply them when it wants, as it happened to me on older versions and the system is snappier overall, MS optimized a lot of stuff, but power settings got scuffed it seems like.

    I do remember that on other Windows versions power settings would sometimes simply stop working too oh and my monitor does sleep btw, only in safe mode lol. I also tried a clean boot and nothing, on normal mode it just refuses to sleep.
     
  6. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,686
    Likes Received:
    279
    GPU:
    MSI 970 Gaming 4G
    try powercfg.exe with CMD.

    powercfg /requests
    You will see a list of items preventing the machine from entering sleep.

    powercfg -devicequery wake_armed
    which can tell you which devices are armed to wake the system from sleep:

    powercfg /waketimers
    To view the active wake timers on Windows 10

    powercfg /lastwake
    as well as which device last woke the machine from sleep:

    https://www.windowscentral.com/how-use-powercfg-control-power-settings-windows-10

    https://docs.microsoft.com/en-us/wi...ice-experiences/powercfg-command-line-options
     
  7. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    powercfg -devicequery wake_armed

    I disabled the devices that would prevent the computer from sleeping and tested it, didn't work.

    powercfg /waketimers

    It said Windows had a pending maintenance task, so I disable it and tested, the monitor does not sleep.

    It is getting very difficult to troubleshoot this, what a shame.
     
  8. Caesar

    Caesar Maha Guru

    Messages:
    1,327
    Likes Received:
    511
    GPU:
    GTX 1070Ti Titanium
    Try:
    >REgedit
    >Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
    >change Attributes = 2 (HExadecinal) - (is 1 there)
    >Go back to Power Options
    >Click Change plan settings under your chosen power plan.
    >click Change advanced power settings
    >Expand sleep in the Advanced settings window then click on System unattended sleep timeout.
    >Change the value of this field to 30 minutes (Default may 2 or 4 minutes, causing the problem).
    >Apply
    >Reboot

    --------------------------
    MIGHT ALSO BE YOU INSTALLED THEMES THAT IS CAUSING THE ISSUE.
    >RESET THEMES
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,961
    Likes Received:
    891
    GPU:
    EVGA 1070Ti Black
    That compatibility issue issue with my 3rd party controller that use 360 drivers stop working correctly with any 360 driver other then the year 2009 driver, all new drivers cause system to stay awake and never let monitor go to sleep, and that was only issue 20h2 build if i went back to 1909 build or earlier everyone one 360 drivers worked fine to let system put the monitor to sleep with said controller.

    I bet there another issue that causing that now doing it with say a mouse or kb now? it can be royal pain to track down. When I was have this issue I went as far as turn off Legacy usb in bios off when it was, I was lucky though First thing I pulled was the gamepad and that fixed so i knew what device was the cause. but depend on how many usb devices one has and if it "vitial" device like KB/Mouse it might not be fun trying to fix.


    powercfg /requests

    and when I use that command to track down what keep it awake there where no requests with or with said controller that was causing, my cause cause issue was within the driver with certain devices connected it wasnt actual device keeping it away
     
    Smough likes this.
  10. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Thank you! It is indeed the Xbox 360 driver software, I turned the device off and monitor sleeps without any issues, found the culprit, but now where do I find the Xbox 360 2009 driver to be free of problems? Do you have a link for this? I am keeping 2009, I don't have any problems with it and games seem to run better, so I will just install the 2009 Xbox controller driver I guess.
     

  11. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    http://deviceinbox.com/drivers/1115-microsoft-xbox-360-wireless-gamepad-drivers.html ??
     
  12. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,961
    Likes Received:
    891
    GPU:
    EVGA 1070Ti Black
    um the 2009 driver was IN 20h2 as oldest driver for me. Then again I did upgrade from 1909 to 20h2 and now 21h1

    But as far as I can tell the 8/13/2009 2.1.0.1349 Xbox 360 controller for windows is the ONLY driver the work for me after 20h2 new drivers keep the monitor from going to sleep, BUT if I pulled controller with the newer drivers monitor went to sleep just fine it just would not if it was connected

    Driver in the link above is same driver i am using my Ifyoo gaming pro Controller that use 360 drivers.

    Does that place have Official MS drivers untouched?
     
    Last edited: Jun 20, 2021
    Smough likes this.
  13. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Nvm, I already installed them, found a link from someone in Youtube, now the monitor goes to sleep fine, you saved me from doing yet again another reinstall in vain.

    EDIT: Lol I ended up reinstalling Windows 10 1809, I didn't like 2009 and some games had performance issues, way more than usual, also it had other odd bugs that I didn't like. This Xbox 360 controller thing was very annoying and doesn't feel right having to use an old driver that isn't originally from Windows.
     
    Last edited: Jun 20, 2021
  14. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,961
    Likes Received:
    891
    GPU:
    EVGA 1070Ti Black
    I glad I was able to help someone with that issue


    I honestly I have NOT really gamed on my pc since 1909, with 20h2 amd 21h1 in both cases i just "upgraded" I have not done "clean" install in 2 years so far. I have just tested my games to make sure the work long as my game hit 60 fps i didnt put much thought into it
     
    Last edited: Jun 20, 2021
    Smough likes this.

Share This Page