Windows 10 Insider Preview build 18290 and SB X-Fi Series NOT WORKING

Discussion in 'Soundcards, Speakers HiFI & File formats' started by PzSniper, Nov 30, 2018.

  1. PzSniper

    PzSniper Member

    Messages:
    25
    Likes Received:
    3
    I was able to use this card with creative Daniel's K SB X-Fi Series Support Pack 4.0 drivers and the SB X-Fi Titanium HD and the associated creative software and drivers all worked flawlessly on the previous versions of insiders build.
    After upgrading to the latest build 18282 I had no sound, drivers Creative SB X.Fi Audio it is INSTALLED inside Device Manager but Creative Control Panel says THERE ARE NO SUPPORTED AUDIO ...

    Also tried install DISABLING INTEGRITY CHECKS not worked

    seems i need to roll back, when this happen it's the Insider Build fault, just roll back to previous version por wait next flight
    https://answers.microsoft.com/en-us...dblaster/f116ef1e-a5b2-4e91-85ce-c6eaa414609c

    https://answers.microsoft.com/en-us...-support/909520b1-a178-4e53-9d52-b8ca91f98b19

    What's look strange it's that on Windows 10 Insider Preview Build 18277 (19H1) Daniel's K drivers were working as usual, same bug happened on 17074 and on later builds everything worked again. There arent any new modded drivers after SB X-Fi Series Support Pack 4.0 http://danielkawakami.blogspot.com/2017/01/sb-x-fi-series-support-pack-40.html

    Tried new Windows 10 Insider Preview build 18290 and SB X-Fi Series Support Pack 4.0 but STILL NOT WORKING!

    Seems after 18xxx Windows seems x-fi drivers stopped working!
     
  2. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    Time to sell it or recycle it. It is just a too old piece of hardware. You can't except a 10 y.o. technology (8 years for your sound-card) to work forever, right? Use public version/stable branch of windows even 7/8.1 not 10. Insiders meant for latest and greatest. No one can help you here.
     
  3. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,422
    Likes Received:
    2,095
    GPU:
    Zotac GTX980Ti OC
    Don't listen to that comment above. SB is perfectly fine even if it were 15yrs old.
    _________________

    Did you disable it in device manager and enable it again?
    Also try switching between modes afterwards.


    This usually fixes it, if not try to remove it in device manager but keep driver, press f5 so windows reinstalled it, reboot and test again. If still doesn't repeat step 1.
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    13,254
    Likes Received:
    5,212
    GPU:
    GTX 1080ti
    Remember that the Memory Protection feature of Defender causes this.
     

  5. PzSniper

    PzSniper Member

    Messages:
    25
    Likes Received:
    3
    checked CORE ISOLATION and it's off i run Kaspesky

    any other idea?
     
  6. PzSniper

    PzSniper Member

    Messages:
    25
    Likes Received:
    3
    I ran commands to disable INTEGRITY CHECKS

    keep in mind i installed them many times until build 18xxx

    1- disabled integrity
    2- rebooted
    3- installed daniels K and disabled integrity
    4- rebooted
    5- sb install in diice manager but creatie doesnt recognize it


    only solution for now its using hd windows driver
     
  7. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,422
    Likes Received:
    2,095
    GPU:
    Zotac GTX980Ti OC
    Did you disable and enable SB in device manager?


    Actually all those steps I mentioned, none has any connection to this driver integrity check
     
  8. Astyanax

    Astyanax Ancient Guru

    Messages:
    13,254
    Likes Received:
    5,212
    GPU:
    GTX 1080ti
    turn off fast startup.
     

Share This Page