Windows 10: Game mode can impact FPS negatively with stutters and freezes

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, May 6, 2020.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    40,821
    Likes Received:
    9,211
    GPU:
    AMD | NVIDIA
    Maddness and Thunk_It like this.
  2. screenager

    screenager Member Guru

    Messages:
    112
    Likes Received:
    3
    GPU:
    XFX R9 290
    Hmm i had unexplainable stutters with my vega 64, will try and see if this helps.


    Edit_____
    I tested it and it worked for me.
    I only hope hopeless Windows 10 does not turn it on like system restore (i have it turned off but it keeps reactivating)

    Game mode is as usefull as a killer NIC:rolleyes:
     
    Last edited: May 6, 2020
  3. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,372
    Likes Received:
    2,705
    GPU:
    RX 5700 XT/ MAC M1
    Well, finally this gets more attention. I have game mode turned off since it was released, and judging by its current state - will continue to do so for the foreseeable future.
     
  4. Richard Nutman

    Richard Nutman Master Guru

    Messages:
    204
    Likes Received:
    83
    GPU:
    Sapphire 5700 XT
    I'd never turned this on, but somehow it was activated. :/
     
    Duke Nil likes this.

  5. Undying

    Undying Ancient Guru

    Messages:
    15,472
    Likes Received:
    4,485
    GPU:
    Aorus RX580 XTR 8GB
    We knew it didnt do anyhing but freezes and stuttering, eh....good thing i've always had it disabled.
     
  6. Morax

    Morax Master Guru

    Messages:
    214
    Likes Received:
    70
    GPU:
    RTX 3080 Suprim X
    Same here, I'm curious!
     
  7. girdhan

    girdhan New Member

    Messages:
    5
    Likes Received:
    2
    GPU:
    GTX1080Ti / 11GB
    It is on by Default. Also in some previous Windows builds the option to enable/disable it was not available for some reason.
     
  8. shamus21

    shamus21 Member Guru

    Messages:
    126
    Likes Received:
    21
    GPU:
    0
    One more Microsoft cock-up
     
    Kaleid likes this.
  9. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,445
    Likes Received:
    2,813
    GPU:
    MSI 6800 "Vanilla"
    Which is curious because at first I assumed it was a AMD driver specific issue with how this changed the CPU priorities but then from further reading it sounds like forced or hack-like so having it default to enabled seems the wrong way to go about it plus many users wouldn't even be aware of the setting let alone what it's actually doing as "Game Mode" itself is pretty non-descriptive.

    https://www.reddit.com/r/Amd/comments/gcladd/if_youre_still_having_5700xt_driver_issues_on/?sort=new

    Bit like playing around with affinity or CPU core allocation and such, well less affinity or priority and more about what cores get to do what I suppose.
     
  10. chr!s

    chr!s Member Guru

    Messages:
    171
    Likes Received:
    27
    GPU:
    GTX 1080
    I've had it "on" for a while - haven't noticed any issues? should I switch it off?
     

  11. Angantyr

    Angantyr Master Guru

    Messages:
    799
    Likes Received:
    251
    GPU:
    MSI 2070 Super X
    You might as well, the concept behind Game Mode itself is a bit ... flawed I'd say. Game mode says it diverts your system resources, to your games ( Or disables them?). Without providing answers on, what system resources are we talking about?

    Personally I think game mode was developed for users who had so many junkware applications running on their system, that it affected game performance.
     
    chr!s likes this.
  12. kakiharaFRS

    kakiharaFRS Master Guru

    Messages:
    613
    Likes Received:
    170
    GPU:
    MSI Gaming X 1080ti
    who didn't know this already ? it's been know since day 1 okay I guess not everyone is a modder/tweaker

    so here's something really useful for you guys, like Jonas above mentions cpu affinity can save your gaming experience
    most games cannot handle more than 4 or sometimes, sometimes only...8 cores so use 4c/8t as your default go to setting
    so if you experience stuttering the 1st thing you need to do it open task manager->right click game process->set affinity->and select 8 threads (4 cores) or 16 threads (8 cores) and see how it goes
    avoid cpu0 and cpu1 (on multithreaded cpus) as a lot of apps and process all hammer the 1st threads and never use the ending threads (that was a well known problem of forza horizon 3 at release it had 100% usage of cpu0 ruining your performance)
    I personnally always select the last threads

    games that handle 8 cores generally don't care about you having more (I have a 24c 3960x and 8c 9900k even on the 9900k I limited most games to 4c/8t)
    setting affinity every time is a pain you can use process lasso to fix that (and do other things) https://bitsum.com/
    I've been using it pretty much since XP back then some games couldn't even handle 4 cores >< some used one core !
    this saved my gaming on threadripper for most games, a tweak website reviews probably didn't do so keep that in mind
    some games are unsalvageable tough :/ skyrim LE and subnautica (the original) give me half or less fps than on a 9900k, can't have everything heh

    if you experience stuttering I can't recommend enough using afterburner and rivatuner https://www.guru3d.com/files-details/msi-afterburner-beta-download.html
    and setting up (it takes a bit of work) at least an on-screen graph of frametimes and fps you will see on your screen live the changes of "smoothness" when tweaking cpu affinity or ingame graphic options

    with it you will instantly see the frametimes and fps graphs go up down or go from chaotic to a flat line and know 100% for sure if your gaming experience is better or not
    no more "guessing" which settings ruin your "fps" you will know for sure
    a giant THANK YOU to the team responsible for this

    p.s.
    thanks guru3d for this article, somehow an update re-enabled game mode >< I'll take note to check every time after big win10 updates
     
    Last edited: May 6, 2020
    JonasBeckman likes this.
  13. MaCk0y

    MaCk0y Master Guru

    Messages:
    954
    Likes Received:
    354
    GPU:
    GB 5700XT Gaming OC
    Coincidentally I had this turned off and turned it back on to test something. Apparently game mode doesn't mess with CPU/GPU prioritization anymore so it shouldn't be the cause of stutter. I can't find where I read this.
     
    JonasBeckman likes this.
  14. Passus

    Passus Ancient Guru

    Messages:
    1,713
    Likes Received:
    493
    GPU:
    RX 5700 Mech OC
    I have had this turned off along with gamebar since they came
     
    TheDeeGee likes this.
  15. loracle

    loracle Member Guru

    Messages:
    184
    Likes Received:
    42
    GPU:
    GTX 1660 super
    I always deactivated this crap, since i noticed low scores in benches when on.
     

  16. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    12,183
    Likes Received:
    4,340
    GPU:
    2080Ti @h2o
    It's bothersome and nobody asked for that in the first place. Deactivated before I even play a game after installing windows.
     
  17. Nicked_Wicked

    Nicked_Wicked Member Guru

    Messages:
    144
    Likes Received:
    74
    GPU:
    RTX 2070 Super
    I have this on for quite a while now with no detrimental effects to speak of. I think it’s enabled by default in 1903 and newer.

    Anyone care to measure some performance metrics in 1909 or 2004?
     
  18. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,682
    Likes Received:
    1,545
    GPU:
    MSI 3080 Gaming X
    Weird that it even exists. The OS should be optimized for all kinds of tasks like e.g. gaming or productivity, there shouldn't be a switch for that.
     
    carnivore likes this.
  19. DaLoona

    DaLoona Member

    Messages:
    15
    Likes Received:
    3
    GPU:
    GB GTX1060 6GB
    I was wondering why Diablo 3 acted so strangely. It indeed freezes and stutters on the most strange times. Im running a 2700X with 16GB 3400MHz memory and a GTX1060 6GB. Just disabled it.
     
  20. buhehe

    buhehe Master Guru

    Messages:
    274
    Likes Received:
    101
    GPU:
    R9 290
    I had explicitly turned off it when I installed windows... and now it's on.
    Updates have a tendency to reset some user preferences. So fu**ing annoying.
     
    Maddness, Elder III and fantaskarsef like this.

Share This Page