Windows 10 Fall Creators Update & HDR

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by masterchan777, Oct 17, 2017.

  1. masterchan777

    masterchan777 Master Guru

    Messages:
    260
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    I have just installed the Fall Creators update and I read that Microsoft has indeed fixed the incorrect croma settings when switching HDR mode on via display settings, so we won't have the washed out colours as with the previous update, however it seems that the bug is still there, at least on my 1070 with the latest hotfix R387.98 drivers ... Any thoughts you guys may have on what to do to resolve this issue and finally get HDR working ?
     
  2. caleb59

    caleb59 Member Guru

    Messages:
    124
    Likes Received:
    1
    GPU:
    ASUS GTX 970 Strix OC 4GB
    For me it's so dark, I see dark desktop, it's like something was changed in colors/brightness?
    I've reinstalled Nvidia drivers and even factory reset my monitor via his OSD menu...
     
  3. Guru01

    Guru01 Master Guru

    Messages:
    216
    Likes Received:
    14
    GPU:
    ASUS ROG STRIX 1070
    Where is the setting to enable HDR?
     
  4. caleb59

    caleb59 Member Guru

    Messages:
    124
    Likes Received:
    1
    GPU:
    ASUS GTX 970 Strix OC 4GB
    Last edited: Oct 18, 2017

  5. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    679
    Likes Received:
    1
    GPU:
    EVGA GTX 980 TI sc
    Not working for me and my system is HDR ready. I followed the microsoft tutorial to but colours still lesser bright

    Display Devices
    ---------------
    Card name: NVIDIA GeForce GTX 980 Ti
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 980 Ti
    DAC type: Integrated RAMDAC
    Device Type: Full Device
    Device Key: Enum\PCI\VEN_10DE&DEV_17C8&SUBSYS_49923842&REV_A1
    Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER]
    Device Problem Code: No Problem
    Driver Problem Code: Unknown
    Display Memory: 14265 MB
    Dedicated Memory: 6103 MB
    Shared Memory: 8162 MB
    Current Mode: 2560 x 1440 (32 bit) (144Hz)
    HDR Support: Supported
    Display Topology: Internal
    Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G2084_NONE_P2020
    Color Primaries: Red(0.679211,0.314953), Green(0.269055,0.667492), Blue(0.152844,0.062023), White Point(0.313977,0.329602)
    Display Luminance: Min Luminance = 0.049110, Max Luminance = 603.665771, MaxFullFrameLuminance = 351.250427
    Monitor Name: Generic PnP Monitor
    Monitor Model: C32HG7x
    Monitor Id: SAM0E13
    Native Mode: 2560 x 1440(p) (144.001Hz)
    Output Type: HDMI
    Monitor Advanced Color Capabilities: BT2020RGB BT2020YCC Eotf2084Supported AdvancedColorSupported AdvancedColorEnabled
     
  6. BangTail

    BangTail Ancient Guru

    Messages:
    2,393
    Likes Received:
    30
    GPU:
    EVGA GTX 1080Ti SLI
    Yep, still broken.
     
  7. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    679
    Likes Received:
    1
    GPU:
    EVGA GTX 980 TI sc
    In game and/or under display settings.

    With Nvidia default display settings colours HDR works half for me in battlefield 1, but lesser bright colours. I use HDMI 2.0 1440p 144hz or 1080p 60hz, i dont get the good colours, but the sun is more realistic also seeing better clouds in the air arround the sun.

    I think i have HDR working now in Shadow Warrior 2 with this settings.

    [​IMG]

    i can select HDR and the HDR brightness slider works aslo. I getting deeper colours, blue red and green, deeper blacks and a higher brigtness from the sun.
     
    Last edited: Oct 18, 2017
  8. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    679
    Likes Received:
    1
    GPU:
    EVGA GTX 980 TI sc
    And do not set HDR on in windows but only in game. Like BF1 i must set brightness to 25-30 range and the HDR brightness to 100 minimal. But orange things in the game like the lag indicator are now yello
     
  9. cryohellinc

    cryohellinc Master Guru

    Messages:
    888
    Likes Received:
    57
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
  10. DxVinxGado

    DxVinxGado Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    2xEVGA GTX 1080Ti FTW3
    Not sure what your link of yesterdays minor update (16299.15 to 16299.19) has to do with the HDR issue present since the initial Creators update. Also, the issue for me has always been that HDR only activates in the Windows 10 desktop if the output color depth is set at 10-bit. The issue with that is if your running your desktop @ 4K, which I am, you are limited to an output color format of YCbCr422 which is HORRIBLE, especially for text.
     

  11. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    This isn't a Windows issues, it's HDMI 2.0 bandwidth issue. HDR requires 10 (HDR10) or 12 (DV) bits of color precision. Running this at 4K at 60Hz results in more bandwidth than HDMI 2.0 can provide.
     
  12. DxVinxGado

    DxVinxGado Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    2xEVGA GTX 1080Ti FTW3
    Fully aware of the issue being a hardware issue with HDMI bandwidth, but they could also allow us to run HDR @ 4K using YCbCr420 10 bit and they don't.

    EDIT: Ultimately the issue is viewing text @ 4K 4:2:0 is more bearable to me than in 4:2:2.
     
    Last edited: Oct 19, 2017
  13. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    679
    Likes Received:
    1
    GPU:
    EVGA GTX 980 TI sc
    It is 8bit+ VRC so hdmi 2 is not an issue
     
  14. cryohellinc

    cryohellinc Master Guru

    Messages:
    888
    Likes Received:
    57
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    And have you tried it?
     
  15. Archvile82

    Archvile82 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Msi 1070 gtx x
    Hi All,

    I have HDR working on my side, settings I am using are :-

    Colour is set to 'use default settings' , audio disabled in NVCP and enable HDR in windows display properties.

    Using the above I get really good HDR in all games apart from Mass Effect which now appears to be broken.

    I tried using NVidia override settings but I would either get extreme banding or overexposed brightness ( I tried all combinations ).

    Obviously the desktop still looks a bit on the dark side but I its easy just to disable HDR when not playing non HDR games.

    Another thing to consider is for whatever reason HDR does not work at 1440p, on my LG B6 I can only use 1080p or 4k.

    Games tested and confirmed working on 16299.19 with the latest drivers:-

    Nex Machina
    F1 2017
    Redout
    Hitman
    Resident Evil 7 - A bit buggy, when exiting the game it disables HDR in windows properties and can make colour go odd, just enable and disable the HDR in windows display properties to fix it. Apart from that the game looks fantastic, I used to get some really bad banding in this game pre creators builds and its virtually gone now.
     

  16. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    Well, this is something which should be controlled by the OS I think. Previously drivers would do this - switch from 8bit+RGB to 10bit+422 when an app would request HDR. In 1703+ though IHV APIs are locked out and this should be done by Windows - but this doesn't work it seems.

    Your display panel may be 8bit+FRC, the signal which goes through HDMI has to be 10/12 bit for HDR to work. So HDMI2.0 is an issue. Partially why I didn't bought anything HDR yet as I'm waiting for HDMI 2.1 devices.

    Yes, this is how it should be in 1703+ for HDR to work.
     
    DxVinxGado likes this.
  17. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,799
    Likes Received:
    75
    GPU:
    Inno3d GTX 1070 iChill x4
    Hopefully ill be able to test this, when i hook up a pc to my pc. if i got the time. i finally got the proper cable now :D
     
  18. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    679
    Likes Received:
    1
    GPU:
    EVGA GTX 980 TI sc
    HDR works fine over the cable, its not 4k and the playstion 4 pro HDR works also over the cable. Also i getting hdr movies working with the HDMI cable on my pc
    [​IMG]
     
  19. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,145
    Likes Received:
    79
    GPU:
    GTX 1080 GRP
    If it's not 4K then there's no bandwidth issue. PS4Pro HDR is running in 422 in 4K@60. All HDR 4K movies are encoded in 422 for now so there's no quality gain from viewing them in 444.
     
  20. DxVinxGado

    DxVinxGado Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    2xEVGA GTX 1080Ti FTW3
    Tried what? Patch? HDR after Patch? if so, yes, and yes.
     

Share This Page