Windows 10 20H1/2 - Cannot get FSO in D3D9 games anymore

Discussion in 'Operating Systems' started by DaRkL3AD3R, Oct 3, 2020.

  1. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    50
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    I have been using a registry tweak to globally disable FSO for the last 3 years and it has generally speaking been working great. If I want FSO On (for testing or whatever) I simply run the following registry file:

    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_HonorUserFSEBehaviorMode"=dword:00000000
    "GameDVR_DXGIHonorFSEWindowsCompatible"=dword:00000000
    "GameDVR_FSEBehavior"=dword:00000000
    "GameDVR_FSEBehaviorMode"=dword:00000000

    When I want FSO Off (my default state) then I run the following file:

    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_HonorUserFSEBehaviorMode"=dword:00000001
    "GameDVR_DXGIHonorFSEWindowsCompatible"=dword:00000001
    "GameDVR_FSEBehavior"=dword:00000002
    "GameDVR_FSEBehaviorMode"=dword:00000002

    This has been working great for me all these years and even earlier on during the 20H1 builds back around April/May, but for the last few months I haven't been able to get my FSO On registry tweaks to work for D3D9 games. They're always running in Legacy Flip exclusive fullscreen mode. I've tried everything I can think of short of formatting and reinstalling to get it back, but I have a feeling it might be Nvidia driver related. I think in the drivers they put out to correct the G-Sync issues with FSO Off in D3D9 games, something is forced a certain way and now it can't be disabled.

    I'd love to hear from anyone using a G-Sync screen on Windows 10 20H1 or 20H2, if they are able to get FSO working in any old random D3D9 game like Crysis, Halo CE, Half-Life 2, Mirror's Edge etc etc. I am all out of ideas and am eager to hear from anyone knowledgeable about this feature and what might be the cause of this issue. Please note that I have not made any further modifications to the registry beyond the two files I listed the contents of above.

    Thanks
     
  2. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    50
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    Tested really old drivers after DDU, 391.35 and same issues. Probably safe to say it's not a driver issue.
     
  3. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,743
    Likes Received:
    850
    GPU:
    EVGA 1070Ti Black
    probably windows change, cant say to either or as I dont mess with FSO or anyof that it all defualt on my system and I see no issue, I disable Gamemode that is about it
     
    Smough likes this.
  4. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    50
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    I don't think it's a Windows change. It definitely was working fine in 20H1 for a long while before it stopped working altogether. Now I'm on 20H2 and it's still not working right. I get the feeling only thing I can do is format and reset my OS and see what happens.
     

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,574
    Likes Received:
    3,869
    GPU:
    GTX 1080ti
    there isn't a change that DX team is aware of.
     
  6. Marios145

    Marios145 Member

    Messages:
    33
    Likes Received:
    0
    For my system, a reboot is required to apply changes.
    I kept changing these and nothing happened, it works only after restart (may work with user logout?).
     
  7. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    50
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    Rebooting after applying the settings did not fix it. I really think I won't get this fixed without a format and reinstall. Once we get a RC ISO for 21H1 I'll be formatting and giving it a try and see if the problem is resolved.
     
  8. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    50
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    Solved my problem. At some point months ago, I must have ran this batch file I have from a Reddit post about globally disabling FSO. The contents of which are:

    REM --- copy from here-----


    (
    reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "4" /f
    sc config XblAuthManager start= disabled
    sc config XblGameSave start= disabled
    sc config XboxGipSvc start= disabled
    sc config XboxNetApiSvc start= disabled
    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable
    takeown /f "%WinDir%\System32\GameBarPresenceWriter.exe" /a
    icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:F /c
    taskkill /im GameBarPresenceWriter.exe /f
    move "C:\Windows\System32\GameBarPresenceWriter.exe" "C:\Windows\System32\GameBarPresenceWriter.OLD"
    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable
    takeown /f "%WinDir%\System32\bcastdvr.exe" /a
    icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:F /c
    taskkill /im bcastdvr.exe /f
    move C:\Windows\System32\bcastdvr.exe C:\Windows\System32\bcastdvr.OLD
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "0" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "0" /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "0" /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "0" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "0" /f
    reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "0" /f
    reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "0" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "0" /f

    )


    REM ---End Copy Here---

    I knew to keep both this, the disabling batch file, and the enabler one that undoes all these changes. On a whim I ran that one and voila, problem solved. I can now go back to my much simpler and less egregious FSO On - FSO Off batch files I keep on my desktop for quickly toggling it whenever I want. For the sake of completion and anyone googling about this, here's the contents of the enabler vice versa to the script above:

    @Echo off
    goto check_Permissions
    :check_Permissions
    echo Administrative permissions required. Detecting permissions...
    net session >nul 2>&1
    if %errorLevel% == 0 (
    echo Success: Administrative permissions confirmed.
    move "C:\Windows\System32\GameBarPresenceWriter.OLD" "C:\Windows\System32\GameBarPresenceWriter.exe"
    icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /setowner "NT Service\TrustedInstaller" /c
    icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:RX /c
    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
    move C:\Windows\System32\bcastdvr.OLD C:\Windows\System32\bcastdvr.exe
    icacls "%WinDir%\System32\bcastdvr.exe" /setowner "NT Service\TrustedInstaller" /c
    icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:RX /c
    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
    sc config XblAuthManager start= auto
    sc config XblGameSave start= auto
    sc config XboxGipSvc start= auto
    sc config XboxNetApiSvc start= auto
    reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "3" /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "1" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "1" /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "1" /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "1" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "1" /f
    reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "1" /f
    reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "1" /f
    reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "1" /f
    ) else (
    echo Failure: Current permissions inadequate.
    )
    pause >nul
     

Share This Page