Win8 - Anti-Stuttering Suggestions?

Discussion in 'Videocards - NVIDIA GeForce' started by yobooh, Aug 28, 2012.

  1. yobooh

    yobooh Master Guru

    Messages:
    254
    Likes Received:
    10
    GPU:
    Gigabyte 970 G1
    Hi, to the community! I'm searching some usefull tips from you Guru's of 3d!
    My problem is that I HATE STUTTERING, i prefer even to play at rock solid 30fps, or introduce a bit of imput lag instead of that.
    Actually i'm having problems on two games: Diablo3 and Darksiders2, in both i reach 60+ fps all the time, so i'm searching to VSYNC @60 or @30fps in the best possible way.
    My general solution to stutters it's Vsync+Forced Triple buffering, but D3Doverrider it's not actually working on win8, so I'm searching the best fix against the problem, these are my questions:

    1)What is the best FPSlimit value to use in combination with VSYNC?
    58 and 59fps reduce imput lag, but what i find it's actually more stuttering it's introduced. I found that 60+ as limit works better than that, but what value it's better 60? 61? 65? 70?
    I found also that MSI afterburner FPS limiter it's more stable than Inspector one, so they works in different ways?

    2)There is a working Vsync/FPSlimit/Pre-rendered-Frame combination that stabilize Vsync for you?


    What i've done until now:
    1.Disabled Win8 useless services, malware and SearchIndexer
    2.Disabled Core parking
    3.Tested than i'm nor Cpu/Gpu limited (either with one single CPU core in Diablo)
    4)Installed latest 306.02 drivers
    5)full screen windowed mode reduced the problem, but i want a solution to stay fullscreen!
    6)i'm really sensible to microstuttering, also a double buffered 30fps Vsync solution it's well accepted.

    I'm waiting for your suggestion :infinity:
     
    Last edited: Aug 28, 2012
  2. krpetrov

    krpetrov Master Guru

    Messages:
    224
    Likes Received:
    0
    GPU:
    HD 7950 at 1135/6000
    Your card probably going into 2D mode during gaming. lowering core, mem and voltage. You should disable it and stay at high voltage and core always. I have the same issue and fix it with MSI afterburner - on power options. I future driver release this will be fixed, I think. I did not have those problems on Win7 and previous gpu drivers.
     
  3. yobooh

    yobooh Master Guru

    Messages:
    254
    Likes Received:
    10
    GPU:
    Gigabyte 970 G1
    No that's not the problem GPU and CPU works well and i have 70-90fps without problems but tearing. Enabled Vsync the fps it's trembling 58-61 fps and i can't reach to stabilize at 60 or 30, i always have some stutterings!
    No way to fix that without triple buffering?

    I'm new to Nvidia cards, my old 4850 had not such a so strong stuttering :S
     
    Last edited: Aug 28, 2012
  4. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    cap the fps to refresh, higher & there is more input lag, lower & you say there's stuttering (well ya, but it should be tiny ticks)
     

  5. snowdweller

    snowdweller Master Guru

    Messages:
    492
    Likes Received:
    0
    GPU:
    Leadtek GTX 580 SLI
    Mines always been like 58-61. I always assumed it was AfterBurner issue as any res/graphics settings I put with Vsync I get the same fps. The exception being when something intense is going on e.g. explosions and such where it will dip under but then go back to 58-61.

    I remember my 6870s keeping 60 exactly in AB though so dunno..
     
  6. yobooh

    yobooh Master Guru

    Messages:
    254
    Likes Received:
    10
    GPU:
    Gigabyte 970 G1
    That's the point.
    With ATI, changing FPS limit and Flip queque size i obtained a constant stable FPS.
    Nvidia maximum pre-rendered frame introduce a lot of imput lag, but do not solve the stutter. So what is its function?
     
  7. Neo Cyrus

    Neo Cyrus Ancient Guru

    Messages:
    9,973
    Likes Received:
    758
    GPU:
    Asus TUF 3080 OC
    I don't think having an AMD card would make a difference, I'm almost never able to get a constant 60fps regardless of what settings such as flip queue I mess around with. It always stutters to 58fps then jumps back to 60.

    The most consistent solution I found was disabling vysnc and just capping games to a high frame rate such as 120fps. That way when it stutters it's not quite as noticeable. But the problem is of course there are very few modern games that I can do that in, not enough GPU power even at such a high overclock. That and in some cases the tearing is just too annoying.
     
  8. yobooh

    yobooh Master Guru

    Messages:
    254
    Likes Received:
    10
    GPU:
    Gigabyte 970 G1
    Searching on the web i found an interesting commercial solution "Virtual Vsync" that solves in an intelligent way stutters and tearing with a quequed process...but that use integrated cpu graphic card.
    Hope that nvidia it's going to enable something like that on an old second card or in a sli configuration!

    I found out also that something "SUPERCOOL" on Vsync side it's on the work...
    http://www.youtube.com/watch?v=NHvBsTLoPMA#t=54m00s
     
  9. Oni29

    Oni29 Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    PNY 780 GTX
    I had stuttering in Starcraft 2, cured it by going into task manager and out again.
     

Share This Page