win7 sp1

Discussion in 'Operating Systems' started by athlon64guy, Apr 20, 2011.

  1. athlon64guy

    athlon64guy Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    580GTX eVGA
    im running win7 home premium and i still have not installed sp1. should i update?
     
  2. Li4m79

    Li4m79 Ancient Guru

    Messages:
    5,155
    Likes Received:
    3
    GPU:
    2xPalit GTX770 Jetstream
    you may as well, nothing to lose. If you have done all other updates there will not be that much to install
     
  3. Snarl

    Snarl Member Guru

    Messages:
    115
    Likes Received:
    0
    GPU:
    GTX 1080 Ti 11GB
    Good luck, SP1 refuses to install on my system, all other updates not a problem.. wierd
     
  4. IAmGhostDog

    IAmGhostDog Maha Guru

    Messages:
    1,128
    Likes Received:
    7
    GPU:
    XFX R9 390
    I'd do it.
    I did it.
    No big deal.
     

  5. Hemectu

    Hemectu Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    Evga GTX465 SC -> 470 SC
    This happened to me too. I worked with a M$ rep to get the SP1 to install.
    I tried all the normal techniques with no effect (clean, direct install, change user, admin...).

    I was also able to install everything else as well. I got some non helpful error that was not in the M$ system.

    To fix it I downloaded the SP1 pack (I have 64bit so used that version) it was just under 1Gig. I then ran the Windows 7 Disc "In Place Upgrade". Do not search the internet for updates, just need the basic 'upgrade' install.

    Then run the Sp1 installer that was downloaded. Reboot, then run Windows update, all good.

    This does NOT re-install Windows but simply replaces the basic system files. The only additional things I needed to do after was Re-Install Drivers, (Video, Sound, RAID).
     
    Last edited: Apr 21, 2011

Share This Page