Win7, 4870X2 + 280GTX

Discussion in 'Videocards vs General Purpose - NVIDIA Ageia PhysX' started by Torch'em, Jan 17, 2009.

  1. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Next week, I'll try to use my 4870x2 with a 8800gts to see if this setup is really working in-game.
     
  2. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Edit the TdEngine.ini in the Mirror's Edge config directory:

    [Engine.GameEngine]
    bSmoothFrameRate=TRUE
    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=62

    You should change the line in bold.
     
  3. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Thanks Zazza, I'll try that after work hopefully tonight.

    LuxZg, I'll know better if I can have a floating FPS so I can see which card is doing the better. Both the 280 (with and without PhysX) and 4870X2 (no PhysX) stay at 62 FPS, but when PhysX enable with the Ati as main display, tends to lag a little and FPS drop in heavier PhysX areas.

    I quickly tried it with the 3 GPU set up before work with the 9800GX2 as dedicated PhysX (display disabled), 280 display extended to the 4870X2. Definatly have PhysX with the 4870X2 as main display and FPS stays at 62. I notice the game did get a little laggy at times as when the 280 was used for PhysX but didn't get a FPS drop.

    BTW, I'm stuck in a spot atm in mirors edge :3eyes:. What I do is play with the 280 until I get to a section with flags, plastic sheeting and dust partical flying around and that's when I switch around to the 4870X2 for testing.
     
  4. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    I changed the MaxSmoothedFrameRate to 150. Got passed the place I was stuck on and tried a few things.


    1600x1200 res'
    Others set as High
    8x anti

    4870X2 disabled, 280GTX display and the 9800GX2 as PhysX. FPS up and hovered around the 90 mark, dropped to 75 in a few spots in game play.
    280GTX with PhysX still around the 75 but did drop to low 60's in a few spots.
    280GTX without PhysX and game PhysX off, FPS up over 75 but yoyo from there up to around 100 FPS.

    4870X2 with both Nvidia disabled and PhysX off. 70 - 140 peak FPS. Mainly stayed around the 85ish mark.
    4870X2 with 280GTX as PhysX, 9800GX2 disabled, around the 65-75 on ave'. Had that annoying cursor flicker on the screen and game lagged a little as well.
    4870X2 with no PhysX from the 280GTX or 9800GX2 but game PhysX on. FPS low 60's, did hit 90 something in a dark spot. When PhysX i.e. flags and plastic sheets, smashed FPS down to 15 and hopeless to play. Game crashed on me as well.

    The game itself needs the 8x anti or the edges jag up really bad no matter which GPU is the display.

    Well I found I can run a Nvidia GPU as a PhysX processor on my system, but not as good as I would have liked. The cursor flicker bug and game a tad laggy a bit of a put off. Drivers, newer version of beta Win7 may help later on.

    I hope some others give it a try and post up what/how/findings as well so we can work together to sort some bugs and issues out. I'm still going to play around to hopefully "fine tune" it better time permitting.
     

  5. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Did you actually see PhysX improvements during game? (Flags,broken glasses, etc).

    This is normal. In this situation PhysX is done by CPU and thus framerate drop. BTW, a patch was released to resolve crash issues.

    In Mirror's Edge someone got problems with latest PhysX driver version. The version that should be used is 9.09.010.

    I hope my 8800gts will come next week to do some testing...
     
  6. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    Well, by the post above seems that everything is indeed working.. OK, buggy, but that's using beta drivers, on beta OS, with hardware which wasn't ment to work together at all, and to top it off - with game that isn't exactly polished as much as I've read in the news and reviews. So you've got something here that shouldn't work at all - so no complaints ;)

    I'm looking forward to Zazza's tests as well. I'm still waiting for my new graphics (sold my HD4870, waiting for store to get a new stock of 1GB model), and I sure hope I'll find some (ANY!) nVidia card that goes to PCI/PCIe x1 slot in the meantime.. Now if THAT works I'll be happy little monkey :D
     
  7. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX

    Yes, did see the shattering glass and could shot holes in the plastic and tear it. Good luck with your testing.
     
  8. Ellisdee

    Ellisdee Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    2x4870x2 1x8800 Ultra
    hmm torch which drivers do u use cause i have crashing Nv control panel with 185.20 and 182.05 only wddm 1.1 works with cp but still need to test again made a mistake follw ur description now this time and figured out its useless to do so to make the physix switchable u just need to switch primary screen to nv card but doing this is useless too casue when u do nothing u get best results lol

    @z u wont find a gpu who fits in a pcix1 slot its just possible to run it in a pcix16 @ 1x 4x 8x 16x 16v2 but maybe i understood wrong
    just saw a pcix4 slot on asus p5e64 revolution which had no back were maybe it could be possible to run in but never tested on my old board

    edit

    BUG Explain :

    only seen at 3dmark Vantage CPU test 2 Physix and Fluidmark in Fullscreen
    Both Program Crash When they try to enter Fullscreenmode when "primary screen"
    flag is choosen on ATI card and Monitor Number is 1 this does not happen when the
    card with primary screen flag has monitor 2 for example

    no problem to enter fullscreen mode on 8800 when "primary screen" flag is
    checked there and monitor number is 2



    BUG FIX:

    Deactivate first ati gpu when u have crossfire or x2 and reactivate it after
    what happens is that in Display resolution/options (german: Bildschirmauflösung)
    the number of the real monitors get switched the ati gets Screen number2 and the
    geforce gets 1
    Now its possible to enter fullscreen mode with both tools on ati gpu but not on Geforce

    not seen a game were this happens but its redoable so its a Bug

    else i have seen when i didnt make the deactivate thing fluidmark trys to start the
    fullscreen on geforce anyway the "primary screen" flag is made to he ati gpu think its
    part of the problem but im no coder ;)

    notice!!!
    u need 2 screen when u deactivate the one were ur screen is at and the second screen
    should run at extended mode or a screen with 2 input dvi dsub hdmi or so


    SYSTEM Specs:

    Asus P6T6WS Revolution
    Intel Core I7 920@ 3,7GHz
    6 GB OCZ PC 15000 @ 1567MHz
    2x 4870X2 Gainward Golden Sample watercooled (GPU/COOLER Hard MOD)
    1x 8800 Ultra Sparkle watercooled zalman waterblock 8800 gtx
    Machine is water cooled so i cat take a the 8800 out or better i dont want
    i just can deactivate it but should be good enough


    Test Explain:

    There were 4 types of NV WDDM 1.1 tests

    1.With Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI and
    choosable physix accelerattion at physix controlpanel (No Hardware Acceleration / Geforce
    Acceleration) and switched to GeForce Acceleration

    2.With Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI and
    choosable physix accelerattion at physix controlpanel (No Hardware Acceleration / Geforce
    Acceleration) and switched to No Hardware Acceleration

    3.With Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI and
    With Grayed Physix Controlpanel which is set to "No hardware Acceleration"

    4.Without Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI and
    With Grayed Physix Controlpanel which is set to "No hardware Acceleration"



    Benchmark Explain:
    3dMarktests are all in fullscreen
    Fluidmark Tests Are in windowed mode due to a bug dont know were its from screen flickers
    or have a refresh bar going up and down like a crt never seen in games


    Benchmark Results:

    [NV WDDM 1.1]

    3dMark Vantage CPU Test2 Physix only!

    1. 4870x2 CF primaryscreen + 8800 Ultra > physix disabled 130.68 Steps/S
    2. 4870x2 CF primaryscreen + 8800 Ultra > Physix enabled 16.53Steps/S
    3. 4870x2 CF Primaryscreen + 8800 Ultra > Physix Grayed 131.43 Steps/S <--- happens if u only de/reactivate ati card
    4. crash goto bug:


    FluidMark Windowed Mode

    1. 4870x2 CF primaryscreen + 8800 Ultra > physix disabled 8279 o3Marks
    2. 4870x2 CF primaryscreen + 8800 Ultra > Physix enabled 1635 o3Mrks
    3. 4870x2 CF Primaryscreen + 8800 Ultra > Physix Grayed 8759 o3marks <--- happens if u only de/reactivate ati card
    4. 4870x2 CF Primaryscreen + 8800 Ultra > Physix Grayed 8280 o3marks

    Test Explain:

    There were 4 types of NV 182.05 Beta driver tests

    1.With Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI
    in window Physix not choosable cause nv and physix controlpanal crashes and is not reachable

    2.Without Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI
    in window Physix not choosable cause nv and physix controlpanal crashes and is not reachable

    3.Without Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on
    8800,in full screen Physix not choosable cause nv and physix controlpanal crashes and is not reachable

    4.With Deactivated/Activated ATI Card for the screen switch,"Primary Screen Flag" on ATI
    in full screen Physix not choosable cause nv and physix controlpanal crashes and is not reachable

    5. And as Final With Only the 4870X2 Crossfire 8800 ultra deactivated
    Benchmark Results:

    [NV 182.05 Beta Driver]

    Futuremark Tests:

    4. 1. 4870x2 CF Primaryscreen + 8800 Ultra > Physix Grayed 137.77Steps/s<--- happens if u only de/reactivate ati card
    5. 4870x3 Crossfire Primaryscreen witouth 8800 ultra 20.78 Steps/s
    Fluidmark tests:

    1. 4870x2 CF Primaryscreen + 8800 Ultra > Physix Grayed 9044 o3marks<--- happens if u only de/reactivate ati card
    2. 4870x2 CF primaryscreen + 8800 Ultra > physix Grayed 8506 o3Marks
    3. 4870x2 CF + 8800 Ultra Primaryscreen > Physix Grayed 8073 o3marks
    4. 4870x2 CF primaryscreen + 8800 Ultra > physix Grayed 288 o3Marks
    5. 4870x3 Crossfire Primaryscreen witouth 8800 ultra 1546 o3Marks

    Mirrors edge benchmark around 60 fps doesnt matter which config
    testing wddm1.1 with forced tomorrow maybe



    if u can follow this u can see u just have a loss when u force to deactivate it in physix panel
    and a lil gain when u just let it grayed also u see that the 182.05 is a lil faster than the wddm 1.1
    but not rly important i think when u need nv cpl u should use the wddm 1.1





    Fluid mark test wddm 3 and nv182.05 1 are same just under diffrent drivers
    same for 3dmark wddm 3 and nv182.05 4

    finaly u see without the gf gpu the benchmark toos get low results so i say it works no need to do anything even the deactivate activate thing is not needed for games probem first time seen today and i run this system with os now 4 weeks its just needed to activate 1 screen at the nv gpu to activate the physix calculation over it

    need a game were we can see a hard physix usage not like mirrors edge but cant find anything
     
    Last edited: Feb 18, 2009
  9. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Elisdee, I used the WDM 1.1, 180.48 and 181.20 Nvidia drivers. WDM 1.1 and 9.1 Ati drivers.

    I found also I didn't mention before that once the display is extended to the ATI, the Nvidia CP would crash if I went into any other tabs bar PhysX. reason why I would leave the ATI's disabled while setting anything in the Nvidia CP, but then leave open on the PhysX tab.

    Fluid mark I had to use a later PhysX driver. Stock 1.1 would run. I could use right up to the latest. I never tried full screen. I was watching the GPU's to see if they were working, like in CCC and Evga precision.

    Interesting how some things work, don't work and variations of set up on different systems. Going to be a trial and error for each system.
     
  10. Ellisdee

    Ellisdee Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    2x4870x2 1x8800 Ultra
    the only point i dont understrand is y does physix test programs can handle
    the geforce for physix and mirrrors edge cant or maybe my cpu is to good in
    physix calculating casue of the same results in every try dont know waiting
    for cryostasis have the hope the game has a higher physix load

    my physix driver in every case was 909.02.03
    found out yesterday on the search for the nvidia demos on my hard disk
    (maybe like ageia boxes) a "PhysXCplUI.exe" to enter the physix control
    panal ( not the one in nv controlpanel its still not reachabel for me) the
    exe is located there
    C:\Windows\SysWOW64\PhysXCplUI.exe

    but one question is the nv cpl crashing for all when the use actual driver or its just me ^^

    but i think cryostasis will give me another problem when its only dx10 cause of win7 directx10 calculating over cpu the techdemo is just crashing :(

    figured out the old physix cpl has no effect when u force switch off in driver 182.05 what i posted some rows up
     
    Last edited: Feb 18, 2009

  11. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    I'm now using the 9800GX2 as PhysX. Some unkown reason my 280 just upped and died.

    9.2 and 182.05 drivers. All still works and smoother. Mirors Edge a lot better with these drivers and not getting major FPS drops using the 4870X2 as display and the 9800GX2 as PhysX.
     
  12. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    Sorry for your 280 card :/
    But it's good to know that newest versions of drivers from both camps work fine together.

    Have you tried if there is any difference between Physx in 182.05 and official WHQL 182.06?

    EDIT: I'm asking cos I've heared that some major Physx bugs are squashed in WHQL driver, but I guess those are same since .05 was WHQL candidate right?
     
  13. Ellisdee

    Ellisdee Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    2x4870x2 1x8800 Ultra
    no diffrence seen using 182.06 and 9.2 at same time now and think so too 05 was rc and nothing rly changed

    did the card smoked or what happend?
     
    Last edited: Feb 21, 2009
  14. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    I'm not sure what happened. Turned on my pc and it wasn't showing up, green light on, fan spins 100%. Tried it in 2 other pc's, same result and windows doesn't see it in any of the pc's.

    I'll try the 182.06 latter.
     
  15. Ellisdee

    Ellisdee Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    2x4870x2 1x8800 Ultra
    hmm damn try rma if no garantie loss (watercooler etc)
     

  16. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Done in guarantee changing cooling. Going to pull apart and check inside if something blown.
     
  17. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    Hey Torch'em, Ellisdee, Zazza - I've been gone for a while, as I still haven't bought me a new ATI card :/ But thought about comming here to see if there's anything new..

    I've read that Torch'em is still running PhysX nicely on that 4870X2 + 9800GX2 combo, so I'm glad it's still working. Ellisdee seems silent for almost as long as I was :D Actually, seems that above post is last of his regarding PhysX in mixed nVidia/ATI setup.. And Zazza never got back on that 4870X2+8800GTS combo that was talked about in this thread.

    So to cut the long story short - anything new? Improved? Have drivers or Win7 updates bring any new stuff .. for better or worse? :D

    There has been a terrible silence here about the ATI+nVidia setups, total of just 4 posts on the subject in 39 days.. and I don't like the sound of silence :-O
     
  18. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Nup, still the same. I have not done a lot myself. I'm waiting for the RC version to come out, then I'll re visit again.

    Yes it is quite.
     
  19. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Hi LuxZg,
    yes you're right, I gave no feedback about my configuration but, like Torch'em said, I'm waiting to test it on Windows 7 RC version.
    So I'll report back, supposedly, on May.

    See ya.
     
  20. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    Well, by RC I should have my new ATI card, and will try to obtain some nVidia card as well.. So hopefully we'll do a next round of testing together :)

    See you all in May than!
     

Share This Page