Win7, 4870X2 + 280GTX

Discussion in 'Videocards - Intel ARC & ARC Driver section' started by Torch'em, Jan 17, 2009.

  1. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Hey guys,

    I'm trying to get PhysX to enable and work with these GPU's with out much luck.

    Gigabyte X58 extreme
    MSI 4870X2 x 2. Top, middle slots as per manual says for Crossfire.
    XFX 280GTX. Bottom slot
    1250w PSU
    6 gig ram. 3 x 2 sticks.

    OS win7 64 dual booted Vista 64 but on separate HD's.

    I can install the drivers, switch to what ever for desk top and seems to work well. I can't enable PhysX on the 280. The only Nvidia drivers which work with giving errors are the ones it loads on windows up date. I've installed the PhysX drivers separate and the box GPU option is greyed out. The Nvidia control panel doesn't give PhysX option or tab either. Connected, disconected a monitor countless times to the 280 to see if that get the PhysX option.
    Other thing is when I try to run Vantage is a "Fail to run full screen error". I've uninstalled 4 times now and still get the same error.

    The 280 is out of my other pc, so it's just a curiousity thing to see if I can get everything working on Windows7.

    Thanks
     
    Last edited: Jan 17, 2009
  2. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Got it working. :banana:
     
  3. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Hi... Glad to hear that.
    Could you please test if physx appears to be enabled in a real game?
     
  4. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    I've only got UT3. Installing a bit later.
    Does UT3 bench mark with PhysX or just general game FPS?
     

  5. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Well, I'd like to know if this setup is properly working with a Physx supported game like i.e. Mirror's Edge. But I think UT3 will do. This is just to confirm that hardware Physx is enabled in the game.

    Thanks for your time.
     
  6. scoter man1

    scoter man1 Ancient Guru

    Messages:
    4,868
    Likes Received:
    160
    GPU:
    MSI GTX 1070ti
    Dang, that system should burn a mile wide hole through any game you play...
     
  7. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    I'm downloading the PhysX mod' pack for UT3. I'll also grab ut3bench 2.1 I think the latest is and wil try time permitting today.
     
  8. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Meanwhile, thanks...
    I'll wait for your report.
     
  9. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Right I've downloaded and installed the UT3 PhysX pack. Played just on the 280, switched, enabled PhysX and on the 4870X2 display, looked exactly the same to me. PhysX box in UT3 still checked. The bench mark tool doesn't seem to have the PhysX demo or map to bench.

    I can run the PhysX demos, fluid mark ect and seems to be working. Switching to CPU only is a big drop so it does seem to work. Fluid mark FPS drops below what the 280 had but looks to be working.

    I can't post attachments here, so if you want a screen shot, PM me your Email add'.

    What I'm trying to do now which is more difficult is trying to just use one display and still be able to keep PhysX enabled. Going to take some time as I jagged it once, but can't replicate it again. ATM only 1 4870X2 in as swapping GPU's around is getting tiresome.
     
  10. Doug

    Doug Ancient Guru

    Messages:
    4,906
    Likes Received:
    0
    GPU:
    GTX 970
    you could upload ths screenie to imageshack or tinypic etc then post the image though? :)
     

  11. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Heres some. Hope you can see and read LOL. I've never used Image shack before.

    [​IMG]

    [​IMG]
     
  12. Zazza

    Zazza Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    ATI 4870x2 + 8800GTS
    Reading impossible. :D
    Anyway, for what I read around, UT3 got the worst Physx implementation to tell.

    Here, you can take a look at titles that support Physx.:

    http://en.wikipedia.org/wiki/PhysX

    I suggest you to try out Mirror's Edge since you should easily notice the difference.

    Here's the in-game comparison:

    http://www.youtube.com/watch?v=w0xRJt8rcmY
     
  13. Doug

    Doug Ancient Guru

    Messages:
    4,906
    Likes Received:
    0
    GPU:
    GTX 970
    wow thats a lot more games than i thought supporting PhysX
     
  14. Colt M4

    Colt M4 Master Guru

    Messages:
    855
    Likes Received:
    0
    GPU:
    Evga GTX 970 SC Sli
    didn't know Grid support physX
     
  15. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Looks like I'm going to have to bite the bullet and buy Mirrors Edge. I'm back on shift for the next 3 weeks tomorrow, so hopefully can get a copy and give it a go today before work chews up my play time.

    Heres a Vantage link ran run 15 min's ago so you can see the CPU tests. Not worried about graphic ones etc.

    http://service.futuremark.com/compare?3dmv=782303
     

  16. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Playing Miirors Edge. Apart from my eyes burning from the bright colours :puke2:, I've got a few questions for anyone who else is playing it.

    1. How do you get more FPS than 62? I've disabled Vsync etc in game and in the control panels but Fraps doesn't go higher than 62 not matter what ressy' I'm using.

    2.What FPS do you get enabling in game physx;
    A, using a ATI and your CPU does the work?
    B, Do you get the annoying pointer flicker on the screen with ATi GPU? Doesn't appear PhysX on/off with the Nvidia GPU. Just smashes the FPS C/panel off and in game on for the 280.

    I can see all the PhysX gear, plastic sheets, holes tearing in it, shattering glass etc, but I just want some info from other peeps what they get.

    Thanks.
     
  17. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    Anyone help out?
     
  18. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    I don't have a solution for Mirrors Edge unfortunately, but I do have one suggestion and a few questions.

    Suggestion is to just use a DVI->VGA dongle on nVidia card. It should be enough for it to THINK that it has display attached to it. So no need to have two displays on your table just for testing...

    And now the questions :)
    First - how did you exactly do it? Enabling the Physx on this setup and all.. I mean, how did you get around the initial problems?

    And about the benches.. While you play or bench any of the games/applications, have you tried comparing following numbers:
    - just GTX 280 in your system - Physx enabled (on GPU)
    - just GTX 280 in your system - Physx enabled (on CPU)
    - just GTX 280 in your system - Physx disabled
    - just HD4870 X2 - Physx disabled
    - just HD4870 X2 - Physx enabled (on CPU)
    - both GTX 280 and HD4870 X2 - Physx disabled
    - both GTX 280 and HD4870 X2 - Physx enabled (on CPU)
    - both GTX 280 and HD4870 X2 - Physx enabled (on GPU)

    If list is a bit too long, you could just try first one and last three

    I'm asking because I'd really like to see if the numbers are better, they should scale something like this (for enabled Physx effects):
    BEST: both GTX 280 and HD4870 X2 - Physx enabled (on GPU) - because ATi is rendering and nVidia is doing Physx
    BIT LOWER: just GTX 280 in your system - Physx enabled (on GPU) - but it has to be lower; if it's same as first one than you've got nothing from using 2 cards
    WAY LOWER (CPU Physx):
    - just GTX 280 in your system
    - just HD4870 X2
    - both GTX 280 and HD4870 X2 (with video rendering on one card, than on another)
    These last three should scale the same with Physx completely disabled and enabled on CPU I guess.. And third one should give roughly same number as you get when using just one card in system (depending which you're using for rendering at the time)

    So once again - why all this?
    Because if you get about the same numbers with just GTX280 (when Physx is enabled on GPU) as you get when using two cards (ATi for rendering and nVidia just for Physx) than you have no use from it all.. Or maybe you always have both Physx and rendering done just on GTX card (? just checking :) )

    Anyway, I'd still like to know what you did exactly to get it working :) Mostly because I'm playing with a thought to test out a setup with ATi for graphics + nVidia PCI or PCIe x1 card for Physx :nerd: .. for all of us that don't have dual PCIe x16 MBOs and money to get two cards 500$ each :D
    Cheers! And thanks for giving us all some hope :D
     
    Last edited: Feb 14, 2009
  19. Torch'em

    Torch'em Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    3 x 480GTX
    This how I do it;

    First up 2 monitors as it's a lot easier.

    Using windows control panel, display ressy, click to show only the nvidia GPU display. Leave open.

    In the Device Manager, disable the Ati Gpu('s).

    Make sure PhysX is enabled in the Nvidia CP by just clicking it on and off and hit apply. Leave open

    Go back into the Dev' man', enable the Ati GPU('s). The screens will flick and carry on.

    In the windows display CP, click on the Ati display picture, click on extend check box, apply and then click PhysX disable then enable and apply should appear in the NV C/Panel. Hit apply.

    I then run Vantage CPU test 2 to see if PhysX is really enabled. If enable doesn't appear, redo the above. It works 8 out of 10 times for me this way, but a simpler way is proberly there but I have not found it as yet.

    Now I'm getting high CPU scores with PhysX enabled than when it's not as it should. What I'm wanting to do is make sure it actually works in games.


    Just because I could, put in a 9800GX2 with the 4870X2 and 280GTX and added a old monitor to see if it worked with 3 diff' types of GPU's, 1 Xfire, 1 Sli and 1 normal. It does with Sli on and of the 9800GX2. I just have to disable the display for the GPU doing the PhysX, do my steps and I can still run Vantage CPU test 2 with PhysX enabled. Vantage scores differ using either the 280 , 9800GX2 in Sli or single config for PyhsX. Games maybe a different matter I suspect.
     
  20. LuxZg

    LuxZg Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD4890
    Tnx for details! Looking forward to more info in future
     

Share This Page