Win 8.1, D3Doverrider and Triple Buffering

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by bloowhalez, Nov 30, 2013.

  1. Terepin

    Terepin Master Guru

    Messages:
    802
    Likes Received:
    77
    GPU:
    ASUS RTX 3070 Ti
    Any Dead Space, not just first.
     
  2. JLevi

    JLevi Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Nope
    I just tried Tomb Raider. First with Radeon Pro and second with D3DOverrider, all using my Nvidia Card, but I'm not any wiser.

    Just uploaded all FPS-benchmarks (Fraps):
    http://www.datafilehost.com/d/6025678f

    If anyone might have a look. There are four folders.

    D3DO-Vsync_TP_ON
    RadeonPro-Vsync_off_TB_off
    RadeonPro-Vsync_on_TB_off
    RadeonPro-Vsync_on_TB_on

    but I couldn't see any real difference between any of the logs.

    Like I said, using RadeonPro with an Nvidia-Card and forcing VSync does work. But I'm still not sure if forcing Triple Buffering works. I know that DirectX doesn't support Triple Buffering by default and these are just dirty hacks, but at least they made some games bearable.
     
    Last edited: Apr 8, 2014
  3. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,268
    Likes Received:
    1,986
    GPU:
    Zotac GTX980Ti OC
    But did you disable ingame triplebuffering?
     
  4. Bradders684

    Bradders684 Maha Guru

    Messages:
    1,007
    Likes Received:
    3
    GPU:
    MSI GTX 980 Ti GAMING
    Triple Buffering definitely works using RadeonPro with NVIDIA.

    Assassin's Creed 4: Black Flag

    In game settings:

    [​IMG]

    V-Sync on in game:

    [​IMG]

    As you can see my FPS is locked at 30fps because it doesn't support Triple Buffering.

    V-Sync off in game:

    [​IMG]

    41 FPS.

    V-Sync off in game but with it on in RadeonPro, Triple Buffering is turned off:

    [​IMG]

    My FPS is locked at 30fps again.

    V-Sync off in game but with it on in RadeonPro, Triple Buffering is turned on:

    [​IMG]

    41 FPS again.

    I am using Windows 8.1 Update 1 btw.
     
    Last edited: Apr 8, 2014

  5. JLevi

    JLevi Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Nope
    Thanks. With WDDM 2.0 it will all be gone, but at least for now I will continue using RadeonPro.
     
  6. Deasnutz

    Deasnutz Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Titan X 12GB
    When is WDDM 2.0 expected?
     
  7. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    So far, MS only said DX12, so it is when DX12 is released.
     
  8. Singleton99

    Singleton99 Maha Guru

    Messages:
    1,048
    Likes Received:
    85
    GPU:
    Aorus-Extreme-1080TI
    d3doverrider is working for me in AC4 , it removes the screen tearing and locks my fps @ 60 ,, Win 8.1 64bit , hope this helps :)
     
  9. Terepin

    Terepin Master Guru

    Messages:
    802
    Likes Received:
    77
    GPU:
    ASUS RTX 3070 Ti
    Together with DX12.
     
    Last edited: Apr 21, 2014
  10. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,833
    Likes Received:
    1,663
    GPU:
    MSI 3080 Gaming X
    D3DO does not seem to play along with Wildstar 64-bit on Win8.1 x64 :(
     

  11. CoMa666

    CoMa666 Master Guru

    Messages:
    418
    Likes Received:
    1
    GPU:
    rtx 3090 Fe
    So what's the best solution for reduce game stuttering?
    RAdeonpro, d3doverider or buy a good g-sync monitor when will be out?
    I have insane stuttering in a 120 hz monitor in TitanFall.
     
  12. mordan

    mordan Member

    Messages:
    19
    Likes Received:
    3
    GPU:
    EVGA GTX1080SC ACX3
    I don't know if this is the correct spot to ask this but I cannot run D3DOverrider under Windows 8.1... Well when I double click on it it does seem to run as I see the process via task manager but I don't get any interface... Any help?
     
  13. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,833
    Likes Received:
    1,663
    GPU:
    MSI 3080 Gaming X
    It runs just fine here and it always starts minimised (I have it on autostart). If I want to open it and do something I just double click the icon in sys tray.

    Note that the program does not support x64 bit apps.
     
  14. mordan

    mordan Member

    Messages:
    19
    Likes Received:
    3
    GPU:
    EVGA GTX1080SC ACX3
    Thanks for your quick response, the problem is that it does not appear on my sys tray, therefor no GUI to do anything, tried running it in compatibility for Win 7, Vista, XP still nothing, just wanted to play Metro 2033 and AC4 with Vsync and TB as I did with my Win 7 installation before... can't seem to do that now and forcing those settings through RadeonPro doesn't seem to work either. Oh, well... Thanks anyway.
     
  15. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    windows by default doesnt show all tray icons, so are you positive it's not there?

    or you can edit the config file to have StartMinimized=1 maybe even FirstRun=1 just in case

    single click :nerd: double click will end up single clicking the next icon in the tray
     

  16. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,833
    Likes Received:
    1,663
    GPU:
    MSI 3080 Gaming X
    :D

    /10char
     

Share This Page