Win 8.1, D3Doverrider and Triple Buffering

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by bloowhalez, Nov 30, 2013.

  1. fleggy

    fleggy Member Guru

    Messages:
    133
    Likes Received:
    5
    GPU:
    GB 3090 Gaming OC
    Sorry, I have only desktop GPU but I think it will work. RadeonPro supports all DirectX tweaks on my GTX 780 Ti and some other things:
    - SMAA/FXAA injecting
    - everything about V-Sync and TB
    - FPS limiter
    - SweetFX injecting (version 1.4 only ATM)
    - FPS monitoring, recording
    - dynamically turning ON/OFF SMAA/FXAA/SweetFX during playing
    - dynamically changing FPS limiter during playing
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,677
    Likes Received:
    3,145
    It works fine with W8 or any newer unreleased OS due to adaptive hooking system. _Clean_ install of D3DOverrider on new OS is the only thing needed to get it working. Alternately, to simulate clean install you may just manually delete configuration files from application's .\Profiles\Config folder.
     
  3. Anarion

    Anarion Ancient Guru

    Messages:
    13,605
    Likes Received:
    382
    GPU:
    GeForce RTX 3060 Ti
    I need to try that. I could swear I have done that but I need to check it out.
     
  4. alabrand

    alabrand Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    Nvidia GeForce GT 650M
    Would be nice if someone with a mobile GPU could confirm if these settings work as well, when using Optimus.
     

  5. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    As I know, only triple-buffering don't works.

    For SweetFX, I am using the official one, so I guess it's works too.
     
  6. Anarion

    Anarion Ancient Guru

    Messages:
    13,605
    Likes Received:
    382
    GPU:
    GeForce RTX 3060 Ti
    Deleted profile folder and added Skyrim again. Tearing is still all over the place so v-sync does not (nor triple buffering) work. Weird....?

    EDIT:
    Facepalm. I had some weird version of D3DOverriderWrapper.exe. Now it works... :bang: Now I can only dream about 64-bit support.
     
    Last edited: Dec 3, 2013
  7. fleggy

    fleggy Member Guru

    Messages:
    133
    Likes Received:
    5
    GPU:
    GB 3090 Gaming OC
    Try RadeonPro. It can be switched to 64-bit mode though I didn't test TB in this mode. Perhaps you will have to find another dream :)
     
  8. DLG

    DLG Active Member

    Messages:
    67
    Likes Received:
    0
    GPU:
    Zotac AMP 1080Ti
    tried the stutter fix mod on skyrim nexus?
     
  9. gpvecchi

    gpvecchi Member Guru

    Messages:
    124
    Likes Received:
    3
    GPU:
    Aorus GTX 1080Ti Xtreme
    RadeonPro says "unable to initiate something" and doesn't work for me: all options are greyed out.
    Any help, please?
     
  10. fleggy

    fleggy Member Guru

    Messages:
    133
    Likes Received:
    5
    GPU:
    GB 3090 Gaming OC
    Some more details? During its installation or when you run it or when a game/profile is loading? Which version? Mobile or desktop GPU?
    BTW I use RP from April 2013.
     

  11. gpvecchi

    gpvecchi Member Guru

    Messages:
    124
    Likes Received:
    3
    GPU:
    Aorus GTX 1080Ti Xtreme
    When I launch it. A popup in taskbar...
    Check my specs, I'm on W8.1...
     
  12. fleggy

    fleggy Member Guru

    Messages:
    133
    Likes Received:
    5
    GPU:
    GB 3090 Gaming OC
    Check if RadeonPro support service is running. Try to install RP with admin credentials. Maybe someone else who's running RP on W8.1 can help?
     
    Last edited: Dec 5, 2013
  13. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,172
    Likes Received:
    2,004
    GPU:
    GTX1070 iChillx4
    meh , somehow i cant force vsync anymore with rp or d3doverrider in windows 8.1. it is not working anymore :( nvcp is working fine :bang:
     
  14. Terepin

    Terepin Master Guru

    Messages:
    802
    Likes Received:
    77
    GPU:
    ASUS RTX 3070 Ti
    There is always RadeonPro.
     
  15. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,172
    Likes Received:
    2,004
    GPU:
    GTX1070 iChillx4
    thats what i ment with rp ;)
     

  16. Anarion

    Anarion Ancient Guru

    Messages:
    13,605
    Likes Received:
    382
    GPU:
    GeForce RTX 3060 Ti
    You know... Sometimes I noticed that if you have enabled v-sync from NVIDIA CP and then disable it from there, it might end up being enabled. In that case either reset the profile or use nvidia inspector to fix it.
     
  17. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,172
    Likes Received:
    2,004
    GPU:
    GTX1070 iChillx4
    Thanks, ive checked it and it was set to off. also reset the profiles. still am not able to force vsync through d3doverrider or rp. Think ill reinstall the nvidia drivers in a minute.

    edit
    Reinstalling drivers did nothing :bang:
    edit2
    seems to be a problem with the origin client. if i launch radeonpro with origin the game crashes. if i launch the game from within radeonpro or click the exe in windows it runs fine.
    d3doverrider still doesnt work though. dont know why it stopped working it worked fine a few hours ago.
     
    Last edited: Feb 14, 2014
  18. JLevi

    JLevi Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Nope
    May anyone please tell me if this is true? I know that the VSync-option and frame-limiters from RadeonPro do work. But I don't know which game I could test the "Force Triple Buffering"-option on.

    Any idea? The game I'm looking for should not have any kind of double/triple buffering already built in and should have intense graphics, so I can drop under 60 fps. Without triple buffering, it should drop to 30 fps.
     
  19. JLevi

    JLevi Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Nope
    Anonye?
     
  20. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,268
    Likes Received:
    1,986
    GPU:
    Zotac GTX980Ti OC
    For example Dead Space1, FEAR1, Metal Gear rising

    or newer Hitman A, TombRaider, have a option to turn it off.
     

Share This Page