Win 7 Desktop laggy

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Angushades, Jan 6, 2013.

  1. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Hey guys since the 300 series drivers and my 680gtx my windows is very laggy , i mean when everytime i drag or re-size or just lower a window to the taskbar its very slow and then it can speed up back to normal smoothness . I'm running 3 LCDs but not in surround so i have no idea what could cause this problem. also my brother has a first gen i7 with 2 560Ti , 4 screens and he has that problem too since updating. In window 8 it doesn't happen but 7 it does.

    Any idea and does anybody else have this problem?
     
  2. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Oh forgot to add even if i open steam or lol or really any window it slowish , sometimes it will go smooth as its ment to be but most of the time its slowish.
     
  3. Penal Stingray

    Penal Stingray Banned

    Messages:
    957
    Likes Received:
    0
    GPU:
    GTX 680 Tri-Sli-S27A950
    Get windows 8 lol
     
  4. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    I do own it but i don't want to reformat
     

  5. Zareph

    Zareph Ancient Guru

    Messages:
    2,626
    Likes Received:
    0
    GPU:
    Sapphire NITRO+ RX480 4GB
    I don't see why anyone would ever wanna downgrade to Win 8. Anyhow, has this only started happening since you updated your video drivers or what?
     
  6. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Well only since i've brought my 680GTX, off-course i have reformatted heaps since then and it hasn't changed. i I use 2 DVI's and 1 HDMI to run the screens. When i got the 680 there was only one WHQL driver for it and a beta.
     
  7. The Goose

    The Goose Ancient Guru

    Messages:
    2,448
    Likes Received:
    80
    GPU:
    MSIrtx2080 superXS
    try just using 1 screen
     
  8. Penal Stingray

    Penal Stingray Banned

    Messages:
    957
    Likes Received:
    0
    GPU:
    GTX 680 Tri-Sli-S27A950
    Stop being lazy and go stick ur windows 8 on that dvd rom and let the awesome sensation of windows 8 caress you.
     
    Last edited: Jan 6, 2013
  9. Noisiv

    Noisiv Ancient Guru

    Messages:
    6,990
    Likes Received:
    674
    GPU:
    2070 Super
    :thumbup: Windows 7 are so 1986

    Anyway, I went berserk trying to fix similar issues like OP.
    Turned out all it was needed was reseating cables, gfx card, RAM.
     
  10. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    You serious as i have rebuilt the pc in a case-labs case with my water-cooling...plus i went to a couple of LANs and its still the same.
     

  11. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Bump , nobody has had this problem or not many ppl run more then 2 screens?
     
  12. Tastic

    Tastic Member

    Messages:
    17
    Likes Received:
    1
    GPU:
    RTX 2080
    Many things could be causing this, but because you mentioned this occurred when you updated to the 300 series, here's what I recommend.

    For starters, turn off Aero if you haven't already (assuming you're running Windows 7). For your desktop themes, change to Windows 7 Basic UI Theme. The Aero theme adds quite a bit of input lag which is likely contributing to your problem if you haven't already turned it off already. This is a basic gaming tweak you should always use, because having Aero enabled affects your in game performance as well, not just your desktop.

    As for your drivers, Nvidia series 300 drivers are well known to have unnecessarily high input lag. One setting that really contributes to this are your scaling options. Open up your Nvidia control panel, and find your 'scaling options.' When you locate it, select 'Do Not Scale,' and make sure 'Display' is selected in the drop box. Click apply, reboot, and test.

    If you still have issues after this, try out different Nvidia drivers. Personally, I find that 295.73 and 270.52 work well. If you go this route, download 'Driver Sweeper' and clean out all remaining Nivida files after you uninstall your current drivers to make sure you don't have conflicting files with a new driver set.

    You'll be amazed at the boost in responsiveness these two tweaks will do for your system. Hope this helps.
     
    Last edited: Jan 15, 2013
  13. playswithfire

    playswithfire Active Member

    Messages:
    75
    Likes Received:
    0
    GPU:
    GTX670 SLI
    Not the OP here, but I tried out using older drivers for my 670, and it wouldn't install them as the card wasn't available when those drivers were released. :/ The oldest drivers I could install were 301.something.
     
  14. Prophet

    Prophet Master Guru

    Messages:
    802
    Likes Received:
    7
    GPU:
    Msi 680 Gtx Twin Frozr
    Using 297.16 working fine on my 680. Was a bit tricky to get them installed though.
     
  15. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    Well i got feed up and now i'm just using my single display. I have no problems now. Windows 8 is a better OS for multi displays. Funny that it took MS so facking long to support it decently.
     
    Last edited: Jan 16, 2013

  16. Uncle Dude

    Uncle Dude Ancient Guru

    Messages:
    2,312
    Likes Received:
    5
    GPU:
    GTX 1080 Ti
    Check that your refresh rate is correct in Nvidia control panel. I've had mine set to 24Hz by a set of drivers a while back.
     
  17. kilyan

    kilyan Master Guru

    Messages:
    594
    Likes Received:
    6
    GPU:
    evga 1080 sc gaming
    windows 8 sux balls don't do something stupid and stick with windows 7,for now
     
  18. BABA-The Hacker

    BABA-The Hacker Banned

    Messages:
    455
    Likes Received:
    0
    GPU:
    PALIT GTX770 OC 2GB
    U have a 7970.....and
    and
    again "and"

    symptoms can be clearer, sir/m'aam?
     
  19. Angushades

    Angushades Master Guru

    Messages:
    218
    Likes Received:
    31
    GPU:
    Gigabyte 2080 OC
    I have a 680GTX , i sold my 7970's due to crap drivers and microstutter. No need to continue the thread as i said i just gave up on using more then one screen.

    Thanks for the input guys but i have checked all that long before i posted up problem.

    Thanks again. Guru's
     
  20. mutate44

    mutate44 Member Guru

    Messages:
    104
    Likes Received:
    0
    GPU:
    GTX 680 2GB WF 1293 Boost
    I have always had crappy dual monitor performance on windows 7 while dragging and closing windows from one screen to the other. To fix it I changed refresh rate from 60 to 59 on the other monitor it was smooth for a while but it came back. With aero off it's smooth. I now have windows 8 and the problem does not exist anymore.
     

Share This Page