Win 7 64 bit + OpenGL + Counter-Strike

Discussion in 'Games, Gaming & Game-demos' started by FliE, Apr 25, 2010.

  1. FliE

    FliE New Member

    Messages:
    7
    Likes Received:
    0
    Equals trouble ahead.

    Good day kind people of Guru 3D.

    I'm a counter-strike player for 11 years and running, and I just recently purchased a new computer, equipped with a XFX Radeon HD 5870, and no complaints from the performance department.

    However, while all new games work (Just Cause 2, FarCry 2 & SHIFT for example), I am having problems with Counter-Strike 1.6, and the OpenGL mode. I have been trying to solve this for a good two months now, and tried every solution google could throw at me, but all my attempts have been futile.

    The problem, in layman's terms, is with flickering textures. Google told me this can be fixed by disabling 'Back -or Depth buffer' from RivaTuner settings, but obviously RivaTuner doesn't yet support 5870, even with the fix/hack that's supposed to make it compatible.

    http://www.youtube.com/watch?v=xLiR969S0Tk

    Here's a video to better portray the problem.

    So any suggestions on how to fix this? I've already tried almost everything humanly possible, from new drivers to different version of opengl to replacing the atioglxx.dll with one from an older version and so on but nothing works. The dll switching supposedly does the trick for some but I get the error message 'Failed to load loadlibrary error 998' or something along those lines, so no dice.

    All help appreciated. While I can keep myself entertained with some real life activities and other games cs is just something that's almost part of my daily routine already and it's annoying to be without.

    Thanks in advance!
     
  2. Cybermancer

    Cybermancer Don Quixote

    Messages:
    13,801
    Likes Received:
    0
  3. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    Not very familiar with CS myself, but surely you can run it in DX something? It doesn't have to be openGL?
     
  4. [ R ]

    [ R ] Master Guru

    Messages:
    790
    Likes Received:
    0

    i think thats D3D, and have you tried the usual? right click exe and choose run as admin or run in compatability to a lower OS etc? have you tried downclocking your clocks of your GPU
     

  5. Labyrinth

    Labyrinth Ancient Guru

    Messages:
    4,287
    Likes Received:
    0
    What drivers for your 5870?
    does this happen in half life 1 too ?
    try disabling catalyst AI and try again
     
  6. FliE

    FliE New Member

    Messages:
    7
    Likes Received:
    0
    CS is such an old game OpenGL is really the only choice. D3D and Software both affect the gameplay somewhat and make the mouse 'sluggish'. And I think the anticheat everyone uses doesn't support anything but OpenGL. The problem disappears in D3D mode, though.

    Catalyst AI, clocks, resolution, windowed/full screen, drivers, compatibility or admin rights make no difference, and the problem affects HL too. And I'm currently running the latest drivers, 10.3 I believe.

    It most likely is because Windows' very lacking support for OpenGL, and that 'Back / Depth Buffer' -thing is so far the only thing I've heard about and that I haven't been able to test.

    Thanks for the suggestions, though! Is my only hope really to just wait for the new RivaTuner that hopefully lets me adjust the OpenGL settings :D?
     
    Last edited: Apr 27, 2010
  7. damage-_-inc

    damage-_-inc Member Guru

    Messages:
    130
    Likes Received:
    0
    A 1.6 player from Finland... I <3 u
     
  8. gamerk2

    gamerk2 Ancient Guru

    Messages:
    2,108
    Likes Received:
    0
    The return of crappy ATI OpenGL drivers, prehaps? Considering their track record in that area, its certainly a possibility. [I eagery await Rage/Doom4 just to test this theory out...].
     
  9. Stukov

    Stukov Ancient Guru

    Messages:
    4,899
    Likes Received:
    0
    I was pretty sure that Half-life was built around D3D not OpenGL, but I can be wrong.
     
  10. Tranzmit

    Tranzmit Member Guru

    Messages:
    162
    Likes Received:
    0
    old cs player here too in fact i used to play the .7 beta when the p90 was the gun to use as it didnt have any bullet spread heh heh. that was when it was obviously still a mod for half life and yes half life and open GL were the way it went with worse performance as its technically running a modified Quake engine. and that was made to run on the voodoo's using mini GL if anyone remembers

    Sorry i have no idea as to why your having issues beyond trying the latest beta drivers/
     

  11. ady1969

    ady1969 New Member

    Messages:
    6
    Likes Received:
    0
    i just instaled cs1.6 and work ok with HD5770 ,OpenGL 1920X1200 32bits
    with Catalyst 10.4b driver on Win7 X64
    run in compatibility Win XP sp3
     
  12. FliE

    FliE New Member

    Messages:
    7
    Likes Received:
    0
    Well I installed the latest package from ATI site, 10.4, but no improvement (although I'd like to say the flickering was reduced a bit but I'm not sure).

    I read some good things about the beta 10.4, any official dl link for it? I found one that links to Megaupload but I'm not exactly thrilled about getting my drivers from Megaupload :p
     
  13. Aura89

    Aura89 Ancient Guru

    Messages:
    6,257
    Likes Received:
    2
    All i have to say on this subject is that CS 1.6 and OpenGL has always, always given me problems, D3D or whatever is the only thing i've been able to play the game with and actually have it look RIGHT
     
  14. ady1969

    ady1969 New Member

    Messages:
    6
    Likes Received:
    0
    yes ,Megaupload version are ok 4 me
     
  15. FliE

    FliE New Member

    Messages:
    7
    Likes Received:
    0

  16. stooeh

    stooeh Member

    Messages:
    34
    Likes Received:
    0
    When Half-Life came out it ran much better in OpenGL than it did in d3d (for both my banshee and Geforce 1).
    OGL support in games is pretty poor compared to D3D nowadays :(
     
  17. inklimited

    inklimited Ancient Guru

    Messages:
    6,118
    Likes Received:
    0
    Have you tried a driver refresh? Tried rolling back drivers to an earlier set?

    Driver Refreshing:
    -Uninstall Catalyst
    -Delete everything from Documents and Settings related to ATI or ACE
    -Delete everthing from registry related to ATI or ACE
    -Delete the C:\ATI driver install temp folder
    -Install new drivers
     
  18. inklimited

    inklimited Ancient Guru

    Messages:
    6,118
    Likes Received:
    0
    ...and try fiddling with the Z buffer (after you refresh ;))
     
  19. FliE

    FliE New Member

    Messages:
    7
    Likes Received:
    0
    I now have the 10.4b drives installed (seem legit thus far) but the problem still persists sadly. I think the drivers helped a little, though.

    Oh and the only OpenGL setting I can change from the control center is triple buffer (on/off). I used to have z-buffer there as well but it disappeared at some point.

    God forsaken new OS :( I'd change over to XP SP3 in a heartbeat if it wasn't for D3D 10 & 11 and new games that only work on 7...

    [Edit:] After the first match with 10.4b it became apparent that OpenGL 4.0 had in fact made the problem HEAPS worse in full screen. Reverting back to 9.1 now :/
     
    Last edited: May 2, 2010
  20. ady1969

    ady1969 New Member

    Messages:
    6
    Likes Received:
    0
    i use cs16full v3 with cs16patch full v19 and work ok
     

Share This Page