1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why does "LocalSystem Container" use 0.2% CPU perma even in idle?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by kurtextrem, Mar 21, 2018.

  1. kurtextrem

    kurtextrem Member Guru

    Messages:
    154
    Likes Received:
    3
    GPU:
    NVIDIA GeForce GTX 970
    Why does the LocalSystem Container service use 0.2% CPU * 2 permanently even in idle? When I start programs or so it goes up to 1% and more, but even if I don't move my mouse at all and all programs are closed it uses 0.1-0.2% for no apparent reason.
    See here: http://prntscr.com/iuathg
    I'm using the latest driver available.

    If I deactivate the service Geforce Experience stops working (which I need for ShadowPlay)

    CC @ManuelG - I guess this is caused by a while loop which scans for key bindings, but there are other programs which do this with 0% CPU usage and they don't spawn twice.
     
  2. maur0

    maur0 Master Guru

    Messages:
    728
    Likes Received:
    21
    GPU:
    point of view gtx 570 1gb
    in my pc using 0%
    [​IMG]
     
  3. khanmein

    khanmein Ancient Guru

    Messages:
    1,572
    Likes Received:
    65
    GPU:
    EVGA GTX 1070 SC
  4. scaramonga

    scaramonga Member Guru

    Messages:
    136
    Likes Received:
    4
    GPU:
    GTX 1080 FE H20 EK

  5. GSDragoon

    GSDragoon Member Guru

    Messages:
    131
    Likes Received:
    6
    GPU:
    Gigabyte GTX960 2GB
    This thing spikes up pretty often, nvsvcStereoLaunchW. I wonder if it's trying constantly start up the Stereoscopic 3D stuff. I remove that folder before installing. Do you do the same? If so, you could try installing with that component and see if it makes a difference.

    [​IMG]
     
  6. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,539
    Likes Received:
    171
    GPU:
    MSI GTX 1070
    0% here as well.

    Windows 10 Pro 64-bit (1703)

    Then again, i don't use Bloatware Experience. Only the Driver and PhysX.

    (wonder why i even install PhysX...)
     
    insp1re2600 likes this.
  7. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    1,864
    Likes Received:
    800
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    Likewise. PhysX, however, is just a "library" of sorts. It sits in the background and provides its data only if an application requests it. No harm at all.
     
  8. Sajittarius

    Sajittarius Master Guru

    Messages:
    310
    Likes Received:
    6
    GPU:
    ROG Strix 1080ti
    If you have procexp (SysInternals), you probably have procmon also. You could run it and filter only NVdisplaycontainer exe and it will tell you what it's doing.

    I just did this the other day with Sound Blaster Connect (CPU was always 1-2%) and it turns out is constantly spamming registry lookups to see the network adapter settings. I blocked it by running as a different user and Denying access to some registry keys. Now it is 0%, lol
     
  9. GSDragoon

    GSDragoon Member Guru

    Messages:
    131
    Likes Received:
    6
    GPU:
    Gigabyte GTX960 2GB
    Process Monitor shows nothing. It's all CPU logic.
     
  10. Sajittarius

    Sajittarius Master Guru

    Messages:
    310
    Likes Received:
    6
    GPU:
    ROG Strix 1080ti
    Interesting, I almost always see something in Process Monitor when CPU is being used.
     

Share This Page