Why do my Games cap at 59 FPS instead of 60?

Discussion in 'Videocards - AMD Radeon' started by Bleed, Apr 2, 2017.

  1. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    Windows Control Panel shows 60 Hertz as my screen refresh rate, yet all games cap at 59 fps when vsync is on.

    - I have no framerate limit set.
    - Running Windows 7 64 bit and have an RX 480/8 GB.
    - My monitor is DELL U2312HM on a DisplayPort cable.
    - Running the latest 17.3.3 AMD drivers.
     
  2. Rambo

    Rambo Master Guru

    Messages:
    267
    Likes Received:
    123
    GPU:
    RX 560 w8 4 Vega 56
    Have you researched something? No, you don't. It's normal cuz some monitors have 59.94Hz or other pointless value. Everything is OK, you don't have to by worry.
     
  3. RealNC

    RealNC Ancient Guru

    Messages:
    3,122
    Likes Received:
    1,347
    GPU:
    EVGA GTX 980 Ti FTW
    Check your refresh rate here:

    https://www.vsynctester.com

    (Let it run for about 10 seconds so it can figure out your refresh rate.)

    It's probably 59.94Hz or something like that. It's normal. Many games or external OSDs like to just truncate the FPS value. If it's 59.9, some of them just strip the ".9" and only display "59".
     
    Last edited: Apr 3, 2017
  4. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    It's 60.0002719 Hz as you can see in this screenshot I took.
    http://imgur.com/6pOuQed
    Also, fps is pretty much stuck at 59, also visible in the screenshot.
     

  5. RealNC

    RealNC Ancient Guru

    Messages:
    3,122
    Likes Received:
    1,347
    GPU:
    EVGA GTX 980 Ti FTW
    In that case, you do seem to have a weird issue. Have you tweaked something in your AMD control panel and forgot about it? Does this only happen with vsync? If you turn off vsync, does your FPS go above 60?

    Also, on the vsynctester site, does the scrolling background seem to stutter once per second? (It would look like a frameskip every second.) That would happen with 59FPS on 60Hz. If not, then you're fine regardless, but then I can't explain what's going on there :p
     
    Last edited: Apr 3, 2017
  6. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,845
    Likes Received:
    131
    GPU:
    EVGA 1080 Ti FTW3
    Yep. I had the same thing with my 2 computers (980Ti via HDMI, HD6870 via DP) and I was able to get all games to use 60Hz by using CRU. Of course make a backup .edid file via CRU first, but then just delete all extension blocks for your active display. You will lose sound over that connection, but most likely lose the 59vs60 issue and get less stutter. Keep in mind this is a VERY short explanation of something I've put dozens of hours in testing on multiple computers. If you'd like more depth or detail let us know, but for now give this simple idea a try and report back.

    https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU
     
  7. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    Tweak something like what? Power efficiency is Global off, framerate target Global off. All of the settings are mostly at the default values. I do have GPU Scaling on, but can confirm it changes nothing if I turn it off.
    Also, it only caps at 59 when vsync is on, if I switch it off, fps goes above 60.

    EDIT: Yes, it stutters, It's like a pause for half a second.
     
    Last edited: Apr 3, 2017
  8. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    But I have no extensions, the list is empty for me:
    http://imgur.com/ymtDMpt
     
  9. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    HEY guys! I have found the problem, took me all day but by Geralt of Rivia I did it!
    it was f.lux, you know that little essential utility that dims your display at nightime.
    Well, it was causing stuttering in everything, not just games, lots of forums posts with this issue, but no fix.
    Now I don't know what's worse, stuttering or my eyes bleeding from all the blue glow.
    Do you awesome people know of any alternative to f.lux?
     
  10. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,845
    Likes Received:
    131
    GPU:
    EVGA 1080 Ti FTW3
    Ahh, nice to hear that you found it. I've never come across any monitor or TV that didn't have extension blocks, so that was weird. As for replacing f.lux, can't you just use the AMD control panel color tools or the monitor menu settings to take some blue out?
     

  11. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    I suppose I could, but it's not automatic therefore it will be a pain to change every time. f.lux is great because once it's night it dims the color temperature and in the morning it switches it back at the default value.
     
  12. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,845
    Likes Received:
    131
    GPU:
    EVGA 1080 Ti FTW3
    Hmm, my best guess is maybe use the Crimson panel to make a color profile and assign it to a hotkey? I switched to nvidia before Crimson was out so I'm not sure if it can do that or not.
     
  13. Bleed

    Bleed Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD RX 480/8 GB
    I'll keep looking for something more practical, in the meantime I think I have found an alternative, if anyone else is interested:
    https://www.reddit.com/r/pcgaming/comments/53dhi6/i_have_two_good_alternatives_to_flux/
    Also, turning on safe mode under f.lux's setting seems to fix the problem as well.

    Thank you very much for all the help guys, can't believe it was under my nose this whole time. GLORIOUS 60 fps here I come!
     

Share This Page