WF3 7950 showing artifacts, please need advise

Discussion in 'Videocards - AMD Radeon' started by agapitoxxx, Mar 17, 2013.

  1. agapitoxxx

    agapitoxxx New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    7950 WF3
    Hello,

    I read a lot of threads on this forum before attempting to post.

    I recently purchased a WF3 gigabyte 7950, the first day was fine, however on the second day while i was playing battlefield 3 it started to show up weird artifacts.

    Tried with other drivers, I was using 13.1, switched to 13.2, 13.3 (almost all the betas on both) even reverted to 12.11 and 12.10 (finally reverted to 13.2 beta 4). Running drive sweeper and rebooted before every driver installation.

    Funny thing is that my new card is running Bios FX0, so i cannot update it to FZ3, and it has 1000mhz stock. the artifacts shows on the catalyst screen and in some games, some other are ok, even when i attempt to run a couple of emulators (pcsx and dolphin), there are no graphical issues.

    I attached some screenshots from GPU-Z and artifacts.

    Should I RMA it or there might be another solution?

    Thanks in advance
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  2. IcE

    IcE Don Snow Staff Member

    Messages:
    10,654
    Likes Received:
    11
    GPU:
    Gigabyte 970 G1
    Faulty VRAM/core for sure. Try backing down the clocks and see if it goes away. Regardless, looks like an RMA is in your future.
     
  3. agapitoxxx

    agapitoxxx New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    7950 WF3
    what is the best tool to drop my clocks?
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Afterburner but looks like bad vram so I'd just go ahead and RMA.
     

  5. agapitoxxx

    agapitoxxx New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    7950 WF3
    alright, thank you for the fast response.
     
  6. Fox2232

    Fox2232 Ancient Guru

    Messages:
    5,583
    Likes Received:
    5
    GPU:
    Fury X - XL2420T(Z)@144Hz
    Pretty low asic, what are your voltages and temperatures?
     
  7. agapitoxxx

    agapitoxxx New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    7950 WF3
    on battlefield 3 with everything on ultra temps dont go higher than 70-72

    voltages, i dont know where to find that, afterburnber doesnt show, i think because of bios FX0, but i could be wrong
     

Share This Page