1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird stutter when enabling G-Sync Compatible

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Vyre, Jan 18, 2019.

  1. Vyre

    Vyre New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    1080TI
    Hello,
    If this is wrong place to ask this, sorry, please move it somewhere more appropriate.
    Also I didn't expect G-Sync to work without a problem on uncertifed monitor but this is really weird and I don't think its monitor that is at fault here.

    So basically after enabling G-Sync in Nvidia Control Panel I launched BFV and was greeted with this. Not a pretty sight. After enabling various stuff in BFV, multiple restarts, god know what else (but i didnt set it to dx12, this will be important later) it somehow stopped doing that. Overjoyed I played for an hour or two and then i slept my PC and went to do something else. When i came back and launched BFV, the issue came back.
    I was annoyed so I started digging deeper. I downloaded program to test freesync/gsync called Refresh2025 and while i was using it I noticed that this issue only happens on DX11 and Vulkan and not on DX12.

    DX11
    DX12
    Vulkan

    My monitor : 27'' LG 27UD58-W

    If you have any troubleshooting tips or know what's going on here, kindly share. I'm out of my mind here.

    EDIT: After DDU-ing and installing "clean" driver issue persists.

    EDIT2: For anyone experiencing this problem, simply poweroff and poweron your monitor while your pc is running, it will fix it.
     
    Last edited: Jan 18, 2019
  2. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,790
    Likes Received:
    478
    GPU:
    R9 290 Crossfire
    My Monitor same panel you have.I know what this is and here is the fix.
    Change resolution to some different in Nvidia control panel run Nvidia Pendulum Demo if you want to check it out and switch back to Native 3840 x 2160.Boom.
    If you get the weird crap in game do the same change resolution. You will have to do it every restart for me I only restart my computer when testing overclocks.

    Also I changed freesync range with CRU 33-61 and tested from 30-40 FPS in Nvidia Pendulum Demo video below.If you use after burner you can turn on frametimes and see how smooth the adaptive/freesync/gsync is.

    LG 27" 4K UHD 5ms GTG IPS LED FreeSync Gaming Monitor (27UD59P-B.AUS) - Black



    Shadow Of The Tomb Raider 4K Ultra SMAAT2X with FPS 35-45 and smooth.
     
    Last edited: Jan 18, 2019
  3. skacikpl

    skacikpl Member Guru

    Messages:
    129
    Likes Received:
    12
    GPU:
    MSI GTX 1070 8G
    I get similar effect every time i reboot the PC after enabling G-sync.
    In my case manually powering the monitor off and on (while PC is running) fixes it.
    It's not a long term solution but since something as trivial seems to solve it, i would guess it might be solved driver side eventually.
     
    fluidz likes this.
  4. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,790
    Likes Received:
    478
    GPU:
    R9 290 Crossfire
    Yes I agree will be fixed ,turning the monitor on/off is even a lot faster.I think i will just do this.Thanks
     
    toyo likes this.

  5. Vyre

    Vyre New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    1080TI
    Thanks for the fix! It works great.
    (A tak btw to wszędzie cię widzę. Pewnie dlatego że mamy podobne zainteresowania lol)

    Thanks for the initial fix but I guess the one that SkacikPL posted is kinda easier to do.
     
    skacikpl likes this.
  6. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,790
    Likes Received:
    478
    GPU:
    R9 290 Crossfire
    Way easier to do,I will be just turning it on /off for a couple days until hot fix is released.
     
  7. Warkratos

    Warkratos Active Member

    Messages:
    63
    Likes Received:
    18
    GPU:
    GTX 1060 6Gb
    Same issue here, with an LG 29UM68-P, this monitor works at 75Hz with freesync, but when I keep my monitor idling (or reboot my PC) for some minutes it begins to skip frames (test with UFOTest https://www.testufo.com/frameskipping) and causing some stutters. Works fine at 60hz.

    My workaround is to go to the monitor OSD config and set the "Ratio" to "Original" then back to "Wide". fixes my issue until they release new drivers.

    I have submitted an report using this link too: https://surveys.nvidia.com/index.jsp?pi=c7e1841997b517fad69d16106b36250b
     
  8. Vlooi

    Vlooi Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    GTX 980ti
    For Samsung U28E590D owners power on off does not work. Just toggle your input selector on the OSD to HDMI1 and back (or any other source for that matter). It will work perfectly then.
     
  9. Erick

    Erick Member

    Messages:
    47
    Likes Received:
    8
    GPU:
    AMD R9 Fury 4GB HBM
    It appears to be a pixel clock and vertical range issue with the G-Sync compatible monitors or...rather FreeSync monitors and DisplayPort issues that we never knew about. It seems to actually scan all vertical and horizontal ranges correctly. I changed my Samsung monitor's vertical minimum range to the default (per the manual) 56hz - 72hz and G-Sync stopped scanning. I then set the minimum back to 48hz and G-Sync was working again. If you can get your minimum vertical range to go lower then it's better, however, you may run into some flashing and black screen issues with gaming.

    The good thing about G-Sync is that it shows if an area of the game causes frames to dip. V-Sync probably locked the refresh to mask those problems whereas G-Sync revealed more problems to the naked eye; we may say that the game might really be broken if it stutters.

    So if it stutters and you have G-Sync compatible enabled, then I agree and it's a problem.
     
    Last edited: Jan 20, 2019
  10. PeskyPotato

    PeskyPotato New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    GTX 970 M
    Just want to say, I have an AW2518H, and have similar issues.

    Even with just regular refresh rate on, rather the G-Sync it is capable of, sometimes the edges of my screen glitch out or get weird opaque/brokenness. Sometimes with a line of the same issue down the center of the screen, but sometimes just on the edges... and even if there isn't any of this more obvious type of issue going on with the monitor, I get some stuttering at times even when my FPS is great & above the 240hz I have.

    In all cases, I've been learning over the months that as gerardfaser said above, changing the resolution or refresh rate of the monitor in the Nvidia Control Panel... then switching it back to the 240hz @ 1920x1080... fixes the issues.

    It's interesting to hear that powering the monitor off and back on while the computer has loaded windows already may help just as much, since it seems like it'll be a lot faster to fix now. Honestly, I'll probably just start turning my monitor off & back on everytime I load up Windows and open a game to play, just to be safe.

    It's probably some issue with G-Sync capable monitors, since I never had as many issues like this with my old Acer 120hz, non G-Sync or Freesync & non ULMB capable monitor. It used DVI cables though, so I guess it could also just be a Display Port thing too?

    Either way, while in some ways I'm very impressed with how 240hz feels compared to 120hz, I guess I've basically found ULMB and G-Sync to be kind of useless for FPS gaming due to the input lag introduced... and when you add in the fact that it can be difficult or impossible to get 300FPS+ constant/stable in a lot of games, it kind of makes me question if the pricetag for this monitor was really worth it overall. These issues and bugs really, really don't help either :/
     

  11. ceevee

    ceevee New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    1050ti
    1050ti with HP 25mx (Gsync compatible). Driver 436.02 (Aug 20 2019 release date)

    After putting the monitor to sleep for an unknown duration, adaptive sync stops working smoothly. Ways I can tell:

    • Pendulum demo has very slight microstutter.
    • Moving a window around on the desktop very fast can produce very slight microstutter.
    • TestUFO demos have performance warnings or states "sync failure". -> this is my go to test as it doesn't rely on my vision to detect and it fast to complete

    If I restart the computer, TestUFO VRR works (green "ready" statement). All other symptoms mentioned above do not manifest.

    I've tried the following without success to get adaptive sync to work again without restarting the PC:
    • Turning monitor on and off
    • turning off displayport hot plug detection low power mode option in the monitor OSD
    • turning off power saving functions in the monitor OSD (still allows monitor to sleep, but not in a further reduced power mode)
    • turning off power saving functions + turning off displayport hot plug detection low power mode
    • changing monitor refresh rate back and forth

    I still need to test the following:
    • restarting the graphics driver
    • switch inputs back and forth
    • others?
    The issue with testing is that putting the monitor to sleep doesn't always result in adaptive sync not working smoothly. It seems like sleep for some unknown duration of time causes the issue.

    I'll continue to investigate.
     
    Last edited: Aug 25, 2019
  12. SoLoR

    SoLoR Master Guru

    Messages:
    221
    Likes Received:
    2
    GPU:
    MSI GTX 1660 Ti
    I also get issue with gsync compatible aoc g2590fx, mostly it happens when you alt + tab (and then back) or go on other monitor (that is some normal 60hz - not gsync/freesync), powering monitor on/off fixes issue for me but its annoying...
     
    Last edited: Aug 26, 2019
  13. Chastity

    Chastity Ancient Guru

    Messages:
    1,948
    Likes Received:
    480
    GPU:
    Nitro 390/GTX1070M
    Turning off/on works for me. The glitch is a firmware issue, which was fixed in Samsung's Gamer monitors but the U series got no firmware update.
     
  14. SoLoR

    SoLoR Master Guru

    Messages:
    221
    Likes Received:
    2
    GPU:
    MSI GTX 1660 Ti
    Hm... all should try 436.15 driver... i didnt get stutter for last ~day... coincidence?
     
  15. ceevee

    ceevee New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    1050ti
    I built another PC with all new parts, with the exception of the monitor and GPU (still 1050ti and HP 25mx monitor). Same nvidia driver.

    The problems persisted.

    However, I partially solved it by doing the following:
    • Using High Performance power plan. I also turned off C states. This solved the microstuttering during the pendulum demo and performance issues in TestUFO demos.
    • Turning OFF displayport hot plug detection low power mode and keeping auto power off ON. This solved black screen issues after sleep when starting a game or pendulum demo. A side effect is that I need to wake the monitor manually by pressing one of the OSD buttons. I need to do this because the monitor sleeps (does not completely turn off as intended), but does not wake with mouse movement.
    • I also installed the HP 25mx monitor driver (previously identified in device manager as PnP display). Not sure if this did anything.

    TestUFO demos no longer give performance warnings or sync failures. The pendulum demo is without microstutter, confirmed subjectively by looking and objectively by a smoother frametime graph. Black screen issues are gone, but I need to manually wake the monitoring by pressing an OSD button (non-power button).

    Retrospectively, the black screen problem is maybe a monitor firmware or nvidia driver issue. The stuttering issue was maybe due to downclocking from low load in the pendulum and TestUFO demos.
     
    Last edited: Aug 30, 2019

  16. janos666

    janos666 Master Guru

    Messages:
    664
    Likes Received:
    43
    GPU:
    MSI GTX1070 SH EK X 8Gb
    Just for reference, it's highly unlikely you really turned off all C states. The most you are usually allowed to do (easily from user menus without tweaking) is to disable all states deeper than C1 (cores are at full voltage but clock-gated during idle). Although that's usually plenty enough when you have latency issues because the return latency (time to switch to P state) grows rapidly as you move to deeper C states and nowadays there are plenty of those (ranging from a few microseconds to hundreds of microseconds, although the last few states around C6 have so many per-requisites you probably never encounter those on a workstation or gaming PC).

    The frequency scaling is a funny topic though. For decades it was mostly accepted as a common rule that it doesn't significantly affect performance. You could find benchmark results trying to prove this. But then both Intel (with SkyLake and SpeedShift) and AMD (with Zen2 and CPPC2) came out with much faster scaling solutions and their marketing now shows benchmark results trying to prove how much it matters in some cases.
    I guess it's only logical to assume that C-states are next. :)
     
    Last edited: Aug 30, 2019

Share This Page