Weird laptop behavior - Low FPS ingames and more

Discussion in 'Laptops & Notebooks' started by tudorboanca, Jul 14, 2017.

  1. tudorboanca

    tudorboanca New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTX 1050 Ti / 4096 MB
    Hi there everyone.
    I have a Lenovo Y520 with:
    GTX 1050 Ti
    i7-7700HQ
    8 GB DDR4
    A 256 GB SSD NVM.e + 1 TB 5400 RPM HDD

    My problems are the following.
    1) I have tryed to play a game that is old but has been released recently in Europe, Black Squad, and I get ~30 FPS ingame. My friends that have a crappy PC get 100+ FPS...
    I have tryed to set the game on VERY LOW, Turn off V-Sync, Run the game in SAFE MODE, run with GPU priority for the dedicated GPU, Updated all the drivers, Close all programs, Scanned for Malware and Viruses, Checked the Processes and killed the ones that consumed more than normal.
    2) After I saw that I have this problem I wanted to see how much of my GPU is used so I installed MSI Afterburner in which I noticed that the values go to 0 once every 1 second and then they jump back to where they were. (ex: 40-0-40-0-41-0-42-0-40-0; those are the celsius degrees for the dedicated GPU). If I select the onboard GPU I do NOT get the same reaction.
    After I saw this I thought that there is something wrong with MSI Afterburner and so I installed GPU-Z, where I get the same behaviour.

    Can you guys help me with those problems? Will a Windows reinstall help?

    Note that I can run every game smooth, but this Black Squad doesn't want to run smooth. Even in the main menu, the cursor lags...

    Here is my GPU-Z LOG FILE (it's big so I decided to copy and paste only a part of it because it goes the same untill the end):

     
  2. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    9,837
    Likes Received:
    75
    GPU:
    1080Ti H20
    Looks pretty clear that those games are using IGP and not the 1050ti.

    First make sure bios is up to date and also you may try using Snappy Driver installer to update all your drivers.
     
  3. tudorboanca

    tudorboanca New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTX 1050 Ti / 4096 MB
    I have just found another person having that low fps problem as I do and I asked him to test his GPU in the GPU-Z and MSI Afterburner and it seems that the alternates happen to him too... Same as for me. And he has a GTX 1070...

    EDIT: I have the "NVIDIA GPU Activity" thing activated and I can see in the tray when the video card is being used. And when the game that goes only 30 FPS is started, it appears in the list. So that means that the game is not running on the IGP :(
     
    Last edited: Jul 14, 2017
  4. DaRealGuru

    DaRealGuru Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    GTX 980 4GB
    If it is an older game, is it possible that you are having issues due to your OS? I remember having really bad frame rate drops trying to play some older games on my Windows 7 laptop.
     

Share This Page