Weird colours Driver Video Amd

Discussion in 'Videocards - AMD Radeon Drivers Section' started by EyesBlue1988, Jun 25, 2019.

  1. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    we can confirm is bug of amd or windows 1903 version
     
  2. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    i have now reinstall driver AG241QG and i-menu , i hope they fix bug amd driver or maybe is 1903 version the problem, the 1809 don't have give me this problem weird colours
     
  3. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    Yes the bug only apply when i go to lock screen and i off screen . When i on screen and i'm back login screen strange colors appear
     
  4. patteSatan

    patteSatan Member Guru

    Messages:
    198
    Likes Received:
    55
    GPU:
    Sapphire R9 390
    It can be VLC player, turn off hardware acceleration in VLC.
     

  5. exmodel

    exmodel Member

    Messages:
    32
    Likes Received:
    5
    GPU:
    MSI RX570 8GB
    I updated from 19.52 and Windows to 1903 at the same time and get this pretty often. Mine is purple however, although today my main screen was almost completely white. It's easily fixed by toggling between my main and secondary monitor with the win+P shortcut but definitely annoying.
     
  6. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    yes sometimes the colour is purple, blue, red in the screen
     
  7. ninja750

    ninja750 Master Guru

    Messages:
    302
    Likes Received:
    76
    GPU:
    RX 6800 REF
    i don't remember this issue in the known issues of the latest drivers, maybe no-one has submitted it
     
  8. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    now i have colours purple/blue unity. For fix i select resolution or vertical or horrizontal and the screen back normal colours

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  9. Undying

    Undying Ancient Guru

    Messages:
    16,463
    Likes Received:
    5,400
    GPU:
    Aorus RX580 XTR 8GB
    I've seen all three green, blue and pink, its random. Somewhere half way through when the screen blinks color appears while finishing the installation. When its done it asks for restart then when it boots everything is fine like i said.
     
  10. OnnA

    OnnA Ancient Guru

    Messages:
    13,492
    Likes Received:
    3,436
    GPU:
    3080Ti VISION OC
    You don't need to unplug the cable ;)
    Once after restart go into windows display settings (right click on desktop)
    And it will back to normal.
    19.6.2 WHQL is free from this issue (on my RIG).
     
    MerolaC likes this.

  11. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    I have now done clean installation of amd driver, before I used DDU in safe mode. The bug still persists with the 19.6.2 june24 drivers

    [​IMG]

    [​IMG]
     
  12. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    I have now done clean installation of amd driver, before I used DDU in safe mode. The bug still persists with the 19.6.2 june24 drivers
     
    passenger likes this.
  13. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,623
    Likes Received:
    478
    GPU:
    MSI 5600XT G. MX
    Yeah, well, was faster for me :p

    It stopped happening to me now.
    But, I updated the driver and the the BIOS with GOP v2.7.0.0.0
    So, it can be one or the other.
     
  14. EyesBlue1988

    EyesBlue1988 Member

    Messages:
    31
    Likes Received:
    2
    GPU:
    Asus Strix gtx 970 4GB OC
    Again with 19.6.3 june 27 . The wrong color at end of driver install still happens (Lime color again!)

    [​IMG]

    [​IMG]

    [​IMG]
     
    JonasBeckman likes this.
  15. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,390
    Likes Received:
    832
    GPU:
    Gigabyte 3060 Ti
    Fixes with a restart.
     
    Undying likes this.

  16. OnnA

    OnnA Ancient Guru

    Messages:
    13,492
    Likes Received:
    3,436
    GPU:
    3080Ti VISION OC
    Or go into Windows Display settings (right click on desktop)
     
  17. Krteq

    Krteq Master Guru

    Messages:
    798
    Likes Received:
    374
    GPU:
    RX Vega 56 +64 BIOS
    Created a video with Radeon SW 19.6.3 driver upgrade from 19.6.2 - No weird color issues for me :)

    RX Vega 56 connected to AOC AG271QX via DisplayPort
    Windows 10 1903 build 18362.175



    Sorry for video quality, captured by phone

    //Just a question: Are you guys using a correct driver and color profile provided by your panel manufacturer?
     
    Last edited: Jun 30, 2019
    OnnA likes this.
  18. AlleyViper

    AlleyViper Master Guru

    Messages:
    482
    Likes Received:
    70
    GPU:
    Strix 2070S A|480 X
    It has nothing to do with color profiles (happens with and without one installed, just as a pnp monitor), and yes, using an inplace update greatly reduces the chance for it to happen, or using the "clean" install in the amd setup that forces a reboot.

    If you do instead the following: uninstall via amd setup, ddu what's left, and clean install the new driver, chances are much higher that you get the crazy colors. It can fail too, it's pretty random.
     
  19. Krteq

    Krteq Master Guru

    Messages:
    798
    Likes Received:
    374
    GPU:
    RX Vega 56 +64 BIOS
    So, a root cause is DDU? Didn't used it for ages, that's probably a reason why I'm not experiencing this issue.

    Let's try to summon @Wagnard to check this thread?
     
  20. AlleyViper

    AlleyViper Master Guru

    Messages:
    482
    Likes Received:
    70
    GPU:
    Strix 2070S A|480 X
    No, it's certainly not ddu the root of this problem. It's a clean install, ddu just makes it easier to show. I've had it the first time installing the amd driver after a fresh windows install without ddu ever being run before

    Let's not forget all the crap the amd installer slips along the driver that could interfere on a clean install, like the Pci bus driver, which you'll already have running during a in-place update, if you haven't completely removed it before or aren't starting from fresh.
     
    Last edited: Jul 1, 2019
    SpajdrEX likes this.

Share This Page