[Watch Dogs] Disable flashing objects, and excessive brightness?

Discussion in 'Game Tweaks and Modifications' started by Deebz, Nov 2, 2014.

  1. Leemonoid

    Leemonoid New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX970
    Success!

    I am excited to report that, using the hint given by Voodoman above, I've removed the flashing effect from objects in the game!
    Follow the steps below and the flashing will be gone from bridges, trains, electrical boxes, etc.

    Here is how to fix the issue:

    Update 9 Nov 2014: The code shown below has been approved by Bo3b, the author of the 3Dmigoto tool. He also verified that doing it as shown should not have any other adverse affects on the game.

    1) Grab a copy of 3Dmigoto from:
    github.com/bo3b/3Dmigoto/releases/download/0.91-beta/3Dmigoto-WatchDogs-0.91.zip

    2) Copy all of the files from the .zip to the "bin" folder of your Watch Dogs game.

    3) Delete all of the files in the "ShaderFixes" folder. They are fixes for 3D monitors/TVs etc. They are NOT required to fix the flashing objects.

    4) Create a file called "30265556e47ec3f0-ps_replace.txt" in the ShaderFixes folder

    5) Enter the text below into the file:
    Code:
    
    void main(
      float3 v0 : TEXCOORD0,
      float4 v1 : SV_Position0,
      out float4 o0 : SV_Target0)
    {
      // disable flashing bridges, selection effect.
      o0 = 0;
      return;
    }
    
    
    6) Save the file and launch Watch Dogs. If everything worked properly, you should see a .bin file created in the folder
    where you saved the .txt file and the flashing will be gone!

    Lee
     
    Last edited: Nov 10, 2014
  2. Wasser

    Wasser New Member

    Messages:
    5
    Likes Received:
    0
    I have not tried your fix yet, but may I ask how did you find out?
     
  3. Leemonoid

    Leemonoid New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX970
    The long and winding road...

    The short answer is: I got lucky. :)

    I had never heard of Helix mod before and I downloaded it because Voodooman mentioned it. I tried to get it to work but then realized that it only supported DX9 and the game is DX11. I stumbled across the DX11 stuff from 3DMITOGO and realized that it seemed to have the same "hunting" functions that will let you turn shaders on and off that Helix mod does.

    I set "hunting=1" in the d3dx.ini file, loaded the game and stood next to a junction box. As I turned slowly from side to side to make it blink, I pressed the 2 key on the numeric keypad over and over again and noticed that different bits of the graphics were turning on and off. Eventually, the highlight disappeared from the junction box. I then ran around the game and saw that ALL of the flashing crap had stopped flashing but the control indicators were still visible.

    I then went WOOOHOOO! :) It took me another bit to figure out that pressing the 3 key on the numeric keypad saved the current shader that was disabled into a .txt file in the ShaderFixes directory.

    I restarted the game and... it didn't work. I read further about the Helix mod and realized that you need to disable the shader code that is in the text file. I took the active code out of the snippet you see in my message above and just left the return; statement.

    I restarted the game and nothing was flashing, profit!

    I know that was rather long winded, but I hope it explains how I got it to work. I am baffled why Ubisoft barfed up such a beautiful game with huge obnoxious flashing in the first place.

    Lee
     
    Last edited: Nov 8, 2014
  4. Essenthy

    Essenthy Master Guru

    Messages:
    415
    Likes Received:
    2
    GPU:
    GTX 980Ti 6GB
    gonna try that
     

  5. Essenthy

    Essenthy Master Guru

    Messages:
    415
    Likes Received:
    2
    GPU:
    GTX 980Ti 6GB
    work like a charm ! thanks sir that was a good find

    [​IMG]
     
  6. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Hey nice find and good work.

    Quick question though for those who have got it working. I looked at the helixmod page, thing is I want to disable those flashing textures, but I dont want all this that the mod does....

    Is there a way for this to work, without all that stuff above ??

    edit, plus after looking at the files contained in this pack, look inside the d3dx.ini file, stuff like this I certainly dont want to happen

     
    Last edited: Nov 8, 2014
  7. Leemonoid

    Leemonoid New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX970
    Lines in the .ini file that start with a ";" are comments. Those lines are ignored by the program. If you only want the shader fix that I found, then follow the instructions I listed: install the program then remove all the files from the ShaderFixes folder. Add the file that I showed you how to create to the ShaderFixes folder. That way, as far as I can tell, the only change that will be applied to the shaders is the one that disables the flashing.

    Lee
     
  8. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    ahh ok.

    I will give it a try. So all the d3d11.dll, d3dcompiler_46.dll, D3DCompiler_46_org.dll, d3dx.ini etc still need to be copied to the bin folder still, then just have your "30265556e47ec3f0-ps_replace.txt" only in the shaderfixes folder.

    edit:

    ok so tried this out, yes the flashing was gone :banana:

    Only thing is though as my 360 pad seemed to have a mind of its own and started doing all sorts of wierd stuff.

    Think i'll give it a miss though, untill im sure that this flashing textures is the only thing being removed.
    That d3dx.ini file has got alot of stuff going on in it.
     
    Last edited: Nov 8, 2014
  9. Deebz

    Deebz Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    GeForce GTX 1080 Ti
    Finally, this is awesome. Now in true video game hacking fashion, I'll bet you anything that this tweak comes with some sort of nasty side effect that nobody has discovered yet. :p

    Either way, I'm giving this a shot. Thanks guys!

    EDIT: Works like a charm! :D
     
    Last edited: Nov 9, 2014
  10. bo3bber

    bo3bber Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    GTX 760 SLI
    Bo3b here, from the 3Dmigoto tool. Similar to Helixmod, but works on DX11 games.

    Just want to say- Great! Always happy to see people using the tool, even for stuff other than 3D hacking.
    Please don't hesitate to contact me for any questions regarding the tool, on this game or others. I build it so people can use it. Using it to disable effects, whether 3D or 2D, is easy.

    The technique shown by Leemonoid is pretty good. In general, when we disable an effect, we like to set the output to zero, not leave it undefined, so a better solution here is to set the o0=0; like:

    Code:
    void main(
      float3 v0 : TEXCOORD0,
      float4 v1 : SV_Position0,
      out float4 o0 : SV_Target0)
    {
      // disable flashing bridges, selection effect.
      o0 = 0;
      return;
    }
    
    Also, there is no need to delete the code out of the shader, since this is HLSL, you can just add the o0=0 (or proper output variable) at the end, and the compiler will do the right thing. In general, it's best to leave the code there in case you want to tweak it later (like if it was used somewhere else that you actually want.) Be sure to add comments to remind yourself what you were doing, beats having a mystery 3 months later.


    @slickric21: as long as you don't modify the d3dx.ini file, it will have no other effect on the game. Use the original d3dx.ini that comes with our game fix, as that is tuned for optimal performance, and least impact on the game. You definitely want to at least have hunting=0, because hunting mode uses a lot of CPU.

    It will only compile and run any shaders in the ShaderFixes folder, so if you only have one, it will only do one. I measured CPU usage when hunting=0 at 0.8%, so using the mod to play is very low footprint.

    Let me know if you have any problems and enjoy.


    BTW: you really should play this game in stereoscopic 3D, it's crazy good. Those white outlines on enemy dudes actually make sense in 3D. It actually makes it possible to hit the turns properly when driving.
     

  11. Leemonoid

    Leemonoid New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX970
    Thanks for the awesome tweaking tool Bo3bber! I have modified my instructions above to include the code changes that you suggested. The game looks SO much better without the flashing - maybe I'm overly sensitive to it but I stopped playing because it was too annoying to me. I hate games that scream HERE, LOOK! THIS IS CLICKABLE! at the player. We are not that stupid (most of us, anyway). :)

    Lee
     
  12. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Bo3d and Lee, awesome work guys and thanks slot for making the game more enjoyable.

    I certainly agree with Lee above, why do games have to assume everyone is stupid and have their hand held the whole way through a game.

    This game is much better now !!!

    edit:

    Now we've got this sorted I wonder if there is a way to disable the blue arrows on the road when you plot a waypoint ? (keeping the blue arrows on the minimap so you can follow that) ?

    Its beyond my techincal competance to even begin to start looking at it though :)
     
    Last edited: Nov 10, 2014
  13. Quest

    Quest Member Guru

    Messages:
    127
    Likes Received:
    1
    GPU:
    SLI GTX 770 JETSTREAM 4GB
    wow, can you share it :banana:
     
  14. Leemonoid

    Leemonoid New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX970
    How to disable the blue GPS arrows on the road but keep them on the minimap

    Here is how to remove the blue GPS arrows on the road in game, but leave them on the mini-map. If you already followed the instructions from my earlier post to remove the flashing objects in the game, skip to step 4:

    1) Grab a copy of 3Dmigoto from:
    github.com/bo3b/3Dmigoto/releases/download/0.91-beta/3Dmigoto-WatchDogs-0.91.zip

    2) Copy all of the files from the .zip to the "bin" folder of your Watch Dogs game.

    3) Delete all of the files in the "ShaderFixes" folder. They are fixes for 3D monitors/TVs etc. They are NOT required to remove the GPS arrows.

    4) Create a file called "c5918d4a64885980-ps_replace.txt" in the ShaderFixes folder

    5) Enter the text below into the file:

    Code:
    void main(
      float3 v0 : TEXCOORD0,
      float4 v1 : SV_Position0,
      out float4 o0 : SV_Target0)
    {
      // disable GPS arrows on roadway while retaining them 
      // on the mini-map and map views
      o0 = 0;
      return;
    }
    
    6) Save the file and launch Watch Dogs. If everything worked properly, you should see a .bin file created in the folder where you saved the .txt file and the GPS arrows will be gone!

    Enjoy!

    Lee

    RANT
    The huge, blue GPS arrows on the road are another example of UbiSoft adding stupid, unnecessary clutter into the game world that takes you out of the immersion of the game. Does Aiden have a Terminator style implant in his eye that makes the arrows appear? Wouldn't he (especially) use his phone as a GPS like everyone else? *sigh*
    /RANT
     
    Last edited: Nov 14, 2014
  15. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Take a bow Leemonoid, you are a star.

    The 2 most irritating and unrealistic things in the game that have bugged me since day 1 on this game, and you just come along and remove them with ease.

    Awesome.

    Thanks also to Bo3b for his great tool and sharing the knowledge.

    :banana:
     

  16. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Hey Lee, works a treat btw, But is there anyway to keep the blue arrows on the World Map when you are actually setting the waypoint ?
     
  17. socola

    socola Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    AMD R9 290x 4 GB
    The game doesn't start

    Hi man!First of all, thanks for your work.
    I have a problem. I did everything you said, but doesn't work.
    When i try to start, the game show the little window that appears "WATCH DOGS", and the face of Aiden. After that, the window disappear and nothing happen, the game doesn't start. If i delete all your archives, the game start.
    I'm using the latest Marduk mod.

    Thank You very much
     
  18. ThatGuyOverTher

    ThatGuyOverTher Master Guru

    Messages:
    569
    Likes Received:
    3
    GPU:
    Gigabyte GTX980
    how do i disablele the key press prompt, you know when you are on a ledge and it says "climbdown" and them the space bar button is floating? How do i disable that, all of it, i really hate seeing that kind of stuff since i have played the game on the first day it came out and still play it to this day.
     
  19. txgt

    txgt Master Guru

    Messages:
    815
    Likes Received:
    3
    GPU:
    MSI GTX 1060 6G
    When you use the X360 gamepad it's not that irritating, for me at least.
     
  20. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    3,343
    Likes Received:
    763
    GPU:
    R9 290 Crossfire
    Try just naming the file 30265556e47ec3f0-ps_replace and not 30265556e47ec3f0-ps_replace.txt .See if that helps.
     

Share This Page