Warcraft III - The Frozen Throne - Blank screen @ startup with Start Menu at bottom

Discussion in 'Games, Gaming & Game-demos' started by BeMyMonkey, Jan 13, 2008.

  1. BeMyMonkey

    BeMyMonkey Ancient Guru

    Messages:
    1,844
    Likes Received:
    1
    GPU:
    GeForce 9300M GS
    Hi everyone,

    I just installed Frozen Throne again after about 5 years - and it simply won't start. My screen changes resolution and looks like it's about to load the intro video, but then the taskbar appears at the bottom and nothing else happens. I've tried a bunch of different video, chipset and sound drivers, and none seem to help.

    Anyone having a similar problem?
     
  2. Ex4000

    Ex4000 Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    2600XT
    have you updated the game?
     
  3. BeMyMonkey

    BeMyMonkey Ancient Guru

    Messages:
    1,844
    Likes Received:
    1
    GPU:
    GeForce 9300M GS
    Hey, I just formatted and now it works perfectly fine - looks like it was a pure software problem. Thanks for trying to help... someone can close this :)
     
  4. BeMyMonkey

    BeMyMonkey Ancient Guru

    Messages:
    1,844
    Likes Received:
    1
    GPU:
    GeForce 9300M GS
    Belay that order - just tried to start up a match with my roommate and it's doing really weird things - when I move the mouse pointer to the edges of the screen to scroll, it scrolls about an inch, then jumps all the way to the other end of the map... wha?

    And the unit animation is extremely choppy - looks like about 5 FPS, but everything else is completely smooth - i.e. mouse movement, the two inches of scrolling that are possible, and the animated unit portrait at the bottom of the screen.

    Anyone else had problems like this with WC3?...
     

Share This Page