Wake from sleep issues

Discussion in 'MSI AfterBurner Overclock Application Discussion' started by KillaGramm, Aug 12, 2011.

  1. KillaGramm

    KillaGramm New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD 5970
    Hello all,

    I've been using AfterBurner for quite some time now and have always had this problem, but could never find a solution. I have a Radeon HD 5970 OC'd with AfterBurner to 1.162/850/1102. Everything runs fine during normal operation and extended gaming use. However, if I put the computer to sleep or hibernate, after waking, if I try to launch a 3D application the graphics card freezes. Sometimes it recovers, and sometimes I get a BSoD as well. I've done a lot of searching and tried different things. One person suggested manually changing the ATI Control Center profile to increase the idle frequencies of the GPUs. Nothing has worked so far. However, after sleep, if I manually change to the default profile in AfterBurner, then switch back to the OC profile, the problem seems to be prevented.

    I believe the problem may have to do with the voltage increase not being applied after wake. I think this because if I disable AfterBurner and apply the same OC settings in ATI OverDrive, I get the same freezing behaviour (and the voltage is the only thing that is, seemingly, different).

    Does anyone have similar issues or know if the voltage is, in fact, the problem? If so, any solutions for this?

    Thanks,

    Graham
     
  2. burgoburgo

    burgoburgo New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI HD6850 @ 1030/1233
    Workaround

    Hi.
    I was looking for a solution to this problem and found this thread.

    I've had this problem for a while (running Win7 and a HD6850) and usually just restart afterburner.

    When I couldn't find a better solution, I automated this restart using task scheduler.

    Details:

    I made a batch file that contains the following
    c:
    tskill MSIafterburner
    start /B /D "c:\Program Files (x86)\MSI Afterburner" MSIAfterburner.exe
    exit


    Then using Task Scheduler I created a new task within Event Viewer Tasks.
    In the Trigger tab I added these details (obtained from event viewer)
    Log: System
    Source: Power-Troubleshooter
    Event ID: 1

    Then add the batch file from the Action tab.

    This should work out well as I often forget to restart Afterburner after a resume.
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,949
    Likes Received:
    37
    There is built-in workaround in Afterburner and it was already documented before, setting RestoreAfterSuspendedMode entry to 1 in configuration file will cause Afterburner to save current settings to a temporary profile before the system is entering suspended mode and restore this profile after waking up.
     
  4. burgoburgo

    burgoburgo New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI HD6850 @ 1030/1233
    ha! excellent, cheers.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,949
    Likes Received:
    37
    No problem. BTW, If I were trying to implement task scheduler based workaround like you did, there is more optimal way:

    Just save desired settings to a profile slot then simply launch the following command after resume:

    MSIAfterburner.exe -profile<index> (e.g. MSIAfterburner.exe -profile1)

    This is much faster and eliminates the need of terminating the previous instanse of application.
     
  6. KillaGramm

    KillaGramm New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD 5970
    Thanks to both of you for the responses! I will try the configuration file edit for AfterBurner. From the sounds of it, it will solve the problem!

    Cheers.
     

Share This Page