Vulkan's lauch - 16.15.1009

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ShFil, Feb 16, 2016.

  1. CRTFTW

    CRTFTW Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    radeon 380x X2
    Can you let us know which DLL files you're talking about?

    I know 15.4 is the last driver that had proper triple buffering, so I copied Mantle64.dll, Mantleaxl64.dll, and the 32 bit versions from that install. I put those in my Battlefield folder. Game won't launch though, no crash or anything, it's just won't launch. I guess I'm missing some DLL's but I have no idea which ones.
     
  2. pimpineasy

    pimpineasy Master Guru

    Messages:
    225
    Likes Received:
    10
    GPU:
    1050ti/Rx570
    Last edited: Mar 1, 2016
  3. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
  4. BoMbY

    BoMbY Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    Fury X
    I wouldn't hold my breath. The Vulkan driver is build upon the new libdrm_amdgpu and amdgpu, and they just recently got into trouble with the kernel driver updates. I expect this to be a requirement for the Vulkan drivers.
     

  5. pimpineasy

    pimpineasy Master Guru

    Messages:
    225
    Likes Received:
    10
    GPU:
    1050ti/Rx570
    i have faith seems like they threw in a bunch of android/adreno ****. least a year ago talking about optimize drivers was like pissing in the wind.
     
    Last edited: Mar 1, 2016
  6. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    As far as I understand the code wasn't accepted because it was too "dirty" and it didn't fit the maintenance standards of the kernel. It seems that they more or less copy pasted a bunch of Catalyst code in there. It won't get accepted until it's easy to maintain by third parties.
     
  7. pimpineasy

    pimpineasy Master Guru

    Messages:
    225
    Likes Received:
    10
    GPU:
    1050ti/Rx570
    I understood it as that too im sure a lot of the code between the AMDGPU, Radeon DRM, the AMDKFD (apu), and the MSM DRM(adreno gpu) is mostly using similar code that needs to be consolidated. i was mentioning android because its one of the major players for Vulcan api. The file size grows since its not just a Intel/AMD ballgame anymore they gotta add lines of code for MSM and ARM; moreover, Android N 7.0 is coming out this year and im sure google, qualcomm, and samsung want power efficiency with higher performance at least in the developers menu sometime soon.
     
    Last edited: Mar 2, 2016
  8. billydydcoen

    billydydcoen Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    RTX 2060 OC TUF
    installed this package overwriting Crimson 16.2.1, now the radeon software it's recognized as 15.11, it is normal? driver version is 16.15.1009-160224a-299853E (as far as i know it's the correct version)
     
  9. vancook

    vancook Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    MSI R9 390 8 GB
    The driver 16.2.1 hotfix crimson have the vulkan?
    Need to install driver vulkan and the crimson driver ?
    who driver contain dx 12 11 and all directx + vulkan driver + mantle etc ?
     
  10. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    Nope, it doesn't. They haven't merged the drivers yet. The Vulkan driver contains DX/OpenGL/Mantle DLL. I don't know if the DX dll it has contain the latest fixes for Tomb Raider and the rest.
     

  11. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    After More or less mixing my drivers (16.2.1 on top of the vulkans) its never worked better. Dont nock it if it works
     
  12. srdjan1995

    srdjan1995 Member Guru

    Messages:
    197
    Likes Received:
    33
    GPU:
    RX 580 4GB
    Ok, so I installed Vulkan beta 5 over 16.2.1 Hotfix drivers, and now in Radeon Settings it says I have 15.11 drivers installed, but display driver version is, I suppose newer, then in 16.2.1. Is it ok, or should I install Vulkan drivers first, and then 16.2.1 on top of them?
     
  13. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    the vulkan drivers report as 15.11, just ignore it.
     
  14. srdjan1995

    srdjan1995 Member Guru

    Messages:
    197
    Likes Received:
    33
    GPU:
    RX 580 4GB
    Ok, thanks. That's all I wanted to hear.
     
  15. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    I just saw this. Go to the DLL thread and just download the 15.4 Mantle DLL. Everything you need is in the zip file, just extract all of them in the game directory.
     

  16. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
    i wish we could take the full opengl 4.5 support from this and apply it to the 16.2.1
     
  17. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    I believe that the 16.3 driver has that. I'll check once it finishes downloading and I test it.
     
  18. Berdugoo

    Berdugoo Member Guru

    Messages:
    151
    Likes Received:
    0
    GPU:
    INTEL 4000 w/ AMD 8750M
    may i know complete installation of this Vulkan driver? Help will be appreciated...Tnx :confused::confused::confused:

    edit: now i knew it vuklan is include with amd 16.3 latest driver hehehe:banana:
     
    Last edited: Mar 10, 2016
  19. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,416
    Likes Received:
    839
    GPU:
    Gigabyte 3060 Ti
    Report back your findings please!
    Thanks! :)
     
  20. srdjan1995

    srdjan1995 Member Guru

    Messages:
    197
    Likes Received:
    33
    GPU:
    RX 580 4GB
    16.3 does include Vulkan. So, just uninstall 16.2.1 and Vulkan Beta drivers and install 16.3 Hotfix, and you're good to go.
     

Share This Page