Vulkan's lauch - 16.15.1009

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ShFil, Feb 16, 2016.

  1. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,809
    Likes Received:
    3,366
    GPU:
    6900XT+AW@240Hz
    I just installed them over 16.1.1. and everything is fine. (With exception of weird VSR behavior in few games.)
     
  2. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,890
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    The way they imply about ReShade is that it will support all APIs. Hell, it even supports DX8. I haven't seen anything official yet, but my guess is that everything will be supported soon.
     
  3. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,890
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    What do you mean by weird VSR?
     
  4. Zweite93

    Zweite93 Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    XFX R9 290X Core Edition
    Well it didn't support mantle, so...
     

  5. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,890
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    That's literally an outlier.
     
  6. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,809
    Likes Received:
    3,366
    GPU:
    6900XT+AW@240Hz
    Witcher 3 played on 4k VSR to 1080p zooms in to middle of the screen, so, 75% of image is not visible.

    WH 40k: DoW II - Retribution has similar problem, but only upon change of resolution. Restarting game afterwards fixes it.

    I tried both with Desktop in 1080p and 4k. Neither helps.
     
  7. valkyrjur

    valkyrjur Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    AMD 6700XT
    Vulkan is a new kind of api and is not supported by reshade...yet. I've read in official's reshade forums that the team behind this amazing tool is working on reshade 2.0, so we hope new libraries will be supported.
     
    Last edited: Feb 21, 2016
  8. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    course you probably know already by now:)...but they work great toether
     
  9. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    worked fine for me installing over the top of 16.1.1 hotfix 2.

    it has some newer profiles, so probably worth the effort.

    FO4 seems more stable, but it could be placebo.
     
  10. kilyan

    kilyan Master Guru

    Messages:
    597
    Likes Received:
    8
    GPU:
    evga 1080 sc gaming
    after installing these drivers reshade still works for me Oo
     

  11. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Using hotfix for 16.1.1 hotfix (Fallout 4 fix).

    I see this VSR problem (screen maxed top left side of the image) in Dying Light (new version) but it finally work well.

    In Fallout 4 i can't use VSR black screen and loading mouse pointer circle.Restart don't fix it.

    :bang:

    Yes both games from Steam...
     
  12. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
    So Beta 5 of the Vulkan driver is out
     
  13. spectatorx

    spectatorx Master Guru

    Messages:
    858
    Likes Received:
    169
    GPU:
    Radeon RX580 8GB
    Last edited: Feb 27, 2016
  14. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,418
    Likes Received:
    839
    GPU:
    Gigabyte 3060 Ti
    Why do we have to install a different driver for vulkan? :p

    It will be like this from now on?
     
  15. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,227
    Likes Received:
    171
    GPU:
    RTX 3090 ROG Strix
    Where do you get that DX12 Dolphin release? I'd love to use that!
     

  16. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,623
    Likes Received:
    259
    GPU:
    RX 580 8GB
    They're testing it this way. It should be within the usual driver eventually.
     
  17. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,809
    Likes Received:
    3,366
    GPU:
    6900XT+AW@240Hz
    Thanks, I appreciate early notice.

    As I wrote in 16.2 "hotfix" driver, it broke compute in very bad way.
    So I did test it with this 16.150.1009-160224a (AMD-Vulkan-Radeon-Software-Beta-Feb25) driver installed over 16.2 hotfix.
    Updated Table:
    Code:
    Device		driver			score		utilization
    
    Test 1		262K Trianlges		score		utilization
    Fury X		15.150.0.0 W8=>10	29370		93%
    Fury X		15.200.1040 Tahiti	29790		94%
    Fury X		15.200.1023.10 Fiji	29869		96%
    Fury X		15.300.1025.0		31391		95%
    [I]Fury X		16.150.1009-160213a	33070		100%[/I]
    [B]Fury X		16.150.1009-160224a	33757		100%[/B]
    
    Test 2		488K Triangles
    Fury X		15.150.0.0 W8=>10	3474		95%
    Fury X		15.200.1040 Tahiti	3506		95%
    Fury X		15.300.1025.0		3620		94%
    [I]Fury X		16.150.1009-160213a	4013		100%[/I]
    [B]Fury X		16.150.1009-160224a	4067		100%[/B]
    
    Test 3		2016K Triangles
    Fury X		15.150.0.0 W8=>10	1753		100%
    Fury X		15.200.1040 Tahiti	1788		100%
    Fury X		15.300.1025.0		1779		98%
    [I]Fury X		16.150.1009-160213a	1841		100%[/I]
    [B]Fury X		16.150.1009-160224a	1846		100%[/B]
    
    I want to know what's behind, but for start:
    - Vulkan driver has additional signatures for new libraries not present in 16.2h:
    AMDh265Enc32.dll=SignatureAttributes.PETrust
    AMDh265Enc64.dll=SignatureAttributes.PETrust
    - From binary compare from inf file there are 3 new libraries as part of driver, but no registry change which would be transferable to 16.2 to fix compute there, so it is actually work (improvement) done in libraries.
    - So, amd_opencl64.dll > 16.2 hotfix has version 2.0.4 and Vulkan has version 2.0.6
     
    Last edited: Feb 27, 2016
  18. billydydcoen

    billydydcoen Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    RTX 2060 OC TUF
    So, can i install this beta 5 package as a normal driver after a clean install? Or it's mandatory to install it over a "normal" driver package?
     
  19. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    they don have DX in them, so if you want to game, youll need to install 16.2 first, then upgrade over the top with the vulkan beta.
     
  20. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,890
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    All the Vulkan releases do. They lack the Crimson Control Center. I'm uploading the DLL of the current beta now, and like the previous one it has everything.
     

Share This Page