Very strange problem with MSI RTX 2080 Gaming X trio

Discussion in 'Videocards - NVIDIA GeForce' started by crashburn162, Jul 28, 2021.

  1. crashburn162

    crashburn162 Active Member

    Messages:
    71
    Likes Received:
    5
    GPU:
    MSI 1080 Ti Wc
    So a buddy has an MSI RTX 2080 Gaming X Trio that apparently died we tested it on 3 different systems and the card didn't want to display anything. Then I've tested it on MSI B450 Gaming PRO AC and the card ran fine I ran valley benchmark for about 3 hours played games on it a few days the card seems fine. On any other motherboard chipset the card doesn't want to run, he bought a different MSI B450 board with a different processor and the card runs on it as well. I've tested it on 2 intel systems one AMD X370 the card doesn't want to run he also gave it to a repair shop that concluded that the chip has failed. Since it's running on the B450 chipset can this be something to do with the bios of the card? I am open to all suggestions.
     
  2. vf

    vf Ancient Guru

    Messages:
    1,874
    Likes Received:
    106
    GPU:
    AMD Radeon™
    People has spoken of recent cards not posting with CSM enabled, no?
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,727
    Likes Received:
    4,427
    GPU:
    GTX 1080ti
    graphics cards don't run on a "chipset" they run on the controller embedded in the cpu.
     
  4. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,049
    Likes Received:
    1,466
    GPU:
    Aorus 3090 Xtreme
    I would take the rope off it, then see if you can update its bios to a none naughty version.
     

  5. crashburn162

    crashburn162 Active Member

    Messages:
    71
    Likes Received:
    5
    GPU:
    MSI 1080 Ti Wc
    The machine the B450 one it's LEGACY+ UEFI so this isn't the problem I guess.


    I do know that but I am telling you on what hardware the card runs. Originally tested on MSI B450 Ryzen 3200G, then I switched the cpu to Ryzen 1700 and now my friend runs it on Ryzen 5 3600x. But the card doesn't want to post on any other chipset.

    He hasn't flashed the bios or anything just one day the card didn't want to post. Any ideas what bios should I reflash it to ?
     
  6. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,049
    Likes Received:
    1,466
    GPU:
    Aorus 3090 Xtreme
    It was a joke, you used the word "strangle" in the title :)
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,727
    Likes Received:
    4,427
    GPU:
    GTX 1080ti

Share This Page