Version 3 and Watch Dogs

Discussion in 'MSI AfterBurner Application Development Forum' started by Jonnygrunge, May 27, 2014.

  1. Jonnygrunge

    Jonnygrunge Master Guru

    Messages:
    206
    Likes Received:
    5
    GPU:
    RTX Inno3D 3090 AC
    Hi,

    The new v3 stable does not appear to work with WD! Causes game to hang on blank screen whilst loading, or the game just crashes! Using latest Cats 14.4 WHQL drivers.
    Any ideas?
     
  2. pangeltveit

    pangeltveit Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    EVGA 780ti SC AC Hybrid
    If you have Teamviewer installed on your PC, turn that off, or turn off QuickConnect button.

    If not, then I dont know.
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    16,065
    Likes Received:
    3,655
    Close any other third party 64-bit OSD software.
     
  4. Jonnygrunge

    Jonnygrunge Master Guru

    Messages:
    206
    Likes Received:
    5
    GPU:
    RTX Inno3D 3090 AC
    Through uPlay? only thing I think may be running!
     

  5. Shuter

    Shuter Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    MSI GTX 970
    I also have that problem in any 64 bits videogame. I can't find a solution and i'm tired of searching around. If you solve the problem, please leave a post
     
  6. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    44,679
    Likes Received:
    11,358
    GPU:
    AMD | NVIDIA
    I tested WD 64-bit with almost 10 AMD graphics cards and AB running for OSD. Have not had an issue my man.
     
  7. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    I have no issues with OSD either. Make sure no active 3d processes are running be it Steam overlay or Uplay overlay. They can cause conflicts. You can make profiles for these in the RTSS control panel and then set their detection level to none..
     
  8. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    16,065
    Likes Received:
    3,655
    Just purchased it, works fine here with steam an uplay overlays enabled.
     
  9. Jonnygrunge

    Jonnygrunge Master Guru

    Messages:
    206
    Likes Received:
    5
    GPU:
    RTX Inno3D 3090 AC
    Me bad! :O I forgot I had re-installed uPlay, and forgot to turn off in-game overlay! Working a treat now! Great work as always Hilbert!
     
  10. ZebMacahan

    ZebMacahan Master Guru

    Messages:
    233
    Likes Received:
    4
    GPU:
    ASUS rog strix 3080
    I get no steam or uplay overlay when Afterburner is running when playing Watch Dogs. I have both overlays in the game when Afterburner is not running. As far as I know I do not have any other 3d party OSD programs running on my machine. Also if I try to start Afterburner after I started game, the game crashes back to desktop.Some clues about what is causing this would be appreciated:).

    PS! It seems that this problem somehow only is current in WD. Far Cry 3 and Far Cry Blood Dragon(both games bought on Steam) does not have any problems with steam/uplay overlays with Afterburner active.
     
    Last edited: Jun 1, 2014

  11. ZebMacahan

    ZebMacahan Master Guru

    Messages:
    233
    Likes Received:
    4
    GPU:
    ASUS rog strix 3080
    SOLVED! Tried to uninstall and reinstall Afterburner. This time both overlays work when playing WD. Not sure what was the case before...
     
  12. psychic717

    psychic717 Member

    Messages:
    32
    Likes Received:
    6
    GPU:
    MSI 1070 Gaming X
    I can't have any overlay enabled with Watch Dogs. Not steam nor uplay.
    I've tired to make a profile for the game and choose "Custom Direct3D support", but the game crashes just after launch.
    I also tried to uninstall and install MSI Afterburner and still can't have overlays.

    If I disable AB, both work fine...
     

Share This Page