valorant and gpu clock problem

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ReK!eN, Dec 3, 2022.

  1. ReK!eN

    ReK!eN Member

    Messages:
    11
    Likes Received:
    0
    hello to all
    i have problems with my rx 6600, it works great in different games but the valorant i am not able to force high clocks while playing.

    I have enabled the game tuning prefix for valorant and i force the minimum clock speed to 2000MHz but it does not stay at that speed, the speed stays at 300MHz most of the time and although i have stable fps i notice stuttering.

    i have tried to force the clock in other games and it seems to respect it but if i limit the fps in those games, for example to 20 fps so that the gpu usage drops then the clocks relax and drop to below the minimum i have set.

    I have done this as a test, in valorant I have limited the fps to 144.

    does anyone know how I can fix it?
    by the way i am not English i hope i have explained myself correctly

    [​IMG]
     
  2. z8373767

    z8373767 Master Guru

    Messages:
    347
    Likes Received:
    160
    GPU:
    6900XT/8650G+7970M
    Turn on MSAA x4. This should prevent downclock, but im pretty sure those stutters are not related to GPU Clock.
    More for shader compilation (UE4 likes it) or too high polling rate set for mouse.
     
  3. ReK!eN

    ReK!eN Member

    Messages:
    11
    Likes Received:
    0
    thanks for your reply

    I have tried with kovaaks and it seems to work fine, the frequency stays at least where I have set it in the profile.

    the stuttering is more like a sensation, it is not very abrupt, it is as if it was not fluid, especially I notice it when the frequency drops to 100MHz, although sometimes if there has been a strong pull that fits more with the compilation of shaders.

    I realize that valorant barely loads my gpu, it only uses between 10-15% of the gpu, as you say, I will try to increase the graphic options, it's a good idea.
     
  4. ReK!eN

    ReK!eN Member

    Messages:
    11
    Likes Received:
    0
    well, I think I solved it using mpo
    in feature control I have disabled the "ds" states, I have tried to play and finally, the clock doesn't drop, it stays and the performance problems disappear, but not everything is good, now I comment it.

    I want to try just disabling ds_gfxclk, I think that might be enough.

    I will try to explain it, I apologize if it is not well understood, I am not English speaking.

    if i set in the valorant profile for example, that the minimum frequency is 1200MHz, when i finish playing and go to the desktop, the clocks relax and fall to 0, but now when some app like chrome, demand a little gpu, my clock hits 1200MHz which is the value that i force for valorant and this value is saved, even when i restart the pc.

    to solve it i have to create a global profile and force the minimum frequency there, on my gpu it is 500MHz, apply it and then hit reset global profile, so on desktop, light apps when they demand a little gpu, it hits at 500 instead of 1200, i have to try to change this value in mpo.

    I am very annoyed that after researching this problem, I found comments dated 2020, and now that we are almost in the year 2023 the problem persists. Amd has no knowledge of this, or cares very little about it? so I have to be making juggling with drivers and options to get performance in games, with how easy it would be to include these options in the game profile settings, with a high performance mode as nvidia, or simply respect the minimum frequency value that I set.
     
    Last edited: Dec 4, 2022

  5. Banana4Nanners

    Banana4Nanners Master Guru

    Messages:
    252
    Likes Received:
    72
    GPU:
    6800XT
    Ds stands for deep state sleep. Yes AMD knows about it, it's a power saving feature and because you are barely loading the GPU you are triggering ULPS hence the low clocks, it's not a card problem it's the game/ your settings. Disable ULPS and move on

    also it really does not matter if you are hitting 1200mhz in chrome if it's using the GPU, setting it to 500mhz you aren't saving yourself anything and those cards don't run hot enough to bother with. Card auto down clocks on its own based on usage even if you set it to 2000mhz, it running at 1200 means you are putting a load on the GPU
     
  6. ReK!eN

    ReK!eN Member

    Messages:
    11
    Likes Received:
    0
    I tried disabling ulps but it didn't work, I also tried unchecking only ds_gfxclk and it is enough, the rest is not necessary to uncheck them.

    the error I mentioned, where the clocks were stuck, does not always happen, it can be corrected by logging in and out of the game or even resetting the global prefix.

    also with mpt, i have lowered the minimum gpu frequency to 100Mhz, now apps like chrome don't use 500Mhz continuously, only if they need it, they use more power.

    when you say it's the game's problem and not amd's i disagree, because as i mentioned, i'm using a custom prefix where i force the gpu to be stuck at a minimum frequency, yet DS has priority and ignores my settings, it's amd's bug

    in nvidia if i set my gpu to max performance, nvidia respects that setting at all times. it would be a good idea for everyone to send in reports, describing that behavior, i sent in a report a few days ago.
     
  7. Banana4Nanners

    Banana4Nanners Master Guru

    Messages:
    252
    Likes Received:
    72
    GPU:
    6800XT
    Didn't work because you have to actually disable all of the DS states for ULPS to no longer function.
     

Share This Page